[Manual intervention required] Package conflict between pipewire-media-session & wireplumber

Thank you for that! I am new to Linux and love Garuda Linux, thanks for all you all do and keep up the great work!!

Typical, when the conflict appeared a couple days ago, I went for removing wireplumber.
-Rdd pipewire-media-session then installing wireplumber appears to have worked for me to switch.

Props on the quick announcement, though in an ideal world, would have announcement prior to conflict arising.

Oh i see... @librewish made a typo in the script >.>

3 Likes

All fixed now, sorry about that everyone!

2 Likes

Followed the instructions and all seems well except for my nvidia audio out. That option is no longer available after a reboot. I both a restart and then a hard reboot to be sure it would have to find the monitor again but so far while it sees the monitor and nvidia reports the dp has audio the sound settings do not have it as an available option. Any suggestions?

Update: for the first time ever our garuda-hotfixes package is being used! Thanks to @TNE this will prompt everyone to apply the fix automatically, so no more intervention is needed if garuda-system-maintenance is installed (which is pretty much every installation that happened after July). If you don't have it installed yet, I'd suggest to do it anyways as it'll reduce the amount of maintenance needed in situations like this :wink:

7 Likes

image
:eyes:

7 Likes

found it..... just needed to dig a bit deeper it is there just disabled by default so simply go into sound settings and display disabled and hit enable and you should be good.

So the issue of it not working automatically is fixed and wasn't sure weird thing only my install was doing right? I ask cuz lately I'm getting alot of write issues and don't know if it's just me :joy:

can confirm.

Garuda System Maintenance - Hotfix Available popup notification displayed on my machine/monitor maybe 15-20 min ago. Accepted hotfix and then updated via Garuda Assistant without incident.

Thanks to everyone involved in making this and other conflicts like it a seamless/painless process!

3 Likes

I may have spoken a tad too soon on the "without incident" part, as it would appear after a system restart that it lacks audio but i see that was also the case for @zoeruda and they were able to fix it so here I go... I'll report back

Update - I've got audio back so all good there (after after removing pulseaudio and the resetting pulseaudio-ctl configs via Garuda assistant).

Question - it seems all of my volume control panel widgets relied on pulseaudio to work and without it, they have ceased to function. I downloaded a program called EasyEffects to control audio in the meantime but despite its name, there is no way to access its controls via the panel/widget so it's anything but easy in terms of adjusting audio levels on the fly. Works great otherwise, though and actually has a lot of awesome plugins for the audiophiles among you. Anyone have any suggestions or solutions you've found for use on your own system?

I just did the Hotfix and then used the command line "update" command. Rebooted and no issues so far (sound works fine for me). Very cool with the Garuda System Maintenance. I will say I was suspicious of the pop-up at first, so came here to make sure it was legit.

A post was split to a new topic: Transaction could not be completed (conflicting files)

The "hotfix" disabled my audio. The pulseaudio config probably got reset, which is why I lost my audio device and pulse tries to use HDMI as the audio source.

So if you had modified your pulseaudio config, make those modifications again and it should be like it was. Probably, what do I know. I have to disable the HDMI and set the new default device to see how it works.

i'm new here, pardon my mistakes.

yesterday i was prompted with the hotfix which i applied, but after a reboot both my audio and video doesn't work. i didn't run the update command after applying the hotfix, neither did i update the system via sudo pacman -Syu (right now i don't have enough data to perform full system update). i read some comments on this thread citing the same issue but i didn't understand how they fixed it. what should i do now?

UPDATE: after a full system update using sudo pacman -Syu everything works fine.

So, no more "pipewire-media-session" and welcome "wireplumber"? Is this?

Hm, this really shouldn't break pulse audio. All it does is replace pipewire media session with wireplumber.... Hm. Is your system otherwise fully up to date?

1 Like

In my case i also had no more audio after the hotfix.

pulseaudio Failed to load module "module-alsa-card"

Removed pulseaudio and installed pipewire-pulse. Now everything is working fine.

2 Likes

Apparently I am on one of the newer versions of Garuda Update? Assuming this since I was prompted for the hotfix yesterday. I first installed Garuda in January, assuming normal updates is what updated it.

I did run the hotfix and then updated. I had no issues and sound is working fine after a reboot. In fact I was surprised as how smooth it went since it had been 36 days since my last update and reboot.

As always, thanks dev team for your work!

4 Likes

Yep, up to date. I think it somehow reset my preferences. I've since applied the fixes suggested here and reconfigured pulse with pavucontrol. Seems to be working as it should. But for some reason I got the hotfix notification again just an hour ago. Is there another fix that we should be awere of?