Make dragonized more blue πŸ˜‰

I can't in the moment, so feel free to open an issue :smiley:

1 Like

Created a Issue :rofl:

1 Like

Maybe gitlab need some time for upload??

Not the best code but it works for me :slight_smile:

Summary

Hello my friend :slight_smile: ,

it works here,

./make-dragonized-blue
[sudo] Passwort fΓΌr sgs:
Done

File in /home/sgs/.kde4/share/apps/color-schemes/SGSblue.colors change date and time.
Files in /usr/share/themes/Sweet-Dark/gtk-3.0/ too.
Running as root (su) give me "This script must be not run as root"

3 Likes

I created a merge request to replace /home/$USER/ to ~

This is supposed to solve this issue

Warning :warning: I have not tested the script. Please make sure to test it before merging.

1 Like

Nothing will be merged, private hack to show what is possible :slight_smile: and which colors I like.

So, more than three like it :smiley: . So we can use a secure way with

*.css
*.colors

files to let the users chose what they like. :blush:

5 Likes

I tried but its not working.
First it says this

cp: cannot stat '/usr/share/themes/Sweet-dark': No such file or directory

and after changed the name to Sweet-Dark which is actually in themes folder then it says this

-r not specified; omitting directory '/usr/share/themes/Sweet-Dark'

1 Like

Sorry, its not perfekt :slight_smile:
Try

sudo cp -R /usr/share/themes/Sweet-Dark ~/.local/share/themes/

After there are many ways and I had it working on my computers, I didn't test it further, thanks for pointing it out.

4 Likes

I wil try and give you feedback​:grin:
Thank you for your response​:heart:

Now it says
cp: cannot create regular file '/home/linux/.local/share/themes/Sweet-Dark/gtk-3.0/gtk.css': No such file or directory

When I created a directory of .themes in home it says this

> cp: cannot create regular file '/home/linux/.local/share/themes/Sweet-Dark/gtk-3.0/gtk.css': Permission denied

╭─[email protected] in repo: make-dragonized-blue on  master
[πŸ”΄] Γ— ./make-dragonized-blue
cp: cannot create regular file '/home/chris/.local/share/themes/Sweet-Dark/gtk-3.0/gtk.css': Permission denied

╭─[email protected] in repo: make-dragonized-blue on  master took 29ms
[πŸ”΄] Γ— sudo ./make-dragonized-blue
This script must be not run as root

Help? New to linux , don't really know stuff

1 Like
# root files in ~/ !!!
sudo chown -R $USER: $HOME
~~~
3 Likes

No sudo ! :slight_smile:

2 Likes

Here is the code


# Check if the current user is not "root"


if [[ $UID == 0 ]]; then
   echo "This script must be not run as root" 1>&2
 exit 1
fi

cp ~/make-dragonized-blue/sweet-blue.colors ~/.kde4/share/apps/color-schemes/sweet-blue.colors

sudo cp -R /usr/share/themes/Sweet-Dark ~/.local/share/themes/

cp ~/make-dragonized-blue/gtk-dark-blue.css ~/.local/share/themes/Sweet-Dark/gtk-3.0/gtk.css

# root files in ~/ !!!
sudo chown -R $USER: $HOME

I edited as you suggested and the output is this.

[sudo] password for linux:
cp: cannot create regular file '/home/linux/.local/share/themes/Sweet-Dark/gtk-3.0/gtk.css': Permission denied

Edit:
I just manually input these three commands in the terminal

cp ~/make-dragonized-blue/sweet-blue.colors ~/.kde4/share/apps/color-schemes/sweet-blue.colors

sudo cp -R /usr/share/themes/Sweet-Dark ~/.local/share/themes/

sudo cp ~/make-dragonized-blue/gtk-dark-blue.css ~/.local/share/themes/Sweet-Dark/gtk-3.0/gtk.css

I got the color theme applied and reboot.
But I didn't find any difference. It was same color theme as sweetified-blue. Applications like firefox still have that bright pinkish color.
May I know if i could change that into a different color?

1 Like

Please post output as text

find $HOME ! -user $USER -type f

If you got some files do

2 Likes

Hi I edited the post please re-read again.
:slightly_smiling_face:

If you open dolphin the pink highlighted must be blue.
Firefox etc. you must change the themes too..

I can't check, in moment I am on i3wm :slight_smile:

Moment.

1 Like

After that check and do

Highlights in dolphin is still pink .
I disabled the sweet theme in firefox but the highlights are same .

Did you check

system settings, Appearance, Global Theme, Colors - applay sSweet-blue or the one you like?

You can edit there also Sweet or Sweetified to your liking.

As I wrote before, I am not a programmer and I use 80 % i3wm, so I am now out of knowledge.

1 Like

I selected that and settings was blue but it didn't applied to everywhere.