MacBook Pro not booting up with power button

Hello Garuda Team!

First of all, thank you for such an awesome distro! I have installed it on my MacBook Pro 12,1 (Early 2015 I suppose) and it worked right out of the box. I especially loved the touchpad gestures native support. In a way, it saved my laptop from finding it's place in landfill (more details below).

So before install Garuda, my MacBook Pro's original battery got dead after years of use and I replaced it. Right after replacing the battery, I pushed the power button and my laptop booted just as fine with Monterey on it. However, after it got discharged completely and shutdown, my laptop refused to recognize the battery and boot on it (even when I placed my laptop on charge for hours - with the amber light turning to green on the power plug). However, after I unplugged the battery, and plugged in the power source, my laptop booted (but with throttled CPU to 800 MHz - I suppose) and when I hot plugged the battery it recognized it. But as soon as the battery discharged with my laptop not on power, it refused to boot up. So the only way I could use my laptop was to remove the back-case, unplug the battery, connect the power cable to my laptop, hot plug the battery, and screw up the back-case again... well.. this is too much to ask of me.

So I thought of erasing the Mac OS altogether and try my luck with Linux. Found Garuda Linux, fell in love with its beauty and simplicity, and one fine day, installed it on my MacBook Pro with no hiccups. Fortunately to my surprise, it at least boots when I plug-in the power cable to my Mac with the battery still plugged in, the no more removing and screwing the back-case. Yay! However, it doesn't boot when power button is pressed -- irrespective of the power cable plugged in or not.

When my laptop on Mac OS, I had tried all the suggestions I searched for, including the SMC reset etc., but nothing worked. With Linux on my laptop now, I got these two source: Battery only detected if AC power connected at bootup / Laptop Issues / Arch Linux Forums and Can't boot when not plugged into AC power - Linux Mint Forums. First one is quite old -- also not exactly the same issue (I can see the battery getting charged on Garuda Linux) and second one is on HP laptop with Linux Mint (didn't bother to read further). One may as well think that the power button has gone non-functional, but I would like to think otherwise as it worked on Mac OS when I replaced the battery for the first time (although not worked later on).

As suggested, here's the garuda-inxi output:

System:
Kernel: 6.0.5-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3b9186f6-a3ee-4548-95dc-048a2804b985 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=1dc61dfb-3521-41db-b272-be8214602c50 loglevel=3
Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Apple product: MacBookPro12,1 v: 1.0
serial: <superuser required> Chassis: type: 9 v: Mac-E43C1C25D4880AD6
serial: <superuser required>
Mobo: Apple model: Mac-E43C1C25D4880AD6 v: MacBookPro12,1
serial: <superuser required> UEFI: Apple v: 430.140.3.0.0 date: 04/18/2022
Battery:
ID-1: BAT0 charge: 38.6 Wh (52.4%) condition: 73.6/72.3 Wh (101.8%)
volts: 11.6 min: 11.3 model: ifixit bq20z451 type: Li-ion serial: N/A
status: charging cycles: 27
CPU:
Info: model: Intel Core i5-5257U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1700 high: 3100 min/max: 500/3100 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 3100 2: 500 3: 500
4: 2700 bogomips: 21598
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Iris Graphics 6100 vendor: Apple driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:162b
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1600 s-dpi: 168 s-size: 387x241mm (15.24x9.49")
s-diag: 456mm (17.95")
Monitor-1: eDP-1 model: Apple Color LCD built: 2013 res: 2560x1600 hz: 60
dpi: 227 gamma: 1.2 size: 286x179mm (11.26x7.05") diag: 337mm (13.3")
ratio: 16:10 modes: 2560x1600
OpenGL: renderer: Mesa Intel Iris Graphics 6100 (BDW GT3) v: 4.6 Mesa
22.2.1 direct render: Yes
Audio:
Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
Sound API: ALSA v: k6.0.5-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple
driver: brcmfmac v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 14e4:43ba class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Bluetooth:
Device-1: Apple Bluetooth Host Controller type: USB
driver: btusb,hid-generic,usbhid bus-ID: 1-3:2 chip-ID: 05ac:8290
class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: N/A
Drives:
Local Storage: total: 233.76 GiB used: 15.75 GiB (6.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0256G
size: 233.76 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: SSD serial: <filter> rev: SA0Q scheme: GPT
Partition:
ID-1: / raw-size: 224.66 GiB size: 224.66 GiB (100.00%) used: 15.75 GiB
(7.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 652 KiB
(0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 224.66 GiB size: 224.66 GiB (100.00%) used: 15.75
GiB (7.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 224.66 GiB size: 224.66 GiB (100.00%) used: 15.75
GiB (7.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 224.66 GiB size: 224.66 GiB (100.00%) used: 15.75
GiB (7.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
System Temperatures: cpu: 62.0 C pch: 58.5 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 220 Uptime: 29m wakeups: 2 Memory: 7.67 GiB used: 3.71 GiB
(48.4%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1228 libs: 304
tools: octopi,paru,yaourt Shell: Zsh v: 5.9 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.22
Garuda (2.6.9-1):
System install date:     2022-10-09
Last full system update: 2022-10-29
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

Looking forward to some suggestions here to help me boot my laptop with the power button, and not just plugging in the power cable. Or is my laptop a gone case :sweat_smile:? If any more info is needed, please let me know! Thank you for taking the time to read it!

It does sound like this has stopped working normally somehow, as opposed to hardware that isn't supported by Linux. This thread details quite a bit of troubleshooting that has gone into getting various bits of the laptop working, and it seems like no one has the same issue with the power button: Macbook Pro Late 2013 Retina / Laptop Issues / Arch Linux Forums

The power button is mentioned in this device's ArchWiki entry (User:Elinux/MacBook Pro 12,1 - ArchWiki), however it is in the context of changing what the power button does when pressed--not getting it working in the first place.

I have to wonder if the connection was disturbed with all the opening and closing of the case/plugging and unplugging of the battery. You may be tired of opening up the case by now, but it might be worth examining the connection of the power button to the motherboard. Double-check the connection is well-seated. Try disconnecting and reconnecting, if the connection is not a solder.

8 Likes

Thank you @BluishHumility for looking into my post and the links you shared! I followed your suggestion and investigated a bit more at the hardware level. The conclusive part of my search is - most likely the "always on" power rail which communicates the signal from the power button to the SMC (probably) has gone faulty or just the power button on the keyboard has gone faulty. The power button sends signal through the 30 or 40 pin cable from the keyboard, and rest of the keys work fine, jut not the power button, therefore high chances the power button is dead (I even tried to disconnect and reconnect the keyboard cable as you suggested).

Found few videos on YouTube talking about unplugging the trackpad cable (one or both the ends) and then pressing the power button to check if the trackpad cable is faulty, but seems like no; the trackpad works great. Came across this: Power button doesn't work - MacBook Pro 13" Retina Display Early 2015 - iFixit where a suggestion was to attempt powering on with the power-on pads: Macbook Pro 2013 2014 2015 power pads - YouTube . Tried this and it worked (with just the battery plugged in and no power source), which again implies that the power button on the keyboard maybe the culprit.

For now, I am leaving my laptop as is, a bit hesitant to tinker more and end up blowing some part of the circuit. What baffles me is that when I first replaced the battery with a new one, screwed up the back case, and pressed the power button it worked like charm! Only when the new battery got drained for the first time, the power button stopped working. Had the power button to go faulty while replacing the battery, it wouldn't have worked the first time when I powered on after the replacement. Did the power rail get fried up due to non-Apple authorized battery? Who knows.. but if Linux on Apple H/W works, you leave it alone. For now I will be content with booting my laptop directly through plugging the power cable in. At least I get to use my system.

Thank you for your time!

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.