MacBook Keyboard problem after update

Hello. Keyboard problem after update. Only numbers work instead of letters. MacBook 4.1 2008. Please tell me how to solve the issue. Thanks.

garuda-inxi:


System:
  Kernel: 5.16.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=d589b821-530f-4a1f-8865-1926e3117901 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=71f2e536-1730-4423-a486-8da00bd3ce32 loglevel=3
  Desktop: GNOME v: 41.5 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 41.3
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Unknown System: Apple product: MacBook4,1 v: 1.0
    serial: <superuser required> Chassis: type: 2 v: Mac-F22788A9
    serial: <superuser required>
  Mobo: Apple model: Mac-F22788A9 v: PVT serial: <superuser required>
    UEFI: Apple v: MB41.88Z.00C1.B00.0802091535 date: 02/09/08
Battery:
  ID-1: BAT0 charge: 15.1 Wh (87.8%) condition: 17.2/45.4 Wh (37.9%)
    volts: 12.3 min: 10.8 model: SONY ASMB013 type: Li-ion serial: N/A
    status: full cycles: 52
CPU:
  Info: model: Intel Core2 Duo T8100 bits: 64 type: MCP arch: Core Yorkfield
    family: 6 model-id: 0x17 (23) stepping: 6 microcode: 0x60F
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 926 high: 1055 min/max: 800/2100 scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 1055 2: 798
    bogomips: 8379
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Mobile GM965/GL960 Integrated Graphics vendor: Apple
    driver: i915 v: kernel ports: active: LVDS-1 empty: DVI-D-1,SVIDEO-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:2a02 class-ID: 0300
  Display: x11 server: X.Org v: 1.21.1.3 compositor: gnome-shell driver: X:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa gpu: i915
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
    s-diag: 398mm (15.69")
  Monitor-1: LVDS-1 mapped: LVDS1 model: Apple 0x9c5f built: 2006
    res: 1280x800 hz: 60 dpi: 112 gamma: 1.2 size: 290x180mm (11.42x7.09")
    diag: 337mm (13.3") ratio: 16:10 modes: 1280x800
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 82801H HD Audio vendor: Apple driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:284b class-ID: 0403
  Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Broadcom BCM4321 802.11a/b/g/n vendor: Apple AirPort Extreme
    driver: wl v: kernel modules: ssb pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 02:00.0 chip-ID: 14e4:4328 class-ID: 0280
  IF: wls4 state: up mac: <filter>
  Device-2: Marvell 88E8058 PCI-E Gigabit Ethernet driver: sky2 v: 1.30
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 5000 bus-ID: 03:00.0
    chip-ID: 11ab:436a class-ID: 0200
  IF: ens5 state: down mac: <filter>
Bluetooth:
  Device-1: Apple Bluetooth HCI type: USB driver: btusb v: 0.8 bus-ID: 3-1:3
    chip-ID: 05ac:8205 class-ID: fe01
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 111.79 GiB used: 10.24 GiB (9.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Patriot model: Burst size: 111.79 GiB
    block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s type: SSD
    serial: <filter> rev: 61.3 scheme: GPT
Partition:
ID-1: / raw-size: 103.11 GiB size: 103.11 GiB (100.00%)
    used: 10.24 GiB (9.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 103.11 GiB size: 103.11 GiB (100.00%)
    used: 10.24 GiB (9.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 103.11 GiB size: 103.11 GiB (100.00%)
    used: 10.24 GiB (9.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 103.11 GiB size: 103.11 GiB (100.00%)
    used: 10.24 GiB (9.9%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.39 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
  ID-2: swap-2 type: zram size: 3.81 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 65.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 205 Uptime: 7m wakeups: 3 Memory: 3.81 GiB
  used: 1.18 GiB (31.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 1079 lib: 299 Shell: fish v: 3.3.1
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.14
Garuda (2.5.6-2):
  System install date:     2022-03-24
  Last full system update: 2022-03-25
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

Maybe you could try to give a look at /var/log/pacman.log If there was an update on a package which might be related.
Then, after confirming "upstream" if there is a bug, you could (e.g.) restore the last working snapshot and update blocking that package.

Edit: Are you really sure that is really happened after an update?
At a quick inernet search I've found this problem to be often associated to Num Lock key mistakenly pressed, which might turn some letters into numbers.
If the keyboard doesn't have a NumLock key, there could be some other way to set it.
It's also worth checking in the Gnome keyboard setup / layout.

2 Likes

Thanks for the quick response. I'm new and don't know much about OS. I found the pacman.log file. But I don't understand any of this, unfortunately.

I also read about numlock, but the tips did not work. By the way, when it goes to sleep, the keyboard while I type the password. How to log in - does not work.

P.S.
Just after the update. Checked several times. Reinstalled the system. Used without updating - everything works. rebooted the system without updating - the keyboard works. As soon as a full update, reboot and the keyboard does not work.

Normally I use (from terminal) something like:

cat /var/log/pacman.log | grep '2022-03-25' | egrep 'installed|upgraded|removed'

but in your case, since you reinstalled, there could be too much stuff... Maybe checking the time could help.
PS1: Welcome!
PS2: Please include your garuda-inxi in the first post (or terminal text in general like this, for better formatting:
~~~
text
~~~

1 Like

Resolved the issue. it turned out to be numLock.
but I had to connect usb-kpd and disable numLock on it. After a reboot everything works well. For now. I will follow.

2 Likes

@VladK85 glad it worked out! Could you plz select either filo's post about NumLock or yours (last one) and mark it as the solution? This way if anyone else is searching for this annoying issue he/she will know quickly it has been solved. :smiley:

EDIT: I also took the liberty to edit your topic's subject and add "Macbook" so it will be clearer again if anyone searches for "macbook keyboard" or something similar.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.