Lxqt-kwin fails at first and after update

Hello!

The installation completes successfully. The new system boots ok . It connects to the internet. All good. However setup-assistant fails with "Update failed". This is happening with a fresh install, right after my first boot. Any subsequent attempt yields the same problem. I tested on different macbooks pro. Same result.
Any help would be really appreciated. Thanks!

System:
  Kernel: 5.19.7-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=c7e8e3b2-c31b-467d-b82f-b7d5c4e28bea rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=35a61ea2-668c-47e9-8628-5f1a381dae64 loglevel=3
  Desktop: LXQt v: 1.1.0 tk: Qt v: 5.15.6 info: cairo-dock, lxqt-panel
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: Apple product: MacBookPro8,1 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-94245B3640C91C81
    serial: <superuser required>
  Mobo: Apple model: Mac-94245B3640C91C81 v: MacBookPro8,1
    serial: <superuser required> UEFI: Apple v: 87.0.0.0.0 date: 06/13/2019
Battery:
  ID-1: BAT0 charge: 42.1 Wh (98.1%) condition: 42.9/54.5 Wh (78.8%)
    volts: 12.4 min: 10.9 model: DP bq20z451 type: Li-ion serial: N/A
    status: charging cycles: 302
CPU:
  Info: model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 798 high: 800 min/max: 800/3400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 798 3: 798
    4: 798 bogomips: 21549
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Apple driver: i915 v: kernel arch: Gen-6 process: Intel 32nm
    built: 2011 ports: active: LVDS-1 empty: DP-1, DP-2, DP-3, HDMI-A-1,
    HDMI-A-2, HDMI-A-3, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0126
    class-ID: 0300
  Device-2: Apple FaceTime HD Camera type: USB driver: uvcvideo
    bus-ID: 1-2:3 chip-ID: 05ac:8509 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
    s-diag: 398mm (15.69")
  Monitor-1: LVDS-1 model: Apple 0x9ccb serial: <filter> built: 2009
    res: 1280x800 hz: 60 dpi: 114 gamma: 1.2 size: 286x179mm (11.26x7.05")
    diag: 337mm (13.3") ratio: 16:10 modes: 1280x800
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.19.7-zen2-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0
    chip-ID: 14e4:16b4 class-ID: 0200
  IF: enp2s0f0 state: down mac: <filter>
  Device-2: Broadcom BCM4331 802.11a/b/g/n vendor: Apple AirPort Extreme
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 14e4:4331 class-ID: 0280
  IF: wlp3s0 state: dormant mac: <filter>
  Device-3: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc
    bus-ID: 1-1.3:6 chip-ID: 0cf3:9271 class-ID: ff00 serial: <filter>
  IF: wlp0s26f7u1u3 state: up mac: <filter>
Bluetooth:
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 1-1.1.3:9 chip-ID: 05ac:821a class-ID: fe01
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 354.07 GiB used: 6.89 GiB (1.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Lexar model: 256GB SSD
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 117D scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Kingston
    model: DataTraveler 3.0 size: 115.59 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 229.37 GiB size: 229.37 GiB (100.00%) used: 6.89 GiB
    (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 608 KiB
    (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 229.37 GiB size: 229.37 GiB (100.00%) used: 6.89
    GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 229.37 GiB size: 229.37 GiB (100.00%) used: 6.89
    GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 229.37 GiB size: 229.37 GiB (100.00%) used: 6.89
    GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.68 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 68.0 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 235 Uptime: 4m wakeups: 2 Memory: 7.68 GiB used: 1.8 GiB (23.5%)
  Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 Packages: pacman: 1154 lib: 305 Shell: fish v: 3.5.1
  default: Bash v: 5.1.16 running-in: qterminal inxi: 3.3.20
Garuda (2.6.7-1):
  System install date:     2022-10-02
  Last full system update: 2022-10-02
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:  

Just use ~~~ on first and last line, not million - :wink:

Working fine here on i3wm.

Try

garuda-update

in terminal.


Thank you!
That worked. The system was updated successfully.

However if i try again setup-assistant it fails as before. I think it's a handy tool as it guides the new user to install proprietary drivers and/or applications suites of interest. Although I can install applications with octopi/pacman ... it would be great if that could be made functional again in a future release. I think it works on all other flavors of Garuda I've tried.

Nonetheless you've been very helpful. And sorry for not inserting the code properly in my initial post, I will do a better job next time :wink:

1 Like

Sad, ok, I move it to #issues-assistance:lxqt

BTW, did you reboot your PC? :slight_smile:

Sadly the issue persists also when rebooting after launching garuda-update.

Thanks again!

I have the same issue with lxqt-kwin. I believe this also happens with cinnamon.

You should able to update your system with garuda-update. After that you can install everything else with add/remove software app (or pacman). That was my approach at least

Garuda recommends using only pacman/paru, pamac (add/remove software) is not recommended.

I can confirm this issue after installing garuda-lxqt-kwin-linux-zen-220909.iso just now.

The Setup Assistant launches, "Welcome to Garuda Linux!" and so on, but when you click "OK" it immediately fails:

I brought the system fully up to date and then ran the Setup Assistant again, but it still immediately fails.

Thinking back to this thread, I installed Alacritty and ran it again. Sure enough, it runs fine after Alacritty is installed.

I took another peek in /usr/lib/garuda/launch-terminal, and it looks like LXQt is supported terminal-wise:

terminal=""
declare -A terminals=( ["alacritty"]="alacritty -e $cmd || LIBGL_ALWAYS_SOFTWARE=1 alacritty -e $cmd" ["konsole"]="konsole -e $cmd" ["gnome-terminal"]="gnome-terminal --wait -- $cmd" ["xfce4-terminal"]="xfce4-terminal --disable-server --command '$cmd'" ["lxterminal"]="lxterminal -e $cmd" ["xterm"]="xterm -e $cmd" )
declare -a term_order=( "alacritty" "konsole" "gnome-terminal" "xfce4-terminal" "lxterminal" "xterm" )

if [ "$XDG_CURRENT_DESKTOP" == "KDE" ]; then
   terminal=konsole
elif [ "$XDG_CURRENT_DESKTOP" == "GNOME" ]; then
   terminal=gnome-terminal
elif [ "$XDG_CURRENT_DESKTOP" == "XFCE" ]; then
   terminal=xfce4-terminal
elif [ "$XDG_CURRENT_DESKTOP" == "LXQt" ]; then
   terminal=lxterminal
fi

:point_up: lxterminal, however, is not installed in garuda-lxqt-kwin-linux-zen-220909.iso. The default terminal is QTerminal.

5 Likes

Easy enough to fix after someone presenting the solution :yum: Good work @BluishHumility !

4 Likes

Interesting

Nice going on the quick fix!

I'm not sure if it matters, but it looks like there is still a lingering lxterminal on line 34 where the terminal order is announced :face_with_monocle::

declare -a term_order=("alacritty" "konsole" "gnome-terminal" "xfce4-terminal" "lxterminal" "xterm")

This is a little off-topic, but maybe if one of you guys has a chance you could figure out how to get mate-terminal on the list? :pleading_face:

It is the only terminal that the Mate spin ships with, so none of the tools that use launch-terminal work until Alacritty is installed. I couldn't figure out how the declare -A terminals= line needs to be handled for mate-terminal. :thinking:

1 Like

A bit more complicated to make mate-terminal work, it requires some special sauce (It doesn't seem to take arguments in the command? And it seems to run the binary directly instead of launching it in a shell? Fair enough.)

4 Likes

We've had similar issues in our eos-quickstart app and we solved it back then by installing xterm on every install :rofl:

Maybe we can use some of your code to add support for Qterminal and mate-termninal

That's... terrible. :stuck_out_tongue:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.