Lutris/Wine: Hearthstone/ crash on call to .NET (when they should not call it at all)


I'm new to Garuda, currently on Dragonized KDE. I have a few issues, and the one I want to describe here is about Hearthstone, the Blizzard Entertainment game.

Using lutris (but the same is true using wine-staging from the system), whenever the Blizzard launcher is started, then Hearthstone is started from the launcher, it crashes shortly after starting the game, before showing the title.

Here's the wine log: Ubuntu Pastebin

I've already asked around in the Lutris Discord (I'm a supporter), but nobody knows why Hearthstone would even be able to throw a .NET error, as the game does not use .NET.

Hearthstone worked before on my Manjaro machine, and other people tested the installation using the Lutris scripts for both Hearthstone and, and Hearthstone works fine from there.

My best guess now is that there's some strange magic going on with something inside Garuda that makes .NET a part of a normal wine process, but that's about the extent of my ideas.

Maybe anyone can shed light on that? Hearthstone isn't a complicated game, and running it seems pretty solved. I hope this is not a sign of things to come with regards to game compatibility.

Thank you.

I have relocated your help request to the Unofficially Supported Software sub-forum (where it more appropriately belongs).

Welcome to Garuda.

1 Like

Straight after posting this here, I find the solution:

Disabling the locationapi.dll seems to do the trick.


Also keep in mind that you're not using wine-staging from the repos:

002c:fixme:winediag:LdrInitializeThunk Wine TkG (staging) 6.0 is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please don't report bugs about it on and use instead.

That is correct, the log was created with the Lutris installer script selecting a wine version. I've tried with the wine-staging system version as well, and the problem was present there, too.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.