Lutris not starting

Hello ! Im new to Garuda And I really been enjoying it I think all the optimizations it comes with they help me alot with gaming on linux ,
I recently updated and I think lutris is broken I did all I think possible deleted all files related to it and still when I try to launch it , it loads for 1 or 2 secs and crashes doesnt open..

Post errors.

2 Likes

where do I see these errors ? im sorry for wasting time I am still a big noob ofc

Start the program from the terminal.

2 Likes

Traceback (most recent call last):
File "/usr/bin/lutris", line 52, in
from lutris.gui.application import Application # pylint: disable=no-name-in-module
File "/usr/lib/python3.9/site-packages/lutris/gui/application.py", line 41, in
from lutris.gui.installerwindow import InstallerWindow
File "/usr/lib/python3.9/site-packages/lutris/gui/installerwindow.py", line 17, in
from lutris.installer import interpreter
File "/usr/lib/python3.9/site-packages/lutris/installer/interpreter.py", line 14, in
from lutris.installer.installer import LutrisInstaller
File "/usr/lib/python3.9/site-packages/lutris/installer/installer.py", line 16, in
from lutris.services import get_services
File "/usr/lib/python3.9/site-packages/lutris/services/init.py", line 2, in
from lutris.services.gog import GOGService
File "/usr/lib/python3.9/site-packages/lutris/services/gog.py", line 9, in
from lxml import etree
ModuleNotFoundError: No module named 'lxml'

:open_mouth: this is it ?

1 Like

well I went to the software center and I installed python lxml package and I guess that fixed it but weird why this happened after update

3 Likes

Good stuff. :+1:

2 Likes

thx for the tip though to check in terminal ! :sweat_smile:

2 Likes

It looks like a packaging issue - Lutris picked up a new dependency (python-lxml) but the package maintainer didn't spot it and so it isn't yet a dependency of the package.

5 Likes

Hey this guide worked for me link

just install from aur

Hi there, welcome.
Thanks for sharing the link but, please, do not post on old topics.
Things might and should have changed after so many months.

4 Likes