Lutris Crash After Trying To add a locally installed game

Hello all, I have a fresh install of garuda linux . Today when trying to add a newly locally installed game to lutris. It crashed . When the add game popup appeared , I configured everything , game location , name everything .

As I cliked on save to complete adding ,my game , it crashed . I have not been able to reproduce it since . I do have to mention that as I started it , it gave a popup : checking for updates , updating icons then its interface appeared , Could it be that the update was completed at the time that caused it to crash ?

I am bothered as I am unsure if it indicates that my installation is broken . I have not had any other issues . Is this bothersome ?


Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=1a3d0a6e-7ed0-49ad-9764-325911ffd2cd rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Desktop System: HP product: HP All-in-One 22-df0xxx v: N/A
serial: <superuser required> Chassis: type: 13 serial: <superuser required>
Mobo: HP model: 87A4 v: 10100 serial: <superuser required> UEFI: AMI
v: F.36 date: 08/07/2023
Info: model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake
gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xBC
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 1024 KiB desc: 2x512 KiB
L3: 4 MiB desc: 1x4 MiB
Speed (MHz): avg: 923 high: 976 min/max: 400/3400 scaling:
driver: intel_pstate governor: powersave cores: 1: 964 2: 825 3: 976 4: 929
bogomips: 9523
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel Iris Plus Graphics G1 vendor: Hewlett-Packard driver: i915
v: kernel arch: Gen-11 process: Intel 10nm built: 2019-21 ports:
active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:8a56 class-ID: 0300
Device-2: Luxvisions Innotech HP TrueVision HD Camera driver: uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-10:6
chip-ID: 30c9:0013 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: HP ALL-in-One serial: <filter> built: 2019
res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2 size: 476x268mm (18.74x10.55")
diag: 546mm (21.5") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris x11: drv: iris
inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (ICL GT1)
device-ID: 8086:8a56 memory: 7.36 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu name: Intel
UHD Graphics (ICL GT1) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:8a56 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.84 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 4000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: rtw_8821ce v: N/A modules: rtw88_8821ce
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 02:00.0
chip-ID: 10ec:c821 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-1: Realtek Bluetooth 4.2 Adapter driver: btusb v: 0.8 type: USB
rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:5 chip-ID: 0bda:b00a
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: no pairing: no class-ID: 7c0104
Local Storage: total: 946.04 GiB used: 302.37 GiB (32.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10EZEX-60WN4A1 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
fw-rev: 1A03 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: Cruzer Blade
size: 14.53 GiB block-size: physical: 512 B logical: 512 B type: USB
rev: 2.1 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
fw-rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: 243.1 GiB size: 243.1 GiB (100.00%) used: 18.9 GiB (7.8%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 243.1 GiB size: 243.1 GiB (100.00%)
used: 18.9 GiB (7.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 243.1 GiB size: 243.1 GiB (100.00%)
used: 18.9 GiB (7.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 243.1 GiB size: 243.1 GiB (100.00%)
used: 18.9 GiB (7.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.53 GiB used: 338.2 MiB (4.4%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
System Temperatures: cpu: 50.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 220 Uptime: 4h 37m wakeups: 0 Memory: total: 8 GiB note: est.
available: 7.53 GiB used: 2.85 GiB (37.8%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1400 libs: 408 tools: pamac,paru Shell: fish v: 3.6.1
default: Bash v: 5.2.15 running-in: konsole inxi: 3.3.31
Garuda (2.6.17-1):
System install date:     2023-11-07
Last full system update: 2023-11-08
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

Had also an issue with Lutris. Program worked earlier today, but after a system update and restart it was broken. The program starts as it shows an icon, but window doesn’t appear and program closes. So I started Lutris from terminal and got following output:

Traceback (most recent call last):
  File "/usr/bin/lutris", line 57, in <module>
    from lutris.gui.application import Application  # pylint: disable=no-name-in-module
  File "/usr/lib/python3.11/site-packages/lutris/gui/", line 45, in <module>
    from lutris.gui.dialogs.delegates import LaunchUIDelegate, InstallUIDelegate, CommandLineUIDelegate
  File "/usr/lib/python3.11/site-packages/lutris/gui/dialogs/", line 9, in <module>
    from lutris.runners import wine
  File "/usr/lib/python3.11/site-packages/lutris/runners/", line 26, in <module>
    from import PEFILE_AVAILABLE, ExtractIcon
  File "/usr/lib/python3.11/site-packages/lutris/util/wine/", line 12, in <module>
    from PIL import Image
  File "/usr/lib/python3.11/site-packages/PIL/", line 82, in <module>
    from . import _imaging as core
ImportError: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden

Then I did a snapshot re-roll and Lutris worked as before.
So it points towards update issue to me.

i’m no software nerd, but on it’s face this looks like an upstream issue with certain python libraries that will more than likely be fixed in a future update.

don’t quote me though because i really have no idea >.>

Update again, it should be fixed.

1 Like

system upgrade or lutris ? I had the latest version installed . Well I have uninstalled the lutris from official repositories and installed lutris-git from AUR . This should fix the issue right ?

System upgrade, and no, no lutris-git is required.


Well, did a garuda-update but got following output:

error: failed retrieving file 'haskell-typed-process-' from : Recv failure: Connection reset by peer
error: failed retrieving file 'haskell-utf8-string-1.0.2-136-x86_64.pkg.tar.zst.sig' from : Send failure: Broken pipe
error: failed retrieving file 'haskell-base-compat-batteries-0.12.2-57-x86_64.pkg.tar.zst.sig' from : Send failure: Broken pipe
warning: too many errors from, skipping for the remainder of this transaction
error: failed retrieving file 'haskell-hslua-objectorientation-2.3.0-15-x86_64.pkg.tar.zst.sig' from : Send failure: Broken pipe
error: failed retrieving file 'haskell-crypton-x509-validation-1.6.12-11-x86_64.pkg.tar.zst' from : Send failure: Broken pipe
warning: failed to retrieve some files
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

So I started the Garuda Assistant and

  • updated mirror-list
  • updated keyrings
  • started garuda upate from assistant

That route finally worked. But why isn’t garuda-update doing the job it is intended to?

This was because of the dependent “libimagequant” which was updated this morning, just update your system and it should fix Lutris. This has happened many times in the past, so if you get these errors again, just wait it out and/or report it on the Lutris forum, it is an upstream thing.


I think the issue was with mirrorlists , after you had updated them manually , I think it fixzed the issue and running garuda-update from terminal would just have been fine , Dont quote me though, I am still a noob.

1 Like

can upgrading the system change wine config ?

one small question real quick , before system upgrade , desktop integration in wine for documents was enabled , but after update it was found disabled . Is this normal.

Don’t really understand your question. It should not break wine config.

1 Like

one small question real quick , before system upgrade , desktop integration in wine for documents was enabled , but after update it was found disabled . Is this normal.

About this

Separate issue from Lutris, but to answer your question, it should not. You could try reinstalling wine again to create the links, see if that fixes it.

1 Like

will try and let you know

no conclusion . The config is the exact same as before uninstalling after I reinstalled

I am not for sure. You can always reinstall everything; wine, lutris, etc. Also, are you using the wine-staging branch? That is usually what I use for gaming, no issues, symlink or otherwise.

no this issue is with wine ge lol in lutris as a runner . Till today before updating , the link to documents folder was there , after upgrade the config was changed to the links being only accessible for downloads and templates folder . Before upgrade , by default it was linked to each directory. Now for each wine version including wine staging the config seems to be changed.

Well, there is also reverting your system back in time with a backup. :man_shrugging:

my main concern is , if this is possibly indicating to a potential system instability.