LUKS - Correct passphrase not working!

Hi everyone!
I am having a hard time getting LUKS to work on this system. Everything during the install goes off without a hitch, until reboot.
Once I reboot, trying to get into my fresh installation, I can't get past LUKS passphrase. I am entering the correct password but LUKS will not unlock. After being thrown into emergency shell typing my password looks correct. What is going on here? I am using default us_en keyboard.

I have tried a fresh install several times now (4-5 times), each with the same end result.
I have also tried installing EndeavourOS as well, but I am met with the same issue. I cannot get past the LUKS passphrase.

A little frustrated! Any help would be greatly appreciated! :confounded:

edit: typos

2 Likes

I have tried searching online for some help before posting here.
I have checked the link that you screen shoot (would have been easier if you shared link), but there is no useful solution to this problem posted there. Am I missing something here?

Why is this even happening. I am using a standard keyboard layout (en_us).
Thanks for taking the time to help.

On what keyboard?

3 Likes

Its a QWERTY keyboard, all default settings (105Key QWERTY en_us)
I am going to try installing again, but this time using a passphrase with no symbols.

Anyone ever run into this issue before?
Any help would be appreciated <3

Sorry. I have nothing to hide, so I don't use LUKS. :wink:
</off topic>

1 Like

2 for 2 useless reply's.
1st reply not relevant to my problem.. You took the time to take a screenshot, save it, edit it and put a box highlight and then post. Rather then share the link like a normal human being.
2nd reply, is just -facepalm-

Not trying to disrespect you SGS, but your replies come off really arrogant and quite pointless, so why bother?

/end rant.

1 Like

Nope, I use Flameshot, mark the spots with it, put it in the clipboard and then paste that here. It's quicker than you think.

If you can't take a joke or go to the basement to laugh, you're probably in the wrong forum.

2 Likes

Status update...
Cleaned up drive and re-installed Garuda again.
Used a password with no symbols.
Everything completed correctly.

Same result! Correct password is rejected, throwing me into grub rescue. Typing password in grub rescue looks correct.

So now I have tried multiple passwords, with symbols and without.
One thing that strikes me as really unusual is that upon entering the password it takes almost a full minute before it rejects my password (that is CORRECT).
This machine is fairly fast, It should not take this long to figure out if the password is correct or not. I have never seen it take this long.

Anyone have a clue what the hell is going on here? Looking around on the net hasn't returned any useful info.

I can take a joke, I just don't get the point of taking a screenshot instead of posting a link... and if u clicked the link and read it you would realize that there is no useful info on how to fix this issue there (so my question remains WHY post it in the first place).

Anyways I am not looking to start a flame war, but you literally made me waste time replicating your search so I can find the result u posted, click it and read it... only to realize you didn't even bother reading what you posted.

try to luksOpen on live environment.
also is this a notebook? try an external keyboard if so.

edit: livecd are rare nowadays :laughing:

1 Like

I used the Garuda Live installer. Booted in, using Thunar I was able to decrypt the disc in question using the password in question.
I locked the drive again and tried to do open it again with luksOpen using:
sudo cryptsetup luksOpen /dev/sda sda1
also tried
sudo cryptsetup luksOpen /dev/sda sda2
and
sudo cryptsetup luksOpen /dev/sda sda
all returned: "Device /dev/sda is not a valid LUKS device."

looking at the output of lsblk I don't see "crypt" under type anywhere for sda.

Confusion intensifies, why is thunar able to decrypt it but I can't do it using luksOpen command.
W T F

If there is no typo on your reply you missed the partition number on command line
should be something like

cryptsetup luksOpen /dev/sdax cryptroot

where /dev/sdax is the luks partition with you root filesystem , if successful will create the /dev/mapper/cryptroot device.

What about external keyboard?

2 Likes

It has been a while since I had to mess with LUKS.
You are right the correct command was "cryptsetup luksOpen /dev/sda2 cryptroot". Resulted in correctly decrypting the drive.

This is a desktop machine, I am using a USB keyboard.
I have tried 2 USB keyboards, I have aloso tried using USB 2 ports USB 3 ports, in the front I/O and rear I/O.
Unfortunately those didn't do anything to help.

Any other ideas what is going on? Why does it take almost a full minute to tell me the password is incorrect.. This has to do something with what is going on.

I don't know how to further diagnose and trouble shoot this.

There are a lot of things that can be causing this issue - unfortunately.

  • check if encrypt is listed in HOOKS in /etc/mkinitcpio.conf - should be.
  • try to change to a very simple password with numbers only (not from keypad) , your have some reference here and here

for the last, I also have noticed that luksOpen now is taking a bit more of time with full disk encryption , if you have /boot not encrypted luksOpen will be noticed faster.

2 Likes

Thanks for the help perewa.

So i checked /etc/mkinitcpio.conf and encrypt is listed in HOOKS.
I set a silly password of 11223344 and I am able to decrypt the drive at boot... and get into the install.
:dizzy_face: This is going to be fun to fix lol.

I am going to burn the Garuda ISO to another USB drive and do another clean full install to this pc using a regular alphanumerical password, just to verify that the install media has not been corrupted, that USB drive is ancient!

Will report back in a moment..

1 Like

Fresh Verified ISO a different USB stick.
Same result.
LUKS password of #Password fails to work at boot.

grub rescue> _It's one of those days.

What can be causing this :dizzy_face:

Well, this sucks!
Just to re-hash what I have done so far:

  • Clean installed with desired password = FAILED
  • Clean installed again with desired password, double checking settings = FAILED
  • Clean installed with "#Password99" = FAILED
  • Clean installed with "Password99" = FAILED
  • Clean installed with "password99" = FAILED
  • Clean installed with "11223344" = SUCCESS
  • Verified ISO different USB drive. Clean installed with "password99"= FAILED
    (everything past this point is on new USB stick)
  • Tried using 2 different USB keyboards = FAILED
  • Tried plugging keyboard into FRONT I/O using USB-2 ports / then boot.= FAILED
  • Tried plugging keyboard into FRONT I/O using USB-3 ports / then boot.= FAILED
  • Tried plugging keyboard into REAR I/O using USB-2 ports / then boot.= FAILED
  • Tried plugging keyboard into REAR I/O using USB-3 ports / then boot. = FAILED
  • Clean installed with "password99" with CSM enabled = FAILED

Additional info:
After failing to decrypt landing in GRUB rescue, entering password looks correct, all characters are displayed correctly including symbols (ex: !@#$%^&*).
The only password that has worked has been purely numerical (listed above).

Can anyone help me try to solve this? I am running out of ideas, or steam to do this lol.

1 Like

I'm running out of ideas too :slight_smile:
but for me seems to be related to some BIOS issue,
maybe trying something with ALLCAPITAL letters.
also inxi -Fxxxza of a successful installation can help a lot...

good luck for now :slight_smile:

Then, I am pretty sure that something is wrong with keyboard layouts. It might happen that your keyboard is different while installation and typing password.

Also, I would suggest using onscreen keyboard, if possible.

Btw, you can also use numeric password like 35828012 (randomly generated).

1 Like