Low quality audio and audio tearing

I just migrated from windows 11 to garuda and the experience is great!
but I have issues with sound. Its the same type of problem with sound before installing realtek audio driver in windows. I saw on youtube and tried alsamixer but nothing changed. Thank you in advance!

System:
Kernel: 5.16.14-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ccb48291-187b-4c25-aeca-be33387526a5 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Gigabyte model: H310M H 2.0 v: x.x
serial: <superuser required> UEFI: American Megatrends v: F12
date: 08/13/2019
CPU:
Info: model: Intel Core i5-9400F bits: 64 type: MCP arch: Coffee Lake
family: 6 model-id: 0x9E (158) stepping: 0xD (13) microcode: 0xEC
Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
desc: 1x9 MiB
Speed (MHz): avg: 3811 high: 4001 min/max: 800/4100 scaling:
driver: intel_pstate governor: performance cores: 1: 3711 2: 4000 3: 4001
4: 4001 5: 3157 6: 4000 bogomips: 34798
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: TSX disabled
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Gigabyte driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 ports: active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0
chip-ID: 1002:67df class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: HDMI-A-0 mapped: HDMI-A-1 model: Acer QG221Q serial: <filter>
built: 2020 res: 1920x1080 dpi: 102 gamma: 1.2 size: 476x268mm (18.7x10.6")
diag: 546mm (21.5") ratio: 16:9 modes: max: 1920x1080 min: 720x400
OpenGL: renderer: AMD Radeon RX 570 Series (POLARIS10 DRM 3.44.0
5.16.14-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
class-ID: 0403
Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
vendor: Gigabyte driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
Sound Server-1: ALSA v: k5.16.14-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: anbox0 state: down mac: <filter>
Drives:
Local Storage: total: 689.33 GiB used: 17.83 GiB (2.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240BX500SSD1
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: R013 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500312CS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 5900 serial: <filter> rev: SC13 scheme: GPT
Partition:
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 17.83 GiB (8.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 17.83 GiB (8.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 17.83 GiB (8.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 17.83 GiB (8.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.57 GiB used: 2.2 MiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 27.8 C mobo: 16.8 C gpu: amdgpu temp: 47.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 806
Info:
Processes: 305 Uptime: 35m wakeups: 0 Memory: 15.57 GiB
used: 3.8 GiB (24.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1780 lib: 524 flatpak: 0 Shell: fish v: 3.3.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date:     2022-03-14
Last full system update: 2022-03-14
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:            bluetooth-autoconnect.service

If you include terminal outputs in your post please use the proper output format in your post.

Using "~" 3 times above and "~" 3 times below the text block will provide a readable, raw look.

Please edit your post and

:slight_smile:

changed it and thanks

1 Like

Is this one of those "fancy" sound systems that uses special drivers to run the speakers in a non-standard way?

no just a typical headphone

I didn't make myself clear; let me try again.

You said that you had the same "low quality audio" under Windows until you installed a specific driver. This probably means the audio chip doesn't use a standard driver codec (like AC97 or whatever). Therefore, if it needs a specific Windows driver to work correctly then it won't work correctly under Linux which doesn't have that Windows driver.

It doesn't matter what you plug into the audio jack if the audio chip isn't running correctly.

Or, are you saying that this problem only occurs with a specific set of headphones?

3 Likes

this is my audio device-

Audio:
Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
class-ID: 0403

and I mean, after installing windows, I went to the motherboard site and downloaded the driver
not sure if I make any sense at all

I am not surprised that this did not turn out to be helpful. I am not sure what the discussion in your video was about, but I am under the impression that Alsamixer is basically just a low-resource channel mixer that runs out of the terminal.

ALSA provides a lot more than a mixer though, and if you are willing to poke around a little there are plenty of adjustments to be made. You can learn more about ALSA here: Advanced Linux Sound Architecture - ArchWiki

The other service running on your system that handles the audio stack is Pipewire. Again, there is a lot to read and plenty of good troubleshooting tips to be found if you have decent web-searching chops. LMGTFY: PipeWire - ArchWiki

Here's a tip: if you temporarily disable Pipewire and force your system to use just ALSA it can help you decide where to focus your troubleshooting. If the audio is just as bad without Pipewire, adjustments you make in Pipewire probably won't provide your fix because ALSA is a more base-level piece of the stack. In this case you should look for a fix in ALSA (perhaps start with alsa-utils).

If the problem is less noticeable or goes away with Pipewire disabled, then the issue might be in how Pipewire is configured. You will probably still want to use Pipewire because it is a lot easier to work with, but obviously you have to figure out how to fix it.

To disable Pipewire:

systemctl --user stop pipewire.socket

Don't forget to turn it back on:

systemctl --user restart pipewire pipewire-pulse pipewire-media-session
1 Like

tried it but no luck with it either. Can use the hda intel pch as default instead of pipewire?

This comment leads me to believe either my meaning was misconstrued, or you did not read the message and just blindly pasted those commands into your terminal. I only noted these commands down for the troubleshooting value that is described in the note; outside of that context they are not valuable and certainly not a fix for your situation.

I have no idea what is the problem with your audio stack. Maybe someone will chime in that knows a quick fix command you can slap into the terminal and be done with it, but unfortunately it's not going to be me.

Whereas in Windows you may be accustomed to clicking the "go-ahead-and-install-whatever-you-want-just-fix-it" button, in Linux there is rarely a functioning version of that. You have to RTFM, learn what options in your system can be changed, and try stuff out to find a solution.

If you can provide (a lot) more detail about what your issue specifically is, when it happens or things that seem to affect the behavior for better or worse, that would be helpful information. Also provide details about what you have learned and what you have tried so far. If you provide useful information, other people can chime in and maybe we can help you find a solution to your problem.

I'm not completely sure what that Intel thing is (a sound card?) but no, you cannot.

1 Like

I want to change my default sound card from pipewire to HDA intel pch. And also I want to change the rear audio port from line out to headphone. I tried jack retask but it gives me this a device or resource busy error. Thanks!

That won't help fix your problem.

This might help fix your problem.

1 Like