Loud Buzzing noise on bluetooth headphones on mSBC

Hello.

I've been trying to get the microphone of my bluetooth headphones (Soundcore Life Q30) working and, as expected, it only works on HSP/HFP, the problem is that the audio quality is really bad, changing the codec to mSBC should fix it, but instead i get a loud buzzing noise that hurts my ears, from what i could gather, this is a problem with the kernel on 5.16 and downgrading to 5.15 should fix it.

System:
Kernel: 5.16.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=b7622284-c5d1-4dab-99e5-59404e2a3b09 rw [email protected]
quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=ddff92b5-7dbe-4d06-b7f5-347468563158 loglevel=3
Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Acer product: Aspire A515-44 v: V1.02
serial:
Mobo: RO model: Calla_RN v: V1.02 serial:
UEFI: INSYDE v: 1.02 date: 03/23/2020
Battery:
ID-1: BAT1 charge: 36.1 Wh (100.0%) condition: 36.1/47.8 Wh (75.5%)
volts: 12.3 min: 11.2 model: LGC AP18C8K type: Li-ion serial:
status: Full
CPU:
Info: model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP
arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
microcode: 0x8600103
Topology: cpus: 1x cores: 6 smt: cache: L1: 384 KiB
desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
desc: 2x4 MiB
Speed (MHz): avg: 2240 high: 2872 min/max: 1400/2375 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2547 2: 2248
3: 2872 4: 1546 5: 1763 6: 2469 bogomips: 28447
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu v: kernel
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1,eDP-1
empty: none bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
Device-2: Microdia Dual Mode Camera (8006 VGA) type: USB
driver: hid-generic,usbhid bus-ID: 3-2:2 chip-ID: 0c45:8006 class-ID: 0301
Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 3-4:3
chip-ID: 04f2:b64f class-ID: 0e02 serial:
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
display-ID: :0 screens: 1
Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 950x285mm (37.4x11.2")
s-diag: 992mm (39")
Monitor-1: HDMI-A-0 mapped: HDMI-A-1 pos: right model: HP LA2205
serial: built: 2012 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
size: 473x296mm (18.6x11.7") diag: 558mm (22") ratio: 16:10 modes:
max: 1680x1050 min: 720x400
Monitor-2: eDP pos: primary,left res: 1920x1080 hz: 60 dpi: 142
size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
OpenGL: renderer: AMD RENOIR (DRM 3.44.0 5.16.16-zen1-1-zen LLVM 13.0.1)
v: 4.6 Mesa 21.3.7 direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel pcie: gen: 4
speed: 16 GT/s lanes: 16 bus-ID: 05:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor
vendor: Acer Incorporated ALI driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x
pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.16.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
vendor: Lite-On driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 04:00.0 chip-ID: 168c:003e class-ID: 0280
IF: wlp4s0 state: down mac:
IF-ID-1: anbox0 state: down mac:
Bluetooth:
Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 1-3:3
chip-ID: 04ca:3016 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address:
Drives:
Local Storage: total: 1.82 TiB used: 1.18 TiB (65.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
model: WD Green SN350 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial:
rev: 33006000 temp: 24.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD10JPVX-60JC3T1 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial:
rev: 1A02 scheme: GPT
Partition:
ID-1: / raw-size: 914.64 GiB size: 914.64 GiB (100.00%)
used: 223.42 GiB (24.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 914.64 GiB size: 914.64 GiB (100.00%)
used: 223.42 GiB (24.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 914.64 GiB size: 914.64 GiB (100.00%)
used: 223.42 GiB (24.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 914.64 GiB size: 914.64 GiB (100.00%)
used: 223.42 GiB (24.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.57 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
ID-2: swap-2 type: zram size: 15.06 GiB used: 1.91 GiB (12.7%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 61.0 C mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 364 Uptime: 8h 4m wakeups: 1 Memory: 15.07 GiB
used: 11.64 GiB (77.3%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 2006 lib: 561 Shell: fish
v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
System install date: 2022-03-21
Last full system update: 2022-03-23
Is partially upgraded: No
Relevant software: NetworkManager
Windows dual boot: No/Undetected
Snapshots: Snapper
Failed units: systemd-networkd-wait-online.service

The LTS kernel is 5.15. Give it a shot! Let us know how it goes.

I believe you can install the LTS kernel through Garuda Assistant now, and select the kernel you wish to use from the grub menu (before the login screen).

3 Likes

Just tried it, yes it no longer creates the buzzing sound and the microphone and audio work! and my ears don't hurt anymore lol

Sadly the audio, athough much better than the CVSD codec, it's still not as good as A2DP, and idk how to fix that.

If there's nothing i can do, oh well, i guess i'll just change it for calls and recordings.

I wouldn't say there is nothing you can do. Audio configurability goes deep! You are limited mostly by how much reading you can tolerate. :joy:

This article is a good place to start if you're in the dark: Advanced Linux Sound Architecture - ArchWiki

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.