Login screen doesn't show

No cigar. However, I noticed something. Even the backlight turns off. When booting after the grub turns the screen black, the backlight is still on for a while and only when "the login screen shows" (as full black) it turns off the backlight too. Not sure if that's relevant or if I was able to explain myself well.

Just to double-check, you already tried setting that same value to true right?

[LightDM]
logind-check-graphical=true

My understanding is that's supposed to be the default, but it's at least worth a shot setting it explicitly because I'm afraid I'm running out of ideas.

Yes. Unfortunately nothing changes. I appreciate the help. It’s not system breaking but it is rather annoying :sweat_smile:

This is a bit of a Hail Mary, but we can try adding a drop-in file to hold back the LightDM service a few seconds.

sudo systemctl edit lightdm

Paste in these two lines:

[Service]
ExecStartPre=/usr/bin/sleep 3

Save and exit (accepting the default filename is fine), reboot and test again.

1 Like
### Editing /etc/systemd/system/lightdm.service.d/override.conf
### Anything between here and the comment below will become the contents of the drop-in file



### Edits below this comment will be discarded


### /usr/lib/systemd/system/lightdm.service
# [Unit]
# Description=Light Display Manager
# Documentation=man:lightdm(1)
# [email protected]
# [email protected] systemd-user-sessions.service plymouth-quit.service acpid.service
#
# [Service]
# ExecStart=/usr/bin/lightdm
# Restart=always
# IgnoreSIGPIPE=no
# BusName=org.freedesktop.DisplayManager
#
# [Install]
# Alias=display-manager.service

This is what I had in the file, are all these lines comented? should any of them not be commented before I make those changes?

When you use sudo systemctl edit to make a drop-in file, you start off with a fully commented version of the unit you are making the drop-in for. Just leave it as-is, and add the two lines between this:

### Anything between here and the comment below will become the contents of the drop-in file

and this:

### Edits below this comment will be discarded
1 Like

Unfortunately that didn't work either. I also tried to mess around with the login window settings and that didn't help either.

I'm not sure where to go with this one @Douradinho. It's possible you are up against a proper bug in LightDM. I encourage you to raise an issue on the GitHub page here:

In addition to explaining how the lock screen is working but the initial login reverts to TTY, it will be useful if you can describe the interventions you have tried so far. They will likely be interested in seeing the log as well:

journalctl -u lightdm.service

Please update the thread if you learn anything more about what's going on. Good luck, sorry I was not able to be more helpful!

2 Likes

Alright, I'll do that :slight_smile: thanks so much for all your assistance!

1 Like

Hey! Back with some more info!

I went back home and tested it on my regular set up which has a 34" monitor plugged in by USB-C.

The greeter shows when booting! HOWEVER, only on the monitor! I set my primary screen to laptop (I had previously set the monitor as primary, before posting here) but it didn't make a difference. It really seems to be an issue of not finding a monitor to show the greeter.

That is a useful discovery! In that case, you can force LightDM to use the correct display. See here:

https://wiki.archlinux.org/title/LightDM#LightDM_displaying_in_wrong_monitor

LightDM displaying in wrong monitor

If you are using multiple monitors, LightDM may display in the wrong one (e.g. if your primary monitor is on the right). To force the LightDM login screen to display on a specific monitor, edit /etc/lightdm/lightdm.conf and change the display-setup-script parameter like this:

/etc/lightdm/lightdm.conf
display-setup-script=xrandr --output *HDMI-1* --primary

Replace HDMI-1 with your real monitor ID, which you can find from xrandr command output.

1 Like

Sorry for the late reply. I tried that but unfortunately it doesn’t change anything.

Also, this is my slick-greeter.conf
The monitor on the last line, is the laptop monitor.

[Greeter]
background=/usr/share/wallpapers/garuda-wallpapers/background.jpg
theme-name=Sweet-Dark
icon-theme-name=BeautyLine
font-name='Fira Sans 12'
activate-numlock=true
cursor-theme-name=Sweet-cursors
keyboard=onboard
reader=orca
background-color=#613583
stretch-background-across-monitors=true
only-on-monitor=eDP-1-0

Have you tried changing that to eDP-1?

Also, any difference if you comment out the stretch-background-across-monitors line, or set it to false?

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.