Live USB Stick Install failed on 128GB RAM

I loved how Garuda Linux looked when i installed it into a VirtualBox machine.
So i decided to put it on my workstation. Used Rufus to build a bootable USB stick and tried to start. it. The initial bootloader screen appeared but when i hit "start with proprietary driver" or "start with open source driver" they both gave me immediately a black screen with just an "out of memory" error.

This must be an error with the initial RAM disk creation.

Unfortunately i can't reduce the memory to test it because for this i would to remove the CPU cooler to put the sticks into the correct order and the BeQuite cooler montage for Alder Lake is the worst i have experienced since good old AMD Athlon in 2002.

Welcome :slight_smile:

Please, check sha sum.
Use Ventoy for boot stick.

Post which ISO you use, full ISO name.

Read (search in forum search :wink: ) black screen.

BTW, I installed with 128 GB RAM without problems.


I downloaded the ISO today


My graphics card is a AMD RX580. This should work out of the box. I'm pretty positive it's the RAM disk. I will try on an older computer today to see if the install works there (using the exact same GPU).

1 Like

Ahh, much luck, I have no problems with 128 GiB RAM :slight_smile:

1 Like

Did you verify the sha256sum value?

I think this is really good advice. You can use Ventoy on Windows (not just Linux), so if you are stuck on Windows right now don't let that stop you.

It is way better than Rufus or many other imaging tools because you can just plop the iso on the disk and carry on. It can also hold multiple isos. Even if it didn't solve your problem (which it might), I think you will be grateful you learned about this handy tool.

1 Like

There are moments in my life where I, or my translation machine, don't get to the point as well as you do. Unfortunately, thank you :slight_smile:


It wasn't the checksum. As i said before, i'm still 95% sure it's the creation of the ramdisk that fails.
Using i9-12900k and a MSI Z690-A Wifi board with 4x32DDR4 sticks. But i guess it is pretty simple config mistake in the boot. All other distros i tried (almost all of the popular onces, a good dozend, worked).

What i did was sticking it all in an older Intel Core 4th Gen board (32GB RAM) and installing on the NVMe drive. Then moving the drive to the modern computer and it worked without any problems at all (just that the 8 year old BIOS couldn't boot from NVMe, but writing wasn't a problem).

1 Like

What else can I say, the RAM is not the problem, works for me.
For KDE and i3wm.
It also works on my old AMD hardware from 2008 and Intel from 2012.
Only weak laptops or hardware from 2002 with 768 KiB RA does not work.

As always with Linux, wait and see can help if your hardware is not yet supported.

1 Like

Wrong. Wrong, wrong, wrong. Please use an acceptable means, as shown in the Garuda Wiki. Rufus used to never work with Arch-based distros, and only does so now if the user just happens to choose the right settings.

Really, there's no sense proceeding further until you re-write the ISO using an acceptable method. Here's the link: System requirements & notes | Garuda Linux wiki See: " * To burn the iso to your thumb drive use our Garuda Downloader application, dd (Etcher, Imagewriter, ..) or Ventoy

I note that the Downloader uses Rufus only because it is tiny, according to the Wiki. And the Downloader, according to its author, uses the correct settings.

I don't know whom this "Rufus" character is but from a Linux perspective, I'd like to kick his "tiny" ass.

Anyway, the point is to start with a known-good image written to a known-good media using a known-good method. It doesn't get any simpler than that. Then, if you still have problems, you'll know not to troubleshoot in that direction.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.