Live USB GNOME won't boot

The USB boots well with the KDE version but doesn't boot with the GNOME version.

Welcome to GRUB!

error: invalid arch-independent ELF magic
Entering rescue mode...
grub rescue >

Screnshot at Imgur: The magic of the Internet

Already burn the iso with BalenaEtcher, KParted and GParted with the exact same result.

Read

and post inxi and ISO name from both.
and

:slight_smile:

1 Like

is it when you start to boot the usb installation
or after the instalation ???
did you have another system running on same hdd
maybe old installation

or you have old files on your usb stick

pls try clean installation with formatted usb stick
and clean hdd with no old boot partition sometimes they are locked and can't read from gparted
only helps format and restart so partition is not loaded and can deleted

Also make sure you verify the image checksum to make sure it was downloaded correctly. If KDE works then GNOME should also work - while the DE is different the underlying operating system is exactly the same.

2 Likes

Image checksums where correct.

Did the burn on the USB using DD and it solved the issue and it boots.
In fact I'm writing this using the live Gnome USB :slight_smile:

sudo dd if=file.iso of=/dev/sdX

See Installation instructions | Garuda Linux wiki

2 Likes