Live USB - black screen - Dell XPS 15 9520


After booting up to Garuda qtile live USB and choosing the proprietary Nvidia driver. I'm able to see the login screen but after typing the password the screen goes black.

On Garuda dr460nized I had to add ibt=off to make it work. However, on qtile this option is already added to the boot options in grub.

I've tried to run a update on the live USB in a virtual console, before typing the password to login into the grapical interface but it just crashes then. Typing startx give an error about connection to X server lost.

Any ideas on how to proceed?

Use open source and install Nvidia later, if Qtile work with Nvidia.


I tried using the open source graphical driver but no difference. Still see a black screen after entering the password and logging in.

PLease, post from live ISO the


Sorry for not being able to paste in the text. Let me know if you need any other information.

I just had this same issue, I got a blank screen on the default wayland after logging in. It works fine on xorg though.

Welcome :slight_smile:

Please, open new help request and follow the template.