Linux loading issue

Restarted my Laptop, it goes through grub and the screen stays blank and the back light turns on and off every second. waited 20 minutes nothing loaded

Memory test passed

tried multiple snapshots and kernels

i get to a black screen that says

setfont: KDFONOP: Function not implmented

  • The root device is not configured to be mounted
  • read-write! it may be fsck'd again later

Google search hints it is a grub configuration issue but do not understand the steps to resolve it or how this even happened. I don't want to be guessing how to fix things and make things worse

It is a intel processor with nvidia card and 2 m.2 drives and 1 ssd

I would be very grateful for anyone who can walk me though this issue.

Can you use CTRL+ALT+F-Keys to switch TTY and login there? If so, please post the link generated from garuda-inxi | tb

What previous snapshot(s) were tried, and did they have the exact same result? Did you do any major changes recently?


Can't seem to get to a tty.

If I do nothing a fast message is in the top left corner but then the screen goes blank and the black light just blinks.

I tried multiple snap shots For example i try one on 4/20/2023 Post Sweet-theme-git

I am not sure which kernel option to try, I have zen, lts, hardened. and fallback.img for all 3

If I try the roll back I get the error stated before but the screen goes blank. I plugged in an external monitor incase my screen is some how bad. it does not get a signal. I can hear my fan changing speed like something is happening but even after an hour nothing changes screen is black

ctrl alt f does nothing if i hit the power button

I can get to a grub command line

does that help?

The only change I did since I rebooted last was an update and removing the ffmpeg 4.2 and installing a different version of ffmpeg. But I have rebooted multiple times since the 4:20 snap shot I am currently using.

I went into advanced options and picked zen recovery option and logged into root.
I can run garuda-inxi but when I pipe it to tb its says" tb command not found "

I an on another computer so can't copy and paste the output here.

What might I look for?

You can use:

garuda-inxi > /path/to/your/inxi-output.txt

to get it saved to a text file.

1 Like

Agreed but not sure how I would get that posted online

Do you have a USB memory stick to copy it to then plug into a computer that is online?

1 Like

ok I typed start x and a desktop loaded but very different can't get online yet will try some stuff.

Ok I opened snapper, rolled back to a previous version, restarted and it appears to be up. Not sure what is going on will try to do updates and what not.

Completed update including AUR. Rebooted and check upd again. Computer seems to be fine. While I was in tty as root, I did notice that my root drive was 96.4% full. I deleted a few files that I didn't need got it to 95.5% full. When I couldn't get online I tried to log in as different user that did nothing.

Not sure what the issue was but I will cleaned up some disk space to be safe.

TY for everyone's help, all great advice.


So steps to resolve were.
Choose advance option from GRUB
Choose a Recovery Kernel option
At command line typed "startx"
A desktop environment loaded
Used snapper GUI to restore previous version
Ran update
Ran update (no changes made)


That is very interesting as I have also been having an issue with my storage filling up but only on one of my machines (primary use old laptop). I did have hourly @home snapshots running (keeping 24 of them) and that has been fine for months up until about 5 or 7 days ago when I noticed this problem started happening and disabled it as it very much exacerbates the issue. I know it's something in the @home subvolume as deleting @home snapshots clears up the free space. I haven't reported the issue properly yet as I've been busy. I first wanted to reply here as we seem to have the same issue so may figure out to as what we have in common. @Mantion Please post your garuda-inxi. Also, do you use Brave Browser?

If anyone wants me to create a separate topic on this issue sooner than later I will.

Here is my inxi:

Kernel: 6.1.27-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=e0430201-0931-4d49-a5a8-f8a1445e4ab0 rw [email protected]
rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=ae0cdb3c-2994-4db6-8822-7960e6e25fe8 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_wayland vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: Apple product: MacBookAir7,2 v: 1.0
serial: <superuser required> Chassis: type: 9 v: Mac-937CB26E2E02BB01
serial: <superuser required>
Mobo: Apple model: Mac-937CB26E2E02BB01 v: MacBookAir7,2
serial: <superuser required> UEFI: Apple v: 428. date: 10/27/2021
ID-1: BAT0 charge: 48.4 Wh (100.6%) condition: 48.1/54.3 Wh (88.5%)
volts: 8.5 min: 7.6 model: DP bq20z451 type: Li-ion serial: N/A status: full
cycles: 88
Device-1: hidpp_battery_1 model: Logitech Wireless Mouse M510
serial: <filter> charge: 55% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i5-5350U bits: 64 type: MT MCP arch: Broadwell
gen: core 5 level: v3 note: check built: 2015-18 process: Intel 14nm
family: 6 model-id: 0x3D (61) stepping: 4 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1514 high: 1699 min/max: 500/2900 scaling:
driver: intel_cpufreq governor: performance cores: 1: 1405 2: 1681 3: 1273
4: 1699 bogomips: 14407
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel HD Graphics 6000 vendor: Apple driver: i915 v: kernel
arch: Gen-8 process: Intel 14nm built: 2014-15 ports: active: HDMI-A-1
off: eDP-1 empty: DP-1,DP-2,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:1626
class-ID: 0300
Display: wayland server: v: with: Xwayland v: 23.1.1
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel HD Graphics 6000 (BDW
GT3) direct-render: Yes
Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel
v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403
Device-2: Intel Wildcat Point-LP High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0
class-ID: 0403
Device-3: Broadcom 720p FaceTime HD Camera driver: facetimehd v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:1570
class-ID: 0480
API: ALSA v: k6.1.27-1-lts status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: cdc_ncm
bus-ID: 2-1:2 chip-ID: 0b95:1790 class-ID: 0a00 serial: <filter>
IF: enp0s20u1c2 state: up speed: 1000 Mbps duplex: half mac: <filter>
Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8
bus-ID: 1-3.3:11 chip-ID: 05ac:828f class-ID: fe01
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Local Storage: total: 233.76 GiB used: 174.13 GiB (74.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0256G
size: 233.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3A0Q scheme: GPT
ID-1: / raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
used: 174.13 GiB (77.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
used: 174.13 GiB (77.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
used: 174.13 GiB (77.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 224.66 GiB size: 224.66 GiB (100.00%)
used: 174.13 GiB (77.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.67 GiB used: 2.48 GiB (32.3%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
System Temperatures: cpu: 75.0 C pch: 83.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 238 Uptime: 19h 45m wakeups: 41 Memory: 7.67 GiB
used: 2.15 GiB (28.1%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: pm: pacman
pkgs: 2184 libs: 602 tools: octopi,pamac,paru,pikaur Shell: fish v: 3.6.1
running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2022-12-02
Last full system update: 2023-05-07
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut(custom) mkinitcpio
Windows dual boot:       No/Undetected
Failed units:            update-aurto.service
1 Like

Hm, home filling up? I wonder if perhaps profile-sync-daemon has anything to do with it.

fish❯ grep BACKUP_LIMIT ~/.config/psd/psd.conf
fish❯ ll .firedragon/ |wc -l
fish❯ du -sh .firedragon/
24G	.firedragon/

Now that you mentioned Brave, if I'm not mistaken all Chromium/Electron stuff (e.g. also Codium/VSCode) keep a crapload of caches where they don't belong, it wouldn't surprise me if they end up in the backups.

Other huge directories in home include caches of paru, go, and rust.


For the first one I also have


otherwise I don't use Firedragon. This happens with me just using Brave. I see my mouse cursor tracking lag sometimes as well now and I wonder if it's related as that problem seemed to start at the same time.

Head scratching time: upgraded, rebooted, noticed a little more CPU and disk activity than usual.
It was a flurry of rm -rf wiping all the old crashrecovery profiles as if it heard me. :magic_wand:
But profile-sync-daemon is 2022-09-10 and there's nothing in last days upgrades to explain it.
The only thing that comes to my mind is that earlier today I had (for the first time) a "spontaneous" crash and logout likely due to an out-of-memory that messed up the browser profile (Firedragon kept complaining it's already running when it actually wasn't, and psd-resync was failed). Also, this prompted me to inspect psd.conf where I noticed I had added luakit to the browsers array just because, so I stopped psd.service and removed it from the list. I doubt that was preventing the cleanup though, I used to have crashrecovery backups older than when I installed luakit. :man_shrugging:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.