Links opening in firedragon even after setting default browser as vivaldi

I changed my default browser to vivaldi from system settings. But whenever I try to open link(mainly from telegram) it opens in firedragon. Why does this behaviour exist even after changing default browser and How can I completely change my default browser to vivaldi. Here are some things that I checked

xdg-settings get default-web-browser


xdg-mime query default x-scheme-handler/https


1 Like

You might want to adjust ~/.profile as well :slight_smile:


already did.....but not sure what to write there exactly I wrote vivaldi-stable....didn't work

You need to provide either the name of the binary (I would guess its vivaldi?) or the path of it :slight_smile:

1 Like

have already tried vivaldi, trying again with it's path....I haven't logged out after making changes....Is that required ?



yeah checked didn't work


This command on terminal actually opens in vivaldi only but If i open something from telegram that opens in firedragon

xdg-mime default vivaldi-stable.desktop x-scheme-handler/http
xdg-mime default vivaldi-stable.desktop x-scheme-handler/https

This worked

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.