Libreoffice Changing Icons and Default save as not working

Issue:
I have installed KDE edition and so far everything works good. However, i have minor issue with libreoffice-fresh

  1. In tools -> Options --> View --> Icon Style - Cannot change any other icon style other than "Breeze (dark)
  2. In tools --> Options --> Load/Save --> General --> Always Save as --> Cannot change it

In past i was able to achieve it, but i did fresh install recently and finding this issue. I have looked upon forums and searched externally also, but could not find any resolution to it.

Any help or guidance will be much appreciated.

Output of inxi -Faz

System:    Kernel: 5.14.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0  
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen  
root=UUID=a07dbd70-9428-4b82-8f09-14761537bad7 rw [email protected] quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
resume=UUID=fbab5f42-f082-438b-9415-bed4021ab9d2 loglevel=3
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM  
Distro: Garuda Linux base: Arch Linux  
Machine:   Type: Desktop System: Dell product: OptiPlex 3050 v: N/A serial: <filter> Chassis:  
type: 3 serial: <filter>  
Mobo: Dell model: 0JP3NX v: A01 serial: <filter> UEFI: Dell v: 1.17.0  
date: 07/20/2021  
CPU:       Info: Dual Core model: Intel Core i3-6100T bits: 64 type: MT MCP arch: Skylake-S
family: 6 model-id: 5E (94) stepping: 3 microcode: EA cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25599
Speed: 3197 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 3197 2: 3189 3: 3175
4: 3166
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:1912 class-ID: 0300
Device-2: AVerMedia Live Streamer CAM 313 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-4.1:4 chip-ID: 07ca:313a class-ID: 0102 serial: <filter>
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.8x15.0")
s-diag: 987mm (38.8")
Monitor-1: DP1 res: 3440x1440 dpi: 109 size: 800x330mm (31.5x13.0")
diag: 865mm (34.1")
OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.2.1
direct render: Yes
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: Dell driver: snd_hda_intel v: kernel
bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403
Device-2: AVerMedia Live Streamer CAM 313 type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-4.1:4 chip-ID: 07ca:313a class-ID: 0102 serial: <filter>
Sound Server-1: ALSA v: k5.14.5-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.35 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell
driver: r8169 v: kernel port: e000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: e000 bus-ID: 02:00.0
chip-ID: 8086:24f3 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-9:5 chip-ID: 8087:0a2b class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060
bus-ID: 00:17.0 chip-ID: 8086.2822 rev: class-ID: 0104
Drives:    Local Storage: total: 338.13 GiB used: 39.95 GiB (11.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G size: 223.57 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter>
rev: 0100 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Ultra size: 114.56 GiB
block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.00
scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 206.38 GiB size: 206.38 GiB (100.00%) used: 19.68 GiB (9.5%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%)
fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 206.38 GiB size: 206.38 GiB (100.00%) used: 19.68 GiB (9.5%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 206.38 GiB size: 206.38 GiB (100.00%) used: 19.68 GiB (9.5%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 206.38 GiB size: 206.38 GiB (100.00%) used: 19.68 GiB (9.5%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 16.93 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 15.39 GiB used: 89 MiB (0.6%) priority: 100
dev: /dev/zram0
Sensors:   System Temperatures: cpu: 66.0 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:      Processes: 312 Uptime: 10h 45m wakeups: 3 Memory: 15.39 GiB used: 7.63 GiB (49.6%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
pacman: 1322 lib: 346 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole
inxi: 3.3.06

Have you tried starting in Safe Mode?
If not working, in the past I solved a couple of strange LibreOffice behaviours (but not this one!) deleting (renaming) the user profile folder (/home/user name/.config/libreoffice/4/user) and restarting LibreOffice.
Most likely it will not help in this case, but it's a quick test and you can easily rollback restoring the old folder by renaming back...

1 Like

Thanks for quick reply....i have tried deleting everything...re-installing etc.

I have not tried safe-mode but will do and post the update.

Additionally, i am copying "registrymodifications.xcu" from other working machine and see if that works.

1 Like

I copied "registrymodifications.xcu" and it seems to work for default save as option, but still unable to change it
Additionally, restarting in safe mode and resetting, fix some other minor nuances, but still both the issues 1. cannot change icon 2. cannot change default save as persists.

I will continue to work on it and post updates on what i am able to figure out

2 Likes

Finally I'm home and had some peace to turn my laptop on...
The only thing I can say is that both settings you mentioned can be changed correctly in my system (Dr460nized Ed.), both before today's update (I had libreoffice-fresh 7.2.0-2) and after (now libreoffice-fresh 7.2.1-2)...
Maybe you could try with the Garuda Assistant / Reset Configs / LibreOffice (unless you don't want to risk to loose your recent setting changes).
Finally, you may want to give a look at the Arch Wiki for LibreOffice:
https://wiki.archlinux.org/title/LibreOffice#LibreOffice_toolbars_unreadable_with_dark_Breeze/Plasma_5_theme
(anyway breeze-gtk is not installed in my system) and
https://wiki.archlinux.org/title/LibreOffice#Theme
(also here, no changes in /etc/profile.d/libreoffice-fresh.sh for me).
I really hope you can figure out and fix your issue!

3 Likes

Sure...thanks...i will try it out today and will respond

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.