Lenovo Yoga 7 touchpad not working

As the title indicates, I have issues getting my touchpad to work.

Here is xinput:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Elan Touchpad id=13 [slave pointer (2)]
⎜ ↳ PixArt USB Optical Mouse id=9 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Video Bus id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ Sleep Button id=8 [slave keyboard (3)]
↳ Integrated Camera: Integrated C id=10 [slave keyboard (3)]
↳ Integrated Camera: Integrated I id=11 [slave keyboard (3)]
↳ Ideapad extra buttons id=12 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=14 [slave keyboard (3)]

My kernel is:

Kernel: 5.10.4-107-tkg-bmq

In what way?

What have you tried?

Where have you looked?

Have you looked on the Arch wiki for your laptop model?

1 Like

It is detected, but it does not move the mouse, or registers clicks

I tried couple of solutions i found on web, most of them were about changing grub file

I havent tried Arch wiki, im going there right now

update:

As per recommendation from arch wiki, I tried updating firmware, but it did not help

Assuming this is the same device:

https://wiki.archlinux.org/index.php/Lenovo_IdeaPad_7_14are05

then the touchpad should work without any additional effort. Therefore, are you sure it is enabled, (e.g. using the keyboard shortcut) and is working generally? Is it shown in the desktop environment's input settings?

Also,

This is quite an old subversion (current is 5.10.13) - have you also tried updating and rebooting?

2 Likes

I managed to fix it by properly updating firmware, fwupd, and not through GUI, but thank you fro trying to help anyway.

Btw I downloaded the latest version of garuda from the website, do you still recommend updating the kernel?

2 Likes

Garuda is a rolling-release distribution. You should always update your system. Do not wait until there is a new installer image available.

3 Likes

Fair point. Thanks

There is however another quirk I discovered. It appears that when I reboot my system, the touchpad stops working, however, if I shut it down, then boot it up, it works just fine.. any ideas on what might cause this type of behaviour?

Nope. Update and see if it still happens, and then try a different kernel to rule that out as a factor.

4 Likes