Lenovo IdeaPad 5 Fan control

Greetings fellow Garuda enjoyers.

garuda-inxi result:
Kernel: 6.3.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=8b45eb55-c8da-4c93-a3b4-b2373dd295f5 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=69be7589-664b-43fd-bde5-39a85d554f0a loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: LENOVO product: 82SN v: IdeaPad 5 Pro 16ARH7
serial: Chassis: type: 10 v: IdeaPad 5 Pro 16ARH7
Mobo: LENOVO model: LNVNB161216 v: No DPK serial:
UEFI: LENOVO v: J4CN37WW date: 03/17/2023
ID-1: BAT0 charge: 46.6 Wh (61.3%) condition: 76.0/75.0 Wh (101.3%)
volts: 16.5 min: 15.4 model: LENOVO AP16L5J type: Li-ion serial:
status: charging cycles: 65
Info: model: AMD Ryzen 7 6800HS Creator Edition bits: 64 type: MT MCP
arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404102
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 2471 high: 4042 min/max: 1600/4784 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 4042 2: 2000
3: 2386 4: 2381 5: 1841 6: 2190 7: 1599 8: 1661 9: 1444 10: 3200 11: 3200
12: 3200 13: 2394 14: 3200 15: 1598 16: 3200 bogomips: 102208
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,
DP-2, DP-3, DP-4, DP-5, DP-6, DP-7, HDMI-A-1 bus-ID: 04:00.0
chip-ID: 1002:1681 class-ID: 0300 temp: 62.0 C
Device-2: Luxvisions Innotech Integrated RGB Camera driver: uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2
chip-ID: 30c9:0057 class-ID: fe01 serial:
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.65x16.65")
s-diag: 798mm (31.43")
Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x09b6 built: 2021
res: 2560x1600 hz: 60 dpi: 188 gamma: 1.2 size: 345x215mm (13.58x8.46")
diag: 407mm (16") ratio: 16:10 modes: 2560x1600
API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon Graphics (rembrandt
LLVM 15.0.7 DRM 3.52 6.3.9-zen1-1-zen) direct-render: Yes
Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 04:00.1 chip-ID: 1002:1640 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 04:00.6
chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.3.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.71 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp1s0 state: up mac:
Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-3:2 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
Local Storage: total: 931.51 GiB used: 83.21 GiB (8.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA2000M81000G
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: fw-rev: S5Z42105 temp: 44.9 C
scheme: GPT
ID-1: / raw-size: 500 GiB size: 500 GiB (100.00%) used: 83.15 GiB (16.6%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 62 MiB (20.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 500 GiB size: 500 GiB (100.00%)
used: 83.15 GiB (16.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 500 GiB size: 500 GiB (100.00%)
used: 83.15 GiB (16.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 500 GiB size: 500 GiB (100.00%)
used: 83.15 GiB (16.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 13.34 GiB used: 3.65 GiB (27.3%)
priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 14.67 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p6 maj-min: 259:6
System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 65.0 C
Fan Speeds (RPM): N/A
Processes: 383 Uptime: 2h 50m wakeups: 60868 Memory: available: 13.34 GiB
used: 4.66 GiB (35.0%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 13.1.1 Packages: pm: pacman pkgs: 1824
libs: 550 tools: octopi,paru Shell: fish v: 3.6.1 running-in: konsole
inxi: 3.3.27
Garuda (2.6.16-1):
System install date: 2023-06-11
Last full system update: 2023-07-05 ↻
Is partially upgraded: No
Relevant software: snapper NetworkManager dracut
Windows dual boot: Probably (Run as root to verify)
Failed units: systemd-vconsole-setup.service

As you can see, I have an IdeaPad 5 Pro 16ARH7, and I'm having some issues with fan speed, in that no tool I found online can control them, and by default they are at very low speed, and even with something like a youtube video, my laptop gets VERY hot (~80 degrees). I thought that maybe it's an issue with the cooling system itself because it has exhausts on the bottom, but there is only like half a centimeter of a gap under it, but, 1. I opened it up and the cooling system is fairly good, and 2. The issue only happens on Linux (or Garuda, I haven't tried other distros), I didn't think much of it until I had to boot up windows for work and noticed that the laptop is running way cooler even with a more demanding load. Does anyone have any suggestions? I tried fancontrol-gui, pwmconfig, thinkfan, nbfc (couldn't figure out how to use this one), and none of them seemed to be able to detect fans or pwm sensors.
As a last resort, I was going to post on Lenovo's forums, but I got the distinct feeling that Lenovo themselves couldn't care less about Linux, and there were vaguely similar questions there already with either 0 replies or useless replies.

Any help is highly appreciated!

have you used

sudo sensors-detect

before generating /etc/fancontrol using pwmconfig or using fancontrol-gui?
Also did you enable fancontrol's systemd service after generating this file?

sudo systemctl enable --now fancontrol

Note: This daemon only starts if /etc/fancontrol has been defined.

Also, is lm_sensors enabled? You can check with

systemctl status lm_sensors.service

It will display something like this

● lm_sensors.service - Initialize hardware monitoring sensors
Loaded: loaded (/usr/lib/systemd/system/lm_sensors.service; enabled; preset: disabled)
Active: active (exited) since Tue 2023-07-04 02:28:44 IST; 1 day 22h ago
Process: 739 ExecStart=/sbin/modprobe -qab $BUS_MODULES $HWMON_MODULES (code=exited, status=0/SUCCESS)
Process: 755 ExecStart=/usr/bin/sensors -s (code=exited, status=0/SUCCESS)
Main PID: 755 (code=exited, status=0/SUCCESS)
CPU: 8ms

Jul 04 02:28:44 siddharth systemd[1]: Starting Initialize hardware monitoring sensors...
Jul 04 02:28:44 siddharth systemd[1]: Finished Initialize hardware monitoring sensors.
1 Like

Of course, I used it for fancontrol, but after all the prompts I just get:

Sorry, no sensors were detected.
This is relatively common on laptops, where thermal management is
handled by ACPI rather than the OS.

Maybe check if this helps:
Not exactly your model, but might be worth reading.


Thank you, you absolute unit of a chad. That worked perfectly! I did have to run sudo -i and then execute the commands listed there, but after that I immediately heard my fans ramping up!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.