Lenovo IdeaPad 5 14ITL05 Touchpad not working

Hello Garuda users.

I recently replace ubuntu and installed Garuda Linux Dragonised KDE on my system. However my observation is that the elantech/ my touchpad driver seems to have a bug perhaps in suspend - resume.
A reboot gets the touchpad to work fine, but after suspending the system and resuming, the touchpad stops working.

Any hints as to what can be done?

sudo garuda-inxi

System:
  Kernel: 6.0.1-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=a3eadc67-17e5-4a86-8b24-7b34a01a3003 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Console: pty pts/3 wm: kwin_x11 DM: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 82FE v: IdeaPad 5 14ITL05
    serial: <filter> Chassis: type: 10 v: IdeaPad 5 14ITL05 serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76485 WIN serial: <filter>
    UEFI: LENOVO v: FKCN42WW(V3.05) date: 05/16/2022
Battery:
  ID-1: BAT1 charge: 30.0 Wh (56.9%) condition: 52.7/56.5 Wh (93.3%)
    volts: 11.8 min: 11.5 model: SMP L19M3PF4 type: Li-ion serial: <filter>
    status: not charging cycles: 91
CPU:
  Info: model: 11th Gen Intel Core i5-1135G7 socket: U3E1 bits: 64
    type: MT MCP arch: Tiger Lake gen: core 11 level: v4 note: check
    built: 2020 process: Intel 10nm family: 6 model-id: 0x8C (140)
    stepping: 1 microcode: 0xA4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2048 high: 2400 min/max: 400/4200 base/boost: 2300/4200
    scaling: driver: intel_pstate governor: powersave volts: 0.7 V
    ext-clock: 100 MHz cores: 1: 2400 2: 2400 3: 2400 4: 2400 5: 1100 6: 2400
    7: 2400 8: 886 bogomips: 38707
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-6:3 chip-ID: 174f:2459 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_x11 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x08d7 built: 2019 res: 1920x1080
    hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.2.1
    direct render: Yes
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound API: ALSA v: k6.0.1-zen2-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:5 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
  Local Storage: total: 1.38 TiB used: 42.6 GiB (3.0%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: MTFDHBA512QFD
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 0013P6LN
    temp: 45.9 C scheme: GPT
  SMART: yes health: PASSED on: 111d 8h cycles: 512 read-units: 7,904,917
    [4.04 TB] written-units: 12,276,256 [6.28 TB]
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Samsung model: PSSD T7
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 85.83 GiB size: 85.83 GiB (100.00%) used: 8.9 GiB (10.4%)
    fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 633 MiB size: 631.8 MiB (99.80%) used: 608 KiB
    (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-3: /home raw-size: 111.76 GiB size: 109.44 GiB (97.93%) used: 33.7 GiB
    (30.8%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-4: /var/log raw-size: 85.83 GiB size: 85.83 GiB (100.00%) used: 8.9
    GiB (10.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
    maj-min: 259:5
  ID-5: /var/tmp raw-size: 85.83 GiB size: 85.83 GiB (100.00%) used: 8.9
    GiB (10.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p5
    maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.41 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 2.79 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
Sensors:
  Src: /sys System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Power: 12v: N/A 5v: 5 3.3v: N/A vbat: N/A
Info:
  Processes: 289 Uptime: 35m wakeups: 2186 Memory: 15.41 GiB used: 3.03 GiB
  (19.7%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1217 libs: 307
  tools: octopi,paru Shell: garuda-inxi (sudo) default: Bash v: 5.1.16
  running-in: tmux: inxi: 3.3.22
e[1;34mGaruda (2.6.8-1):e[0m
e[1;34m  System install date:e[0m     2022-10-16
e[1;34m  Last full system update:e[0m 2022-10-18 e[1;31m↻
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m NetworkManager
e[1;34m  Windows dual boot:      e[0m Yes
e[1;34m  Snapshots:              e[0m Snapper
e[1;34m  Failed units:           e[0m 

welcome
First of all can you provide your complete garuda-ixni
second you are booting of a snapshot. you need to restore it properly

2 Likes

First of all can you provide your complete garuda-ixni
second you are booting of a snapshot. you need to restore it properly

My bad, xclip isn't configed properly perhaps in my tmux. Also I rebooted hence am not in a snapshot anymore.

First of all (welcome :slight_smile: and), I'd try to switch to the linux-lts kernel, to make sure this is not a recent kernel regression.
Then, try to give a look at this kernel bug.
I don't know if that's your touchpad model, but the linked workaround might give you some ideas, then use something like the script, two comments later, based on sleep hook.
https://bugzilla.kernel.org/show_bug.cgi?id=214749#c5

4 Likes

Thanks for the warm welcome @filo !
I went through that thread and tried modprobe-ing whatever was suggested but that did not get the touchpad to work. I also installed the lts kernel, here's my output:

╰─λ uname -r
5.15.74-1-lts

Also, a few interesting dmesg logs:

[  130.381901] PM: suspend entry (s2idle)
[  130.389021] Filesystems sync: 0.007 seconds
[  130.603546] Freezing user space processes ... (elapsed 0.001 seconds) done.
[  130.605513] OOM killer disabled.
[  130.605515] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[  130.606771] printk: Suspending console(s) (use no_console_suspend to debug)
[  130.768782] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[  131.203241] ACPI: EC: interrupt blocked
[  140.672101] ACPI: EC: interrupt unblocked
[  141.162888] OOM killer enabled.
[  141.162891] Restarting tasks ... done.
[  141.337010] PM: suspend exit
--clipped--
[  169.941535] i2c_hid_acpi: unknown parameter 'i2c_hid' ignored
[  170.164754] input: MSFT0004:00 06CB:CD98 Mouse as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-15/i2c-MSFT0004:00/0018:06CB:CD98.0004/input/input20
[  170.164939] input: MSFT0004:00 06CB:CD98 Touchpad as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-15/i2c-MSFT0004:00/0018:06CB:CD98.0004/input/input21
[  170.165093] hid-multitouch 0018:06CB:CD98.0004: input,hidraw2: I2C HID v1.00 Mouse [MSFT0004:00 06CB:CD98] on i2c-MSFT0004:00
[  170.166774] audit: type=1106 audit(1666101405.490:126): pid=3435 uid=1000 auid=1000 ses=3 msg='op=PAM:session_close grantors=pam_systemd_home,pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/sudo" hostname=? addr=? terminal=/dev/pts/1 res=success'
[  175.660013] kauditd_printk_skb: 6 callbacks suppressed
--clipped1--

Please check if the following works to re-enable the touchpad when you resume after suspend:

xinput --enable "MSFT0004:00 06CB:CD98 Touchpad"

If so, you could create a script accordingly.
See e.g.

6 Likes

Yes! Thanks alot.

xinput --enable "MSFT0004:00 06CB:CD98 Touchpad" worked like a charm.
Will create a script as you pointed out.

1 Like

For the wider audience, a summary of what worked for me,

  1. I checked first if the following command fixed the touchpad issue for me post-resume.
xinput --enable "MSFT0004:00 06CB:CD98 Touchpad"
  1. I then followed the link Automatically enable touchpad after suspend - Support - Manjaro Linux Forum provided by @filo , further scrolling took me to cscs' comment # 16.

I did exactly as was suggested over there and the issue got solved, now after testing mutiple suspen resume cycles, the touchpad doesn't fail on me anymore :smile: .

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.