Latte dock "unhides" on second display if both displays are being used fullscreen

Hey, how do i make it so that i can have two windows in full-screen while not having the latte-dock bar in the way? The show option is set to always show normally, but while having two fullscreen windows i'd set it to auto show, but it is not really working, seeing as it is still being shown... how do i have it not being shown while having two windows on fullscreen? The bar is configured as shown on all screens

Maybe to clear things up; i want the panel to be permanently shown, unless i have anything running on fullscreen mode, if i just maximize a window it should still be there, but as soon as an window runs in fullscreen mode, it should hide and stay hidden if i go to the other screen, at the moment if i set it to dodge active it will go away for the one screen, but as soon as i focus anything on the other screen, it is shown again?

Hi @ash3781, the desired behavior you are describing--the dock is automatically hidden when an app on the display is set to fullscreen--is the default behavior. Double-check in Behavior -> Advanced Settings -> Can be above fullscreen windows (it should be disabled). If it is not working, an issue should be raised with the developers (the GitHub page says you should do that here: Log in to KDE Bugtracking System).

I am not sure how responsive the dev team is to issues on this application. The GitHub page makes it seem like it has just been absorbed into KDE's other numerous works.

A workaround has been noted here, involving setting a window rule for the fullscreen app to "keep above all": How to get rid of the plasma panel and latte appearing when playing on GeForce Now? - r/kde

2 Likes

It is set to not be above full-screen windows, which does work, if i stay on the display... say i'd have youtube on my second display and it would be hidden, as soon as i start doing stuff on my main display and i bring anything on the main screen to focus, the panel is seen again, if i go to the second display and click on it once or switch to the window with alt + tab it is hidden again... from the looks of that github issue page i'd rather talk with my walls, they seem to be more active... i'll try that keep above all window rule, even tho that would be not as good since i want to use other time from time to time other than say firefox... anyways thank you for your answer, do i put the issue as solved or just let it close itself after two weeks?

also i just tried it and i don't want to do that, since that means that nothing, not even the latte dock can be above that window and as long as i have say firefox open i can't use the display for anything else, which i'd not call a workaround... still thank you

Update: i found a in my view good workaround, i have set a window rule for the panel, rather than each app; i told it to apply the "keep below other windows" to force yes, which means that only the fullscreen-windows can "block the view" to the panel, but everything else still gets the position of the panel an hence does not even try to put something above it. in my view exactly what i was searching for, tho a shame that that is not the actual default, especially with that option described earlier
also i figured you have to do the opposite for the "keep above others" too, which means forcing it to a no

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.