Latte Dock is not working after update 11/30/2020

Hi guys! I love the Dr46onized version and I have been using it for a week now. But today I updated it and the latte dock was not showing anymore and it shows this error
Error loading QML file://ust/share/plasma/plasmoids/org.kde.latte.containment/contents/ui/main.gml:1249:9: Type.AppleItem unavailable.

I already tried to use the command 'cp -rf /etc/skel/. ~/ And reboot ' but it still does not work.

Do I have to wait for a fix in a future update?
Here is a picture for that you can see.

2 Likes

Also welcome to you! :slight_smile:
Well I just updated and was greeted with the same issue. The issue is the update of latte-dock-git, need to report this to their github.
If you didnt update until now, you are not affected. If you did, look at the solution for instructions how to proceed :slight_smile:

4 Likes

Thank you so much for your help but before I posted this I decided to use brute force and try to fix it by reinstalling dragonized and when I do sudo downgrade latte-dock-git it just shows me version r4605.0f06f008-1 which is the one that does not work, so I guess I will wait for them to fix it. :slight_smile:

Edit2: the bug is fixed and the fixed version is now available as update.

6 Likes

Perfect! Now it works fine, thank you so much for your help! Your amazing! Love your distro!

2 Likes

Thanks for reporting this! :slight_smile:

I have filed the bugreport right now. Hopefully it will be fixed quickly :slight_smile:

6 Likes

Still not working after the latest update. How to fix it?

Moreover, the system has suddenly started bloating hard...

Welcome aboard, can you please clarify for us what's not working? Thanks

Can you please explain what's bloated? Lattedock or something else? Thanks

1 Like

Can you reboot and pick another image from Timeshift?

3 Likes

i timeshifted back a day and then updated tonight and the system excessive cpu usage is gone and latte is fixed.

I change my default theme and layout to breeze dark and its working for me. Also latte dock and layout get more time to load so I changed default theme and layout.

Greetings from Russia. As mentioned on the topic above, I got a problem with latte dock i.e. it didn't appear despite I had updated the system. About bloating, I've noticed pacman and grub-customizer are getting stuck for 30mins to finish updating configuguration. And now, grub is completely crushed. It says "missing snapshot..rescue mode'. What am I supposed to do next? Never encountered with that before. Thanks in advanced.

1 Like

Already have

The version available in our repo is definitly working though. Check if you are running the right version:

╭─nico at T440p-void in ⌁
╰─λ pacman -Q latte-dock-git
latte-dock-git r4607.2deed2d1-1

Also try to apply latest /etc/skel (configs) changes via Garuda Assistant:

1 Like

With that much going on if you were in Windows I'd say you got a bad install right out of the gate. All it takes is for the system to act up for a quick second at just the right time to mess up the install.

One reason that could happen is if your ISO that you downloaded contained errors. Before you ever even burn the ISO to a disk, (flashdrive etc) you should perform a checksum

Checksumming the ISO is always best practice, as it ensures you don't install a system with errors or omissions with important files. A checksum file is always included on every ISO download page to ensure the file is valid and hasn't been tampered with in any way by someone with malicious intent.

6 Likes