Latte Dock has no animations any more and a black background

As you can allready guess from the title my latte dock has a black background since yesterday, it also has no animations any more.
(I would have loved to show you an image, but sadly I am not allowed to upload one)

What I did before the issue came up

My system should be nearly identical to the one you get when you install the "Dragonized" version of Garuda. I am using this since three days, I changed some shortcuts and installed some programs I need for daily work, I had not made any modifications to Dock.

  • I showed my cool new linux system to a friend, when it was still working
  • The computer was not connected to the internet and I did not install anything
  • I ran the command libinput-gestures-setup restart, this is a program that allows touchpad gestures and appearantly it doesn't start by default so I have to start it manually.

What I tried to resolve the issue

  • run latte-dock --replace to restart latte
  • restart my laptop a couple of times
  • Revert to the last timeshift backup
  • reinstall latte through the "add and remove software"

Another issue that may be connected:

I selected "grid" as task switcher Visualisation and it used to show me a picture of the apps I between which I am switching and now it only shows me an icon. This also happened at the same time.

Output of inxi -Faz

System:    Kernel: 5.13.13-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=ba94a8de-44a1-41c0-8cae-bf96a8de9c6c 
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM 
Distro: Garuda Linux base: Arch Linux 
Machine:   Type: Laptop System: ASUSTeK product: ZenBook UX334FAC_UX333FAC v: 1.0 serial: <filter> 
Mobo: ASUSTeK model: UX334FAC v: 1.0 serial: <filter> UEFI: American Megatrends v: UX334FAC.303 
date: 12/13/2019 
Battery:   ID-1: BAT0 charge: 32.2 Wh (80.1%) condition: 40.2/50.0 Wh (80.4%) volts: 11.9 min: 11.9 
model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging cycles: 316 
CPU:       Info: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP arch: Kaby Lake note: check 
family: 6 model-id: 8E (142) stepping: C (12) microcode: EA cache: L2: 6 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33599 
Speed: 4163 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 4163 2: 4191 3: 4103 4: 4022 
5: 4101 6: 4151 7: 4101 8: 4012 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf status: Not affected 
Type: mds status: Not affected 
Type: meltdown status: Not affected 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
Type: srbds mitigation: TSX disabled 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: ASUSTeK driver: i915 v: kernel 
bus-ID: 0000:00:02.0 chip-ID: 8086:9b41 class-ID: 0300 
Device-2: IMC Networks USB2.0 HD IR UVC WebCam type: USB driver: uvcvideo bus-ID: 1-5:3 
chip-ID: 13d3:56cb class-ID: 0e02 serial: <filter> 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel 
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 168 size: 290x170mm (11.4x6.7") diag: 336mm (13.2") 
OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Comet Lake PCH-LP cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel 
alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 0000:00:1f.3 chip-ID: 8086:02c8 
class-ID: 0403 
Sound Server-1: ALSA v: k5.13.13-zen1-1-zen running: yes 
Sound Server-2: JACK v: 1.9.19 running: no 
Sound Server-3: PulseAudio v: 15.0 running: no 
Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel port: 3000 
bus-ID: 0000:00:14.3 chip-ID: 8086:02f0 class-ID: 0280 
IF: wlo1 state: up mac: <filter> 
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-10:4 
chip-ID: 8087:0026 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: intel_nvme_remap v: N/A
port: 3060 bus-ID: 0000:00:17.0 chip-ID: 8086.282a rev: class-ID: 0104
Drives:    Local Storage: total: 116.21 GiB used: 27.63 GiB (23.8%)
ID-1: /dev/sda maj-min: 8:0 type: USB model: USB Disk 3.0 size: 116.21 GiB block-size:
physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 8.01 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 115.95 GiB size: 115.95 GiB (100.00%) used: 27.63 GiB (23.8%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 115.95 GiB size: 115.95 GiB (100.00%) used: 27.63 GiB (23.8%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 115.95 GiB size: 115.95 GiB (100.00%) used: 27.63 GiB (23.8%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 115.95 GiB size: 115.95 GiB (100.00%) used: 27.63 GiB (23.8%)
fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.57 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:      Processes: 313 Uptime: 10m wakeups: 339 Memory: 7.57 GiB used: 2.54 GiB (33.5%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1330 lib: 318
Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: konsole inxi: 3.3.06
1 Like

Hi there, welcome!
Have you tried resetting to default config via Garuda assistant?

2 Likes

No, I will try that right now. Thank you very much!

1 Like

Okay, I resetted the latte config and although it did change the apps in my dock, the black background seems to stay unfortunatly. Are there other configs I should resset?

Try to right click on the dock, select "Edit Dock", click "Advanced" and check there.
I'm not on the system at the moment... Hopefully there's something interesting.

Maybe check also if this helps

1 Like

There is a "Background" setting with a purple box next to it but nothing happens when I click on it. It seems as if I can't modify it. It looks like this.

I checked both things and they are as desired.

I think the compositor is off.

Try pressing Alt-Shift-F12

 

p.s. That is a beautiful first post, @TheFibonacciEffect

4 Likes

Okay, I tried that and apparently nothing happened. What should happen? Are there any other ways to (re-)start the compositer?

PS: Thank you very much :slightly_smiling_face:

Well, make sure it's set to start on login:

System Settings :arrow_right: Display and Monitor :arrow_right: Compositor

"Enable Compositor on Startup" checked

Then log out and back in.

4 Likes

I couldn't agree more!

4 Likes

Okay, I found it!

In the Compositer settings ( System Settings :arrow_right: Display and Monitor :arrow_right: Compositor) there was a message displayed that KWin had crashed because of OpenGL (Screenshot).
I clicked Re-Enable openGL detection and restarted my laptop and now everything workes like it used to.
Propably OpenGL just crashed randomly and Kwin decided it will deactivate OpenGL so that KWin doesn't crash. (I did not do any driver upgrades)

Thank you very much for your help @filo @Catra. I really learned a lot, especially the Garuda Assistant seems great for troubleshooting.

3 Likes

Nice that it worked. :slight_smile:

My mistake.

We always mark the solution here, not the execution of the same. So I change it.

1 Like

The issue wasn't that enable compositor wasn't checked it was that KWin was not using OpenGL any more. So although looking into this menu was the critical step towards the solution it wasn't the solution itself, so if someone else with the same problem would look at the post, this would not solve it.
(Of course all the credit goes to @Catra lead me onto the right track!)

(If you have a point system for solutions, Catra could also edit her answer to make it the solution and get credit this way)

1 Like

Her

             

4 Likes

No, we have not.
So, I am sorry, it looks same for me :frowning:
:slight_smile: :smiley:

Catra will already know what will be the best to solve this "conflict". :blush:

1 Like

Yeah, I guess?

@TheFibonacciEffect has the full solution in his post, so - being the purpose of the solution marker is for future folks to find the actual solution quickly - I'd say put the mark there.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.