Latté dock flickering

Hello, I have this weird issue where my Latté dock flickers but the flickering is only visible on videos/when I share my screen.
I have tried resetting its config in Garuda Assistant but that didn't help.

Here is a bad video of how it looks for me (left) and how it looks when recording (right):
https://krypt0n.eu/share/latte_bug.mp4

garuda-inxi output:

System:
Kernel: 6.0.10-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=10754dab-b749-4309-8eb4-01f5e861e31e rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.26.3 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ATs product: X-DIABLO GAMER v: X-DIABLO Gamer
serial: <filter> Chassis: type: 3 v: X-DIABLO Gamer serial: <filter>
Mobo: ASUSTeK model: TUF GAMING B550-PLUS v: 2021-05-28 serial: <filter>
UEFI: American Megatrends v: 1804 date: 02/02/2021
CPU:
Info: model: AMD Ryzen 5 5600X socket: AM4 bits: 64 type: MT MCP arch: Zen 3
gen: 4 level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 32 MiB desc: 1x32 MiB
Speed (MHz): avg: 3700 min/max: 2200/4650 boost: enabled
base/boost: 3700/4650 scaling: driver: acpi-cpufreq governor: performance
volts: 1.1 V ext-clock: 100 MHz cores: 1: 3700 2: 3700 3: 3700 4: 3700
5: 3700 6: 3700 7: 3700 8: 3700 9: 3700 10: 3700 11: 3700 12: 3700
bogomips: 88634
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] vendor: ASUSTeK
driver: nvidia v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
status: current (as of 2022-10) arch: Turing code: TUxxx
process: TSMC 12nm built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 08:00.0 chip-ID: 10de:1f08 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 5760x1080 s-dpi: 92 s-size: 1590x301mm (62.60x11.85")
s-diag: 1618mm (63.71")
Monitor-1: DP-0 pos: primary,center res: 1920x1080 dpi: 93
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
Monitor-2: HDMI-0 pos: left res: 1920x1080 dpi: 93
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
Monitor-3: HDMI-1 pos: right res: 1920x1080 dpi: 93
size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX
2060/PCIe/SSE2 direct render: Yes
Audio:
Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel bus-ID: 1-2:2 v: kernel chip-ID: 3299:4e55 pcie:
gen: 3 class-ID: 0300 speed: 8 GT/s serial: <filter> lanes: 16
bus-ID: 08:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: SM950 Microphone type: USB
driver: hid-generic,snd-usb-audio,usbhid
Sound API: ALSA v: k6.0.10-zen2-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.60 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 5-3:4 chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 3.64 TiB used: 1.03 TiB (28.3%)
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P5PSSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 type: SSD serial: <filter> rev: P7CR403 temp: 42.9 C scheme: GPT
SMART: yes health: PASSED on: 21 hrs cycles: 24
read-units: 4,372,574 [2.23 TB] written-units: 3,212,040 [1.64 TB]
ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Samsung model: SSD 980 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7 temp: 38.9 C scheme: GPT
SMART: yes health: PASSED on: 73d 0h cycles: 724
read-units: 59,374,473 [30.3 TB] written-units: 101,377,772 [51.9 TB]
ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS541010A9E680
family: Travelstar 5K1000 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B sata: 2.6 speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: A560 temp: 28 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 241d 10h cycles: 1248
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10JPCX-24UE4T0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: 1A01 temp: 35 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 1y 344d 5h cycles: 317
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 246.09 GiB (26.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
maj-min: 259:1
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 246.09 GiB (26.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 246.09 GiB (26.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 246.09 GiB (26.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.53 GiB used: 1.72 GiB (11.1%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 70.8 C mobo: N/A gpu: nvidia temp: 58 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 31%
Info:
Processes: 388 Uptime: 5h 41m wakeups: 0 Memory: 15.53 GiB
used: 9.11 GiB (58.7%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
pkgs: 2158 libs: 554 tools: octopi,pamac,paru pm: appimage pkgs: 0
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.23
Garuda (2.6.9-1):
System install date:     2022-10-12
Last full system update: 2022-11-28 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Yes
Snapshots:               Snapper
Failed units:            plymouth-deactivate.service plymouth-start.service

Welcome to the Forums! :smiley:

Latte-Dock might become more unstable with time since no one really took over the maintenance since its main developer left last Summer.
Maybe someone can help on your specific issue, though, personally I can't help much about it, sorry.

Also I wanted to point out not to forget to reboot after you perform an update:

:smiley:

4 Likes

This might not be entirely related but I had some latte-dock related problems a few days ago though different. My latte-dock was working properly before and rebooting device did not help. What fixed it:

latte-dock --replace

followed by a reboot which corrected the erroneous behavior. I am asking to reboot because closing the konsole will kill the latte-dock. However, if you don't want to reboot and want your latte-dock to work even after closing the konsole the following command might help:

nohup latte-dock --replace &

Which creates a nohup.out file in your present working directory which you can delete.

Would it be possible to add 'Please reboot at the earliest opportunity.' (or something like) after 'System updated!' is displayed following the update?

That's a question for the Garuda Team, I'll let them decide.

1 Like

Not all updates require a reboot, only updates to major core components require this. So, a blanket reboot after updating notification is unlikely to be implemented.

3 Likes

This did not help. But thank you.

Ok, I found a fix, it seems like it's caused by the Blur desktop effect (https://i.imgur.com/rZm9lQj.png). Disabling it stopped the flickering.

5 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.