Latte-dock completely broken

Latte doesn't start. At all. I've tried latte-dock -r, reinstalling latte, latte-dock -d and starting it through KRunner and Konsole. None of that has worked. Can anyone help me with this?

Also, inxi -Fza results:

System:    Kernel: 5.13.7-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/timeshift-btrfs/snapshots/2021-08-05_15-20-42/@/boot/vmlinuz-linux-zen 
root=UUID=b9cbb8e7-f16d-4535-98a1-6173b4f3fc6a quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
base: Arch Linux 
Machine:   Type: Laptop System: LENOVO product: 80XH v: Lenovo ideapad 320-15ISK serial: <filter> Chassis: type: 10 
v: Lenovo ideapad 320-15ISK serial: <filter> 
Mobo: LENOVO model: LNVNB161216 v: SDK0J40679 WIN serial: <filter> UEFI: LENOVO v: 4WCN47WW date: 06/30/2020 
Battery:   ID-1: BAT0 charge: 22.7 Wh (94.6%) condition: 24.0/30.6 Wh (78.3%) volts: 8.4 min: 7.6 model: CPT-COS L16C2PB2 
type: Li-poly serial: <filter> status: Unknown 
CPU:       Info: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP arch: Skylake family: 6 model-id: 4E (78) 
stepping: 3 microcode: EA cache: L2: 3 MiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15999 
Speed: 2000 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 2000 2: 2000 3: 2000 4: 2000 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds mitigation: Microcode 
Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 520 vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1921 
class-ID: 0300 
Device-2: Acer EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:4 chip-ID: 5986:210f class-ID: 0e02 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting 
alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.1.6 direct render: Yes
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel alternate: snd_soc_skl
bus-ID: 00:1f.3 chip-ID: 8086:9d70 class-ID: 0403
Sound Server-1: ALSA v: k5.13.7-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.32 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000
bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo driver: ath10k_pci v: kernel
port: 3000 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 chip-ID: 0cf3:e500 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 4060 bus-ID: 00:17.0
chip-ID: 8086.282a rev: 21 class-ID: 0104
Drives:    Local Storage: total: 1.82 TiB used: 32.87 GiB (1.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: LDM2 scheme: GPT
Partition: ID-1: / raw-size: 61.93 GiB size: 61.93 GiB (100.00%) used: 32.77 GiB (52.9%) fs: btrfs dev: /dev/sda7 maj-min: 8:7
ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 103.5 MiB (40.4%) fs: vfat dev: /dev/sda1
maj-min: 8:1
ID-3: /home raw-size: 61.93 GiB size: 61.93 GiB (100.00%) used: 32.77 GiB (52.9%) fs: btrfs dev: /dev/sda7
maj-min: 8:7
ID-4: /var/log raw-size: 61.93 GiB size: 61.93 GiB (100.00%) used: 32.77 GiB (52.9%) fs: btrfs dev: /dev/sda7
maj-min: 8:7
ID-5: /var/tmp raw-size: 61.93 GiB size: 61.93 GiB (100.00%) used: 32.77 GiB (52.9%) fs: btrfs dev: /dev/sda7
maj-min: 8:7
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.62 GiB used: 620.5 MiB (16.7%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 42.5 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 211 Uptime: 6m wakeups: 1 Memory: 3.62 GiB used: 1.94 GiB (53.6%) Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1192 lib: 305 Shell: fish v: 3.3.1 default: Bash v: 5.1.8

Run latte through terminal and ull probably have ur answer from errors
What is the error output from konsole?

Have you tried with the button to restore default settings in the Garuda assistant?


Please :slight_smile: , explain to a non-English-speaking people what this means.

Because a lot of members here rely on electronic translators,
thank God no one needs books for that anymore,
I kindly ask everyone to refrain from using dialects or abbreviations.


That worked, thanks :slight_smile:

1 Like

an easier solution without needing to reset configuration of latte dock is to do the following. Atleast I did it this way. Today two things borked after update. I downgraded gtk3 to version 1:3.24.28-4 and latte dock to version 0.9.12-1.

sudo downgrade latte-dock
sudo downgrade gtk3

Thank you i have another issue with Latte-dock the downgrade fix it thank you a million times :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.