Latte-dock allows maximizing and moving windows behind it

Using default latte-dock config from Dragonized. Think it happened in the last few days when I updated.

Unsure if there's a solution, but if there is I would like to know it.

What is the easy way to downgrade packages by the way? Is there one for chaotic-aur stuff?

System:
  Kernel: 6.0.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=74b4d5d6-793e-49c5-b882-ea7d9611ad1c rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma v: 5.26.0 tk: Qt v: 5.15.6 info: latte-dock
    wm: kwin_wayland vt: 2 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Convertible System: LENOVO product: 81Q9 v: Yoga C940-14IIL
    serial: <superuser required> Chassis: type: 31 v: Yoga C940-14IIL
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0K17763 WIN
    serial: <superuser required> UEFI: LENOVO v: AUCN57WW date: 08/18/2020
Battery:
  ID-1: BAT1 charge: 32.0 Wh (100.0%) condition: 32.0/60.0 Wh (53.3%)
    volts: 8.5 min: 7.7 model: Celxpert BASE-BAT type: Li-poly serial: <filter>
    status: full
  Device-1: wacom_battery_0 model: Wacom HID 51E2 serial: N/A charge: 0%
    rechargeable: yes status: N/A
CPU:
  Info: model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
    gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xB2
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1171 high: 1500 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 967 2: 1500 3: 1101
    4: 1100 5: 1005 6: 1100 7: 1500 8: 1101 bogomips: 23961
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
    empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0 chip-ID: 8086:8a52 class-ID: 0300
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-1:2 chip-ID: 13d3:56b2 class-ID: 0e02
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.3
    compositor: kwin_wayland driver: X: loaded: intel dri: i965 gpu: i915
    display-ID: 0
  Monitor-1: eDP-1 model: LG Display 0x061f built: 2018 res: 1920x1080
    dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) v: 4.6 Mesa
    22.1.7 direct render: Yes
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-icl
    alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
    chip-ID: 8086:34c8 class-ID: 0401
  Sound API: ALSA v: k6.0.1-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:4 chip-ID: 8087:0026 class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 3 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 208.19 GiB (43.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB512HBJQ-000L2 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 3L1QEXF7 temp: 38.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 379.01 GiB size: 379.01 GiB (100.00%) used: 208.16 GiB
    (54.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 29.2 MiB
    (11.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 379.01 GiB size: 379.01 GiB (100.00%) used: 208.16
    GiB (54.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /var/log raw-size: 379.01 GiB size: 379.01 GiB (100.00%) used: 208.16
    GiB (54.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-5: /var/tmp raw-size: 379.01 GiB size: 379.01 GiB (100.00%) used: 208.16
    GiB (54.9%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 11.25 GiB used: 5.39 GiB (47.9%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 68.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 298 Uptime: 14h 56m wakeups: 54301 Memory: 11.25 GiB used: 6.42
  GiB (57.0%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 2414 pm: pacman pkgs: 2398
  libs: 480 tools: gnome-software,pamac,paru pm: flatpak pkgs: 16 Shell: fish
  v: 3.5.1 default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.22
e[1;34mGaruda (2.6.8-1):e[0m
e[1;34m  System install date:e[0m     2021-11-23
e[1;34m  Last full system update:e[0m 2022-10-13
e[1;34m  Is partially upgraded:  e[0m No
e[1;34m  Relevant software:      e[0m tlp NetworkManager
e[1;34m  Windows dual boot:      e[0m Probably (Run as root to verify)
e[1;34m  Snapshots:              e[0m Timeshift (maybe)
e[1;34m  Failed units:           e[0m systemd-networkd-wait-online.service 

A quick/easy thing to try before digging too deeply would be to reset the Latte config from Garuda Assistant--sometimes that is enough for it to revert back to working properly.

2 Likes

Also having this issue. I think it started after the KWin (and many other packages) update a couple days ago. Tried some Latte changes with no luck, haven't tried fully resetting Latte but I'd rather not have to since I'm not using the default Dragonized.

Switching to Xorg should fix this behaviour. I filed a bug report about this but there is no response yet.
https://bugs.kde.org/show_bug.cgi?id=459755

5 Likes

Thanks! I didn't end up switching to Xorg, but editing the top panel to dodge maximized works as it should still and I might even prefer that to having the dock always there so at least until a fix comes I'll chill here.

Didn't work, but maybe did seem to fix another issue I've been having with latte-dock, so thanks for the suggestion. Fortunately, I don't remember configuring anything myself other than the apps on my bottom dock.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.