Latest update ICU breaks Thunderbird-appmenu

Getting the following conflict and can't upgrade my system. Any suggestions?

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (70.1-1) breaks dependency 'libicui18n.so=69-64' required by thunderbird-appmenu
:: installing icu (70.1-1) breaks dependency 'libicuuc.so=69-64' required by thunderbird-appmenu

I see in the arch repo icu was updated tonight and
Provides: libicudata.so=70-64, libicui18n.so=70-64, libicuio.so=70-64, libicutest.so=70-64, libicutu.so=70-64, libicuuc.so=70-64
So I guess thunderbird-appmenu from the AUR needs a rebuild.
I don't know if the (nightly?) rebuild in the chaotic AUR fix it...

2 Likes

It only rebuilds automatically if the maintainer increases pkgrel, which didn't happen in this case though. I still rebuilt it (+bumped pkgrel), does it help?

5 Likes

Awesome, looks like it is upgrading without the error now. I wasn't for sure where the issue lied. If it was the maintainer, I was going to fill out a report, but... @dr460nf1r3 done ...did...his magic. Thanks guys!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.