Latest update breaks time/date from displaying in top bar

Hello, the latest update breaks the time and date display on the top bar.
image

inxi -Faz

System:    Kernel: 5.15.2-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=72071089-d419-485a-9a2f-14e721d62e38 rw
           [email protected] quiet
           cryptdevice=UUID=b29157b9-880f-47d4-9db6-d45198405171:luks-b29157b9-880f-47d4-9db6-d45198405171
           root=/dev/mapper/luks-b29157b9-880f-47d4-9db6-d45198405171 splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: i3 4.20.1 info: i3bar vt: 7 dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Dell product: Precision 5540 v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
           Mobo: Dell model: 03G9D9 v: A00 serial: <filter> UEFI: Dell v: 1.3.3 date: 09/25/2019
Battery:   ID-1: BAT0 charge: 41.5 Wh (100.0%) condition: 41.5/56.0 Wh (74.0%) volts: 12.9 min: 11.4 model: BYD DELL CP6DF9A
           type: Li-poly serial: <filter> status: Full
CPU:       Info: 6-Core model: Intel Core i7-9850H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6
           model-id: 9E (158) stepping: D (13) microcode: EA cache: L2: 12 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62399
           Speed: 990 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 990 2: 900 3: 900 4: 900 5: 901 6: 900 7: 900 8: 900
           9: 900 10: 901 11: 900 12: 900
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
           Type: srbds mitigation: TSX disabled
           Type: tsx_async_abort mitigation: TSX disabled
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:3e9b class-ID: 0300
           Device-2: NVIDIA TU117GLM [Quadro T1000 Mobile] vendor: Dell driver: N/A alternate: nouveau bus-ID: 01:00.0
           chip-ID: 10de:1fb9 class-ID: 0302
           Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-12:5 chip-ID: 0c45:6723 class-ID: 0e02
           Display: x11 server: X.Org 1.21.1.1 compositor: picom v: git-dac85 driver: loaded: modesetting display-ID: :0
           screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5")
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
           alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
           Sound Server-1: ALSA v: k5.15.2-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel bus-ID: 3b:00.0 chip-ID: 8086:2526 class-ID: 0280
           IF: wlp59s0 state: up mac: <filter>
           IF-ID-1: docker0 state: down mac: <filter>
Bluetooth: Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 8087:0025
           class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: no
           address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 34.13 GiB (7.2%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200S NVMe 512GB size: 476.94 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 22001030 temp: 37.9 C
           scheme: GPT
Partition: ID-1: / raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 34.13 GiB (7.2%) fs: btrfs dev: /dev/dm-0
           maj-min: 254:0 mapped: luks-b29157b9-880f-47d4-9db6-d45198405171
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 712 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
           ID-3: /home raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 34.13 GiB (7.2%) fs: btrfs dev: /dev/dm-0
           maj-min: 254:0 mapped: luks-b29157b9-880f-47d4-9db6-d45198405171
           ID-4: /var/log raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 34.13 GiB (7.2%) fs: btrfs dev: /dev/dm-0
           maj-min: 254:0 mapped: luks-b29157b9-880f-47d4-9db6-d45198405171
           ID-5: /var/tmp raw-size: 476.64 GiB size: 476.64 GiB (100.00%) used: 34.13 GiB (7.2%) fs: btrfs dev: /dev/dm-0
           maj-min: 254:0 mapped: luks-b29157b9-880f-47d4-9db6-d45198405171
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 30.96 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 52.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 3404 fan-2: 3395
Info:      Processes: 342 Uptime: 5m wakeups: 801 Memory: 30.96 GiB used: 4.1 GiB (13.3%) Init: systemd v: 249
           target: graphical.target tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1331 lib: 330 Shell: Zsh v: 5.8
           running-in: terminator inxi: 3.3.08
man i3status

pages show new time format.

           tztime local {
                   format = "%Y-%m-%d %H:%M:%S"
                   hide_if_equals_localtime = true
           }

           tztime berlin {
                   format = "%Y-%m-%d %H:%M:%S %Z"
                   timezone = "Europe/Berlin"
           }

old

format_time = "  %H:%M:%S | %a. %d.%m.%Y "

I fixed it in /etc/skel/
You can fix it in

.config/i3status/config
		   tztime local {
					format = "%H:%M:%S |  %a. %d.%m.%Y"
					locale = "de_DE.UTF-8"
		   }
4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.