Latest Garuda update deleted Chromium bookmarks and installed Garuda links instead

Hello,

with yesterday's Garuda update (29. Jan. 2022) my Chromium bookmarks are deleted and exchanged by Garuda links preset. I was able to re-contstruct them from exported bookmarks, but I would like to give a response, so this bug will not happen in the future. Chromium is not my main browser, so not a big deal at all, but I would ask to care about such unnecessary distraction.

Thank you!

Here the requested garuda-inxi output.



[details="Summary"]
```
System:
  Kernel: 5.16.3-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=3acd578e-46d5-4b3e-b159-d07795e6e296 rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: Cinnamon 5.2.7 tk: GTK 3.24.31 info: plank wm: muffin
    dm: LightDM 1.30.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 2501
    date: 04/07/2014
CPU:
  Info: model: AMD FX-8350 bits: 64 type: MT MCP arch: Piledriver
    family: 0x15 (21) model-id: 2 stepping: 0 microcode: 0x6000852
  Topology: cpus: 1x cores: 8 smt: enabled cache: L1: 384 KiB
    desc: d-8x16 KiB; i-4x64 KiB L2: 8 MiB desc: 4x2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 1445 high: 1737 min/max: 1400/4000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1424 2: 1737
    3: 1400 4: 1404 5: 1400 6: 1394 7: 1403 8: 1403 bogomips: 64212
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67df
    class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 driver: loaded: amdgpu,ati
    unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x285mm (34.2x11.2")
    s-diag: 915mm (36")
  Monitor-1: DisplayPort-0 res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.5x13.2") diag: 686mm (27")
  Monitor-2: DVI-D-0 res: 1366x768 hz: 60 dpi: 85
    size: 410x230mm (16.1x9.1") diag: 470mm (18.5")
  OpenGL: renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.44.0
    5.16.3-zen1-1-zen LLVM 13.0.0)
    v: 4.6 Mesa 21.3.5 direct render: Yes
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.3-zen1-1-zen running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.44 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel port: c000
    bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 4.2 TiB used: 1.58 TiB (37.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD PLUS 120GB
    size: 111.8 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 00RL scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DX001-1CM162
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC44
    scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD5000AACS-00G8B0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: 4C05
    scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital
    model: WD10EZEX-60WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: MBR
  ID-5: /dev/sde maj-min: 8:64 vendor: Western Digital
    model: WD20EARS-00MVWB0 size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: N/A serial: <filter> rev: AB51
    scheme: GPT
Partition:
  ID-1: / raw-size: 107.59 GiB size: 107.59 GiB (100.00%)
    used: 30.08 GiB (28.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 489 MiB size: 488 MiB (99.80%)
    used: 576 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 931.51 GiB size: 915.89 GiB (98.32%)
    used: 81.02 GiB (8.8%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  ID-4: /var/log raw-size: 107.59 GiB size: 107.59 GiB (100.00%)
    used: 30.08 GiB (28.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-5: /var/tmp raw-size: 107.59 GiB size: 107.59 GiB (100.00%)
    used: 30.08 GiB (28.0%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 3.73 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
  ID-2: swap-2 type: zram size: 15.53 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 29.6 C mobo: N/A gpu: amdgpu temp: 52.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1203
Info:
  Processes: 385 Uptime: 1h 42m wakeups: 0 Memory: 15.53 GiB
  used: 5.06 GiB (32.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1939 lib: 526 Shell: Zsh v: 5.8
  running-in: tilix inxi: 3.3.12
Garuda:
  System install date:     2021-12-06
  Last full system update: 2022-01-30
  Is partially upgraded:   No
  Using TLP:               No
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
```
[/details]


Report everything you have already attempted to solve your problem.

Done above.

Where exactly are these bookmarks stored?
No program changes data in the /home folder.
I move it vom #issues-assistance to #cinnamon
@Naman

4 Likes

Hi there, welcome to the community.

Bookmarks for chrome/based browsers are stored in ~/.config/<browser_Name>/Default/Bookmarks

So, these are unlikely to be modified by any updates.

Also, I use google-chrome (for google meet), and updated both yesterday and today. But my bookmarks are not cleaned. (I am also on Cinnamon)

Also, check ~/.config folder, there might be some backups.

And thanks for reporting, we will keep this in mind, and try to investigate for the reason.

4 Likes

Thanks all for caring about the issue and I'm glad to join the Garuda family after testing a lot of different distributions.

Well, usually I also would not point on Garuda update to have caused the loss of bookmarks. But, on the other side, it was exchanged by the Garuda pre-set of links to the website and the forums. So I thought it would be a good idea to report about the issue.

Side information, my /home directory is on a different hd (Ext4), probably this information may help to review the issue. Nevertheless none of the other browsers (Brave, FireDragon) was compromised.

Thread could be closed, as it was only posted to report about.

Thx!