Last update of sddm caused black screen after plymouth

  1. Happy Birthday!
  2. Your birthday? Aha! Now we know the culprit.
  3. Have you ever been known as a jinx (before)?

:smiley: :smiley: :smiley:

3 Likes

I upgraded yesterday before I found out about the problem. I only found out about it in the forum and I am glad and grateful that it did not affect me. :four_leaf_clover:

1.Thanks!
2.We, indeed, do! :smiley:
3.At my age, it's a really big probability! :wink:

1 Like

Is there still someone in the forum who is not affected by this problem, or am I the only one lucky?

All I will say at this point is I am very pleased it wasn't me what broke it, this time... Thanks to those much more worthy than I shall ever be for putting us (by us I mean serial dim-bulbs) out of our misery. Gonna load up on popcorn and watch it happen.

I can not upgrade my system until this is fixed
Also can someone please fix the typo in the name :grinning_face_with_smiling_eyes:

There have been a couple suggestions in this thread that would allow you to upgrade. Either ignore the package or change to the sddm-git package.

I update my system with this command

sudo pamac -Syu --ignore sddm

Or, you can update via pacman-manager unselecting the sddm update.

Typo in title fixed (plymouth now).
At least that one I can fix by myself.
:blush:

1 Like

Well Plymouth-git and Plymouth got updated in chaotic repo

Now the issue with sddm is gone

You just have to now update your system as usual without any ignores

14 Likes

Is it better to change back to plain sddm, from the-git version?

Don't really know the difference, though I will educate myself on the weekend :wink:

Yes. -git usually means that its build from master branch (-> bleeding edge). In this case it worked helped fixing the bug temporarily so using is fine, as the issue is resolved now its good to go back to the stable version.

10 Likes

That cleared it up and was along the lines, I thought. Thanks!

But how do I boot into my system to upgrade it, how do I disable splash screen

On the GRUB screen:

  1. Press E.
  2. In the kernel parameters (the line starting with "linux") look for the "splash" and remove it.
  3. Press F10 to boot.
1 Like

Hi, guys. I installed sddm-git (0.19.0.10) instead of just sddm (0.19.0.5), but the problem remained. Can you tell me what I missed?

Maybe this:

3 Likes

so, I just reinstalled plymouth, but the error still remains. Then I tried plymouth-git, without success.
P.S. I also updated the system.

Try sddm (0.19.0.5)

3 Likes

Thanks! Unfortunately, downgrade from 0.19.0.10 (git) to 0.19.0.5 helped