Last update of sddm caused black screen after plymouth

Same issue

1 Like

Ok so how do we recall a package.

I managed to do it in this way

They said they can not get to a tty.

Yes sure, not in that case.
So I guess that also booting removing splash from grub does not help?

1 Like

When on grub line press button E. In the boot string locate the Word splash and delete It, then ctrl+x

3 Likes

I am going to add SDDM to the ignorePkg section of pacman.conf for kde-multimedia. By default.

1 Like

Sure, I did it as well.
With all these troubles I hope it will be fixed soon...

Same issue here on Qtile. At this point it's probably an upstream issue

Should SDDM be in ignorePkg by default in kde-multimedia (Poll open for a few hours)

  • Yes
  • No
  • I do not care

0 voters

Yes, the root cause is definitely in the update linked by @dr460nf1r3 above imo

2 Likes

Temporarily, I think.

3 Likes

Yes indeed.
I'll jeep a close eye at pacman at each update since it always warns the skipped update of sddm along with the new version available

Maybe I should use it too? :thinking: I will test this

3 Likes

Yep, it just works. You can replace sddm with sddm-git

1 Like

I just hope no one will port there the patches causing the issue in sddm :blush:

1 Like

Yeah, I hope so too. Although it's unlikely

1 Like

@ExistingDude please stop posting your issues on this thread. You have opened your own separate thread on your issue.

As I see it your issue has the same root cause, but you have reused your home directory from a prior installation which may be contributing to your problems.

Please don't muddy the waters here. Keep your issues on your own thread. If you persist posting here I will purge all your posts from this thread.

Edit:

As I suspected your home directory issues were preventing you from correcting your problem. I am purging your posts from this thread so that others looking for a solution to this issue aren't confused by your unrelated posts.

2 Likes

When you remove splash from grub command line, I believe you have to also replace sddm-plymouth with sddm.
This should logically be done properly (during boot), if you also add 3 at grub command line, so you will boot to TTY (before SDDM), login and disable sddm-plymouth. Start sddm.service. If it succeeds, you can enable it (to permanently be in charge), but you should also remove splash at /etc/default/grub and plymouth from mkinitcpio (re-create images and grub after that).

Can someone confirm this works? (I cannot confirm and so I am not certain).

1 Like

Well, actually I removed splash as a first step only to check possibile error messages during the booting process.
By chance, I discovered that the issue was not occurring anymore in that way, so I took the chance to downgrade sddm, which had just been updated before the issue.
So, for me removing splash was only temporary and I'd prefer avoiding to change things now...

1 Like