Laptop freeze after 4 to 7 seconds of booting

inxi

System:
Host: study-hplaptop15sfq4xxx Kernel: 5.15.32-1-lts arch: x86_64 bits: 64
compiler: gcc v: 11.2.0 parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=565958d8-7fbb-482d-9659-0bd051c1dcfe rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: HP Laptop 15s-fq4xxx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 89BC v: 57.37 serial: <superuser required> UEFI: AMI
v: F.16 date: 10/18/2021
Battery:
ID-1: BAT0 charge: 40.8 Wh (99.5%) condition: 41.0/41.0 Wh (100.0%)
volts: 13.0 min: 11.4 model: HP Primary type: Li-ion serial: SerialNumber
status: charging cycles: 20
CPU:
Info: model: 11th Gen Intel Core i5-1155G7 bits: 64 type: MT MCP
arch: Tiger Lake family: 6 model-id: 0x8C (140) stepping: 2 microcode: 0x22
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1309 high: 3479 min/max: 400/4500 scaling:
driver: intel_pstate governor: powersave cores: 1: 628 2: 976 3: 888
4: 1416 5: 1274 6: 629 7: 3479 8: 1186 bogomips: 39936
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Hewlett-Packard
driver: i915 v: kernel ports: active: eDP-1
empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 0000:00:02.0
chip-ID: 8086:9a49 class-ID: 0300
Device-2: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo
bus-ID: 1-3:2 chip-ID: 0408:5365 class-ID: 0e02
Display: x11 server: X.Org v: 1.21.1.3 compositor: kwin_x11 driver: X:
loaded: modesetting alternate: fbdev,intel,vesa gpu: i915 display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 model: BOE Display 0x0991 built: 2020 res: 1920x1080
hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.0.1
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard
driver: sof-audio-pci-intel-tgl
alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
chip-ID: 8086:a0c8 class-ID: 0401
Sound Server-1: ALSA v: k5.15.32-1-lts running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:
Device-1: MEDIATEK MT7921 802.11ax PCI Express Wireless Network Adapter
vendor: AzureWave driver: mt7921e v: kernel bus-ID: 0000:01:00.0
chip-ID: 14c3:7961 class-ID: 0280
IF: wlp1s0 state: up mac: 90:e8:68:a2:05:af
Bluetooth:
Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8
bus-ID: 1-10:3 chip-ID: 13d3:3567 class-ID: e001 serial: 000000000
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: N/A
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev:
class-ID: 0104
Drives:
Local Storage: total: 476.94 GiB used: 6.94 GiB (1.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZH
size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: BTKA14943S24512A rev: HPS1
temp: 34.9 C scheme: GPT
Partition:
ID-1: / raw-size: 98.16 GiB size: 98.16 GiB (100.00%) used: 6.94 GiB (7.1%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 501 MiB size: 500 MiB (99.80%)
used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 98.16 GiB size: 98.16 GiB (100.00%)
used: 6.94 GiB (7.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 98.16 GiB size: 98.16 GiB (100.00%)
used: 6.94 GiB (7.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 98.16 GiB size: 98.16 GiB (100.00%)
used: 6.94 GiB (7.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.42 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 260 Uptime: 16m wakeups: 1933 Memory: 7.42 GiB
used: 2.09 GiB (28.2%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 11.2.0 Packages: pacman: 1137 lib: 292 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.14

I face small problem after installing Garuda. Garuda gets freeze after 4 to 7 seconds of booting. The only way to unfreeze is directly turn off laptop using the power key. I tried n number of solutions from forum. But each failed and finally I tried LTS-kernel and that issue is gone.

Edit : Both 5.17 zen and 5.17 tkg-bmq makes freezing problem and 5.15 lts and 5.18 mainline working just fine. Out of these 5.18 mainline works just great for me.

I am facing second problem on EVERY LINUX DISTRO including Garuda is, my laptop keyboard start working after 1 to 2 minutes of startup of system. I search about this issue many time but I didn't get its solution. This issue is not too big for me.

Try to give a look here (in the comments, the link in the first post is removed):

4 Likes

Yes, i8042.dritek=1 to GRUB Kernel parameter solves keyboard delay issue. Thank You @filo . :pray:

2 Likes

@filo your SearchFu is strong young grasshopper. :martial_arts_uniform:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.