Laptop display showing as "Unknown-1" in display settings


I’ve got an older laptop (Dell Latitude E6410) that I’ve been trying to get Garuda to work on but when I install Nvidia drivers it doesn’t want to recognize my display properly and shows it as “Unknown-1” in display settings, leaving me unable to change the resolution and overall behaving oddly. I used the Garuda Setup Assistant to install the Nvidia driver. I did try booting with the LTS kernel just to see if it would help, but got the same result as on the zen kernel.
In display settings itself, it shows the monitor as:
Unknown-1 (800x600)
and does not give me much else to work with. I have read through some posts on here and tried using X11 instead of weyland but was met with the same issue.

Kernel: 6.9.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ec6ce11f-676f-4555-8abf-dafcf1ade358 rw rootflags=subvol=@
quiet resume=UUID=abe504db-d289-4422-921d-1d59e5de184e loglevel=3
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Type: Laptop System: Dell product: Latitude E6410 v: 0001
serial: <superuser required> Chassis: type: 9 serial: <superuser required>
Mobo: Dell model: 0K42JR v: A01 serial: <superuser required>
uuid: <superuser required> UEFI: Dell v: A17 date: 05/12/2017
ID-1: BAT0 charge: 73.0 Wh (100.0%) condition: 73.0/84.7 Wh (86.2%)
volts: 12.5 min: 11.2 model: Samsung SDI DELL R289607 type: Li-ion
serial: <filter> status: full
Info: model: Intel Core i5 M 540 bits: 64 type: MT MCP arch: Westmere
gen: core 1 level: v2 built: 2010-11 process: Intel 32nm family: 6
model-id: 0x25 (37) stepping: 2 microcode: 0x11
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2793 min/max: 1199/2534 boost: enabled scaling:
driver: acpi-cpufreq governor: schedutil cores: 1: 2793 2: 2793 3: 2793
4: 2793 bogomips: 20215
Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: NVIDIA GT218M [NVS 3100M] vendor: Dell driver: N/A
alternate: nouveau, nvidia_drm, nvidia non-free: series: 340.xx
status: legacy (EOL~2019-12-xx) last: release: 340.108 kernel: 5.4
xorg: 1.20 arch: Tesla process: 40-80nm built: 2006-2013 pcie: gen: 1
speed: 2.5 GT/s lanes: 16 link-max: gen: 2 speed: 5 GT/s bus-ID: 01:00.0
chip-ID: 10de:0a6c class-ID: 0300
Display: wayland server: v: with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: N/A display-ID: 0
Monitor-1: Unknown-1 res: 800x600 size: N/A modes: N/A
API: EGL v: 1.5 platforms: device: 0 drv: swrast gbm: drv: kms_swrast
surfaceless: drv: swrast wayland: drv: swrast x11: drv: swrast
API: OpenGL v: 4.5 vendor: mesa v: 24.1.1-arch1.1 glx-v: 1.4
direct-render: yes renderer: llvmpipe (LLVM 17.0.6 128 bits)
device-ID: ffffffff:ffffffff memory: 7.56 GiB unified: yes
display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 4 device: 0 type: cpu name: llvmpipe
(LLVM 17.0.6 128 bits) driver: mesa llvmpipe v: 24.1.1-arch1.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib,wayland
Device-1: Intel 5 Series/3400 Series High Definition Audio
vendor: Dell Latitude E6410 driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403
Device-2: NVIDIA High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
link-max: gen: 2 speed: 5 GT/s bus-ID: 01:00.1 chip-ID: 10de:0be3
class-ID: 0403
API: ALSA v: k6.9.3-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Intel 82577LM Gigabit Network vendor: Dell Latitude E6410
driver: e1000e v: kernel port: 8040 bus-ID: 00:19.0 chip-ID: 8086:10ea
class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel Centrino Advanced-N 6200 driver: iwlwifi v: kernel pcie:
gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:422c
class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
Local Storage: total: 465.76 GiB used: 13.51 GiB (2.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B
speed: 3.0 Gb/s tech: SSD serial: <filter> fw-rev: 2B6Q scheme: GPT
ID-1: / raw-size: 456.66 GiB size: 456.66 GiB (100.00%)
used: 13.51 GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 456.66 GiB size: 456.66 GiB (100.00%)
used: 13.51 GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 456.66 GiB size: 456.66 GiB (100.00%)
used: 13.51 GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 456.66 GiB size: 456.66 GiB (100.00%)
used: 13.51 GiB (3.0%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
zswap: no
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/sda3 maj-min: 8:3
ID-2: swap-2 type: zram size: 7.75 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
System Temperatures: cpu: 74.0 C mobo: N/A sodimm: SODIMM C
Fan Speeds (rpm): cpu: 3813
Memory: total: 8 GiB available: 7.75 GiB used: 1.92 GiB (24.8%)
Processes: 216 Power: uptime: 2m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 3.06 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1314 libs: 376 tools: octopi,paru Compilers:
gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole
inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-06-12
Last full system update: 2024-06-12
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:

Something went wrong, the drivers are installed but are not loading.

Try switching to the open source driver nouveau:

Open the “Garuda Settings Manager” → “Hardware Configuration” and click on “Auto Install Open-Source Driver”.

Then reboot and check whether everything is working properly.

If you don’t need the full performance of the old Nvidia card, then just use the nouveau driver.

It appears the incorrect drivers have been installed. See here:

Remove the nvidia-dkms package:

sudo pacman -Rc nvidia-dkms

Install the 340xx version:

sudo pacman -S nvidia-340xx-dkms nvidia-340xx-settings nvidia-340xx-utils
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.