Lag and graphical artifacts on fullscreen

So i have a weird thing, it started a few days ago, the issue happens like this:

Whenever i have a fullscreen electron app (only testes with discord “vesktop” and chrome/brave) on my second display (4k connected via hdmi) it gets extremly laggy (like if the fps drops), and on primary display (1440p displayport) i get artifacts on open windows on mouse movement (green and black boxes around movement and changes on the area), as soon as exit fullscreen on the second display its gone. This issue happens even after a restart and is consistent. If i open some games (only tested with balatro) the issue does not happen, even if i put it on the second display, and after opening the game the issue seems to be gone (closed the game and it didnt happen o discord for the 5 minutes i kept testing), the issue is back if i restart or log out then back in. the other game i tested was helldivers 2 and when it open was laggy (the steam fps counter was above 180, buit the game felt choppy like it was at 30 or less), changing the kde settings and enablind hdr solved it and the game went back to normal (idk what is happening here), after log out then in and the issue is back.

I have tested both hyprland and kde x11, the issue was only noticeable in kde wayland. trying to measure desktop fps with the kde in built tool made the issue not happen. I tried downgrading, but i only had “recent” snapshots, and they all either didnt work (couldnt get to desktop) or had the issue. Ive tested both monitors on different ports, same issues.

My question is: is my GPU dying? I would guess not, as it is new (not even 6 months) and it doesnt seem to have the issue on other DEs and x11 (at least not that I could notice) and that I`m having a seemingly unrelated issue: google chrome isnt loading pages on kde wayland (it works on other DEs).

video of the artifacts

  Kernel: 6.8.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=8ae5615f-c6d8-4e31-89de-ac9490bb8ee9 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=357e86cf-c5fb-42d3-9c8d-9dd891f79fd6 loglevel=3 amd_iommu=on
    iommu=pt rd.driver.pre=vfio-pci kvm.ignore_msrs=1
    pcie_acs_override=downstream,multifunction amdgpu.sg_display=0
    clearcpuid=304 ibt=off
  Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A wm: kwin_wayland tools:
    avail: swaylock dm: SDDM Distro: Garuda base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7D73 v: 1.0 serial: N/A
  Mobo: Micro-Star model: MPG B650I EDGE WIFI (MS-7D73) v: 1.0
    serial: <filter> uuid: 49e6398a-67a4-5a16-afc1-047c16bb5ba3 UEFI: American
    Megatrends LLC. v: 1.20 date: 03/24/2023
  Device-1: hidpp_battery_8 model: Logitech G502 X LIGHTSPEED serial: <filter>
    charge: 86% rechargeable: yes status: discharging
  Info: model: AMD Ryzen 7 7700X socket: AM5 bits: 64 type: MT MCP arch: Zen 4
    gen: 5 level: v3 note: check built: 2022+ process: TSMC n5 (5nm)
    family: 0x19 (25) model-id: 0x61 (97) stepping: 2 microcode: 0xA601203
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 8 MiB desc: 8x1024 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 2565 high: 5360 min/max: 400/5573 base/boost: 4500/5550
    scaling: driver: amd-pstate-epp governor: performance volts: 1.3 V
    ext-clock: 100 MHz cores: 1: 5336 2: 400 3: 5349 4: 400 5: 400 6: 5360
    7: 400 8: 400 9: 400 10: 5350 11: 5349 12: 400 13: 5349 14: 400 15: 400
    16: 5350 bogomips: 144008
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
  Device-1: AMD Navi 31 [Radeon RX 7900 XT/7900 XTX/7900M]
    vendor: Sapphire PULSE driver: amdgpu v: kernel arch: RDNA-3 code: Navi-3x
    process: TSMC n5 (5nm) built: 2022+ pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: DP-2,HDMI-A-2 empty: DP-1,HDMI-A-1,Writeback-1
    bus-ID: 03:00.0 chip-ID: 1002:744c class-ID: 0300
  Device-2: AMD Raphael vendor: Micro-Star MSI driver: vfio-pci v: N/A
    alternate: amdgpu arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 13:00.0
    chip-ID: 1002:164e class-ID: 0300
  Display: server: X.Org v: 23.2.6 with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :1 screens: 1
  Screen-1: 0 s-res: 7680x2160 s-dpi: 96 s-size: 2032x572mm (80.00x22.52")
    s-diag: 2111mm (83.11")
  Monitor-1: DP-2 pos: primary,right model: LG (GoldStar) ULTRAGEAR
    serial: <filter> built: 2023 res: 3840x2160 hz: 165 dpi: 139 gamma: 1.2
    size: 700x390mm (27.56x15.35") diag: 800mm (31.5") ratio: 16:9 modes:
    max: 2560x1440 min: 640x480
  Monitor-2: HDMI-A-2 pos: left model: Samsung U32J59x serial: <filter>
    built: 2018 res: 3840x2160 hz: 60 dpi: 139 gamma: 1.2
    size: 700x390mm (27.56x15.35") diag: 800mm (31.5") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.5-arch1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 7900 XTX (radeonsi
    navi31 LLVM 17.0.6 DRM 3.57 6.8.7-zen1-1-zen) device-ID: 1002:744c
    memory: 23.44 GiB unified: no
  API: Vulkan v: 1.3.279 layers: 11 device: 0 type: discrete-gpu name: AMD
    Radeon RX 7900 XTX (RADV NAVI31) driver: mesa radv v: 24.0.5-arch1.1
    device-ID: 1002:744c surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.0.5-arch1.1 (LLVM
    17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:ab30
    class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 13:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 13:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Device-4: Micro Star USB Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-10:5
    chip-ID: 0db0:36e7 class-ID: 0300
  Device-5: SteelSeries ApS Arctis Nova Pro Wireless
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-5:2 chip-ID: 1038:12e0 class-ID: 0300
  Device-6: Kingston HyperX QuadCast
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 5-1:2 chip-ID: 0951:16df class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.8.7-zen1-1-zen status: kernel-api with: aoss
    type: oss-emulator tools: N/A
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: PipeWire v: 1.0.5 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin 4: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 0e:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp14s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 0f:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp15s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
  Device-1: MediaTek Wireless_Device driver: btusb v: 0.8 type: USB rev: 2.1
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-12:6 chip-ID: 0e8d:0616
    class-ID: e001 serial: <filter>
  Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: no address: <filter> bt-v: 5.2 lmp-v: 11
    status: discoverable: no pairing: no
  Local Storage: total: 3.64 TiB used: 1.69 TiB (46.5%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S2000G
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: SBM02103 temp: 33.9 C
    scheme: GPT
  SMART: yes health: PASSED on: 104d 15h cycles: 330
    read-units: 18,507,430 [9.47 TB] written-units: 12,371,952 [6.33 TB]
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Kingston model: SNV2S2000G
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: SBM02103 temp: 41.9 C
  SMART: yes health: PASSED on: 104d 11h cycles: 330
    read-units: 20,363,219 [10.4 TB] written-units: 11,155,369 [5.71 TB]
  ID-1: / raw-size: 1.75 TiB size: 3.57 TiB (203.81%) used: 1.69 TiB (47.4%)
    fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 25.9 MiB (8.6%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1
  ID-3: /home raw-size: 1.75 TiB size: 3.57 TiB (203.81%)
    used: 1.69 TiB (47.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-4: /var/log raw-size: 1.75 TiB size: 3.57 TiB (203.81%)
    used: 1.69 TiB (47.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  ID-5: /var/tmp raw-size: 1.75 TiB size: 3.57 TiB (203.81%)
    used: 1.69 TiB (47.4%) fs: btrfs block-size: 4096 B dev: /dev/nvme0n1p2
    maj-min: 259:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 61.96 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 68.16 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
  System Temperatures: cpu: 48.1 C mobo: 36.0 C gpu: amdgpu temp: 56.0 C
    mem: 64.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
  Memory: total: 64 GiB note: est. available: 61.96 GiB used: 7.2 GiB (11.6%)
  Processes: 386 Power: uptime: 54m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 24.76 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Packages: 2419 pm: pacman pkgs: 2390 libs: 587 tools: octopi,paru
    pm: flatpak pkgs: 29 Compilers: clang: 17.0.6 gcc: 13.2.1
    Shell: garuda-inxi (sudo) default: Bash v: 5.2.26 running-in: alacritty
    inxi: 3.3.34
Garuda (2.6.26-1):
  System install date:     2023-08-15
  Last full system update: 2024-04-20
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       Yes
  Failed units:

If theres anything else i can provide/test please inform me.

Which settings?

Seems Plasma 6 is in moment more beta than Hyprland :wink:

All in all it’s a settings problem.

1 Like

HDR, enabling it made it go away or be considerably less noticeable.

new developent is that minecraft does not seem to solve the issue like balatro did, and there was some weirdness on the image, like it had motion blur on everything during the game. Im probably goint to reinstall the system this week to see if it solves it. still if theres anything you think I should try please let me know, ive tryied reinstalling all packages and it did not solve, maybe deleting my .config folder?

seems so, i love hypland and use it on my laptop, but its too much of a hassle to set up for my desktop, to many things i do different there.

New new development, decided to mess with settings on the second (4k) display, settin the refresh rate to 30hz makes it look like 30fps (duh) but solves the artifacting issue on the primary display when discord is on fullscreen. maybe an issue with my hdmi cable or gpu driver/controler?

Check and see if your issue is related to what I had, there was a bug with Kwin 6.0.4-1 introduced on the 17th.

EDIT: The patch for this issue was released this morning, please run a system update, reboot, and verify if the issue is gone or not.

1 Like

tried to update, but i didnt seen kwin or plasma being updated, and the issue is still here. my kwin version is 6.0.4-1

setiing the primary monitors refresh rate to 60 hz also fixes the apparent lag and artifacts

got it on the update now, seems to have solved it, i coul notice it for a brief instant after boot when a notification from vesktop appeared, but it literaly lasted an instant and now seems to be solved

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.