KWallet-Pam not opening on login after update

Kernel: 6.2.10-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=7b049ab1-cf8c-4eb1-809e-b21343f9b233 rw rootflags=subvol=@
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Type: Desktop Mobo: MSI model: A68HM-E33 V2 (MS-7721) v: 9.0 serial: N/A
UEFI: American Megatrends v: 8.5 date: 11/01/2018
Info: model: AMD Athlon X4 860K socket: FM2 (P0) note: check bits: 64
type: MT MCP arch: Steamroller level: v2 built: 2014 process: GF 28nm
family: 0x15 (21) model-id: 0x30 (48) stepping: 1 microcode: 0x6003106
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB
desc: d-4x16 KiB; i-2x96 KiB L2: 4 MiB desc: 2x2 MiB
Speed (MHz): avg: 3700 min/max: 1700/3700 boost: enabled
base/boost: 3700/3700 scaling: driver: acpi-cpufreq governor: performance
volts: 1.3 V ext-clock: 100 MHz cores: 1: 3700 2: 3700 3: 3700 4: 3700
bogomips: 29541
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Baffin [Radeon RX 460/560D / Pro
450/455/460/555/555X/560/560X] vendor: PC Partner / Sapphire
driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm
built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 8 ports:
active: DP-1,HDMI-A-1 empty: DVI-D-1 bus-ID: 01:00.0 chip-ID: 1002:67ef
class-ID: 0300 temp: 54.0 C
Device-2: Logitech BRIO Ultra HD Webcam type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 8-2:3
chip-ID: 046d:085e class-ID: 0300 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 952x285mm (37.48x11.22")
s-diag: 994mm (39.12")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: primary,left model: Dell S2721H
serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: Dell P2217
serial: <filter> built: 2017 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
size: 474x296mm (18.66x11.65") diag: 559mm (22") ratio: 16:10 modes:
max: 1680x1050 min: 720x400
API: OpenGL v: 4.6 Mesa 23.0.1 renderer: AMD Radeon RX 460 Graphics
(polaris11 LLVM 15.0.7 DRM 3.49 6.2.10-zen1-1-zen) direct-render: Yes
Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
vendor: PC Partner / Sapphire driver: snd_hda_intel bus-ID: 8-2:3 v: kernel
chip-ID: 046d:085e pcie: gen: 3 class-ID: 0300 speed: 8 GT/s
serial: <filter> lanes: 8 bus-ID: 01:00.1 chip-ID: 1002:aae0
class-ID: 0403
Device-2: Creative Labs EMU10k1 [Sound Blaster Live! Series]
driver: snd_emu10k1 v: kernel bus-ID: 04:05.0 chip-ID: 1102:0002
class-ID: 0401
Device-3: Logitech BRIO Ultra HD Webcam type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
API: ALSA v: k6.2.10-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.68 status: n/a (root, process) with:
1: pipewire-pulse status: active 2: wireplumber status: active
3: pipewire-alsa type: plugin 4: pw-jack type: plugin
tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: wgpia0 state: unknown speed: N/A duplex: N/A mac: N/A
Local Storage: total: 1.35 TiB used: 481.27 GiB (34.9%)
ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT240M500SSD1
family: Micron Client SSDs size: 223.57 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: MU05 temp: 36 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 4y 184d 5h cycles: 1481
written: 22.78 TiB
ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT240M500SSD1
family: Micron Client SSDs size: 223.57 GiB block-size: physical: 4096 B
logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD serial: <filter>
rev: MU05 temp: 37 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 5y 39d 23h cycles: 788
written: 32.87 TiB
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD10EALX-009BA0 family: Blue size: 931.51 GiB block-size:
physical: 512 B logical: 512 B sata: 3.0 speed: 6.0 Gb/s type: N/A
serial: <filter> rev: 1H15 temp: 35 C scheme: GPT
SMART: yes state: enabled health: PASSED on: 5y 313d 1h cycles: 1979
ID-1: / raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 26.52 GiB (11.9%) fs: btrfs block-size: 4096 B dev: /dev/sdb2
maj-min: 8:18
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 612 KiB (0.2%) fs: vfat block-size: 512 B dev: /dev/sdb1 maj-min: 8:17
ID-3: /home raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 26.52 GiB (11.9%) fs: btrfs block-size: 4096 B dev: /dev/sdb2
maj-min: 8:18
ID-4: /var/log raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 26.52 GiB (11.9%) fs: btrfs block-size: 4096 B dev: /dev/sdb2
maj-min: 8:18
ID-5: /var/tmp raw-size: 223.27 GiB size: 223.27 GiB (100.00%)
used: 26.52 GiB (11.9%) fs: btrfs block-size: 4096 B dev: /dev/sdb2
maj-min: 8:18
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.58 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 35.4 C mobo: N/A gpu: amdgpu temp: 54.0 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 1095
Processes: 274 Uptime: 2h 2m wakeups: 0 Memory: 15.58 GiB
used: 3.67 GiB (23.5%) Init: systemd v: 253 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1389
libs: 379 tools: octopi,paru Shell: garuda-inxi (sudo) default: Bash
v: 5.1.16 running-in: konsole inxi: 3.3.26
Garuda (2.6.16-1):
System install date:     2023-04-05
Last full system update: 2023-04-07
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Yes
Failed units:

Hi There. There was a medium sized update yesterday which in included kwallet-pam 5.27.4-1
After a restart my system couldn't access passwords. Installing walletmanager and opening the wallet manually helps but this doesn't fix it opening automatically on login.
Is anyone else having trouble with this?
A snapshot restore to previous version fixed it and now its back to normal
I've ignored the kwallet update and the rest of the updates are fine.

After having another look last night it might also be because of changes to sddm.
Any idea's?

Do you mean the changes to Plymouth? Or did you change something with your SDDM?

I took this update on a system here just now and can't find any issues. The wallet is working normally, no intervention was needed.

cat /var/log/pacman.log | grep kwallet-pam
[2023-04-09T07:44:27-0400] [ALPM] upgraded kwallet-pam (5.27.3-1 -> 5.27.4-1)

This update also pulled down the hotfix which enabled sddm.service (since Plymouth has eliminated the need for their custom implementation):

cat /var/log/pacman.log | grep sddm.service
[2023-04-09T07:44:34-0400] [ALPM-SCRIPTLET] Created symlink /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/sddm.service.

Like I said, in my case everything is working normally.

Let's back up a step:

Can you explain more specifically what you mean by that?

If you are getting an error message, what does it exactly say? It could be a useful clue. :man_detective:

1 Like

Thank you for the reply, I must say I’ve struggled a bit with this for the last two days. I do not think it is related to the Plymouth/SDDM issues we had a couple of weeks ago. I re-enabled SDDM quite quickly and the Plymouth theme is is still using the Dr460nized theme. I am usually quite aware of what is happening with the OS install and also quite OCD and particular that everything is OK.

For a few years now, on boot my OS starts an instance of VLC with an automatic connection to one of my video cameras. Additionally, it auto starts Evolution mail with 4 email address’. Both these programs use passwords stored in the kwallet. Every thing was OK until a Garuda update updated kwallet-pam. Immediately afterwards, on the next restart, the passwords could not be accessed resulting in both programs asking for the password again. On auto-login, the wallet cannot be opened regardless of a system password, a blank password or a unique password. A return to a snapshot just before the update fixed this.

I narrowed this down to the kwallet-pam update and ‘ignored it’ in pacman.conf. All good.

But it was an important security update so I needed a fix. It turns out that the updated kwallet-pam is a bit more sensitive to auto-login and wont open kwallet if auto-login is used. There is actually a warning in kwalletmanager if you attempt this.

The ultimate fix is to turn off auto-login and set the kwallet password to that of the OS system login. Everything is fine again.

I suppose this is much more secure than an auto-login which also opens kwallet. Not so much on the desktop but this issue also affected two of my laptops which I travel with, auto-login and no kwallet password on a travelling laptop is not good .

So the fix for this was to disable auto-login, install kwalletmanager and set the kwallet password to the system password.

So, I need your help with last bit. In doing this, which I’m happy with, I’ve lost the dragon background picture in the sweet sddm theme. These sddm themes seen to be very sensitive to login changes. I’ve replaced the all white background with a dragon picture by Miordmiro and it does look rather good but I’d like the opportunity to revert back to the dragon. Its a bit like the aurora dragon wallpaper but slightly different.

So, lastly, what is the name, location and size of the dragon background in the customised sweet sddm theme?

Sorry for the long post and thanks.


It should be /usr/share/wallpapers/garuda-wallpapers/Malefor.jpg. It looks like it's 5.1 MiB.

1 Like

What did you think of the answer?
Not bad for an amateur.
PS, I'm not sure that's it.
This one :-

I'll probably get a telling of from SGS for posting a picture but after two days of this I don't care :slightly_smiling_face:
How long before I'm a Mod!

There are many pictures here in the forum, you don't seem to have noticed, many of them are linked for quality reasons. A good place to store them is Github or Gitlab, for example.

It's about avoidable images that affect texts, whether in the terminal or elsewhere.
Error messages in a small window consisting of one sentence, then posted here as a 3840x2160 pixel screenshot of the entire desktop.

Pictures of the black screen are also dispensable. We believe the users when they write that the screen is black. :smiley:

If you open your own forum, immediately,
but here with us, it might take longer.


Hi. Can someone help me with the name and location of the login picture above please. The Dragon one.

I'm not in front of a computer right now, but you should be able to just paste the path /usr/share/wallpapers/garuda-wallpapers/ into Dolphin and look at the thumbnails.

ls /usr/share/wallpapers/garuda-wallpapers/ | grep 'Dragon.png'
.rw-r--r-- 670k root  4 Feb 18:19  Aurora Dragon.png <-- no
.rw-r--r--  38k root  4 Feb 18:19  Black Dragon.png  <-- no
.rw-r--r-- 865k root  4 Feb 18:19  Dragon.png        <-- yes

The topic KWallet-Pam not opening on login after update was solved.

Please only one problem per thread.

Insert your own picture (Settings>User), or avatar, whatever, then reboot. If that's what you are referencing. :slight_smile: