KMail Error showing Akonadi PIM service not available

Hello everyone,

I am facing problem using KMail, as it says Akonadi PIM service not operational.
I have tried to change the local config by changing the ./local/share/akonadi folder to ./local/share/akonadi-old. And restarted my system so that Akonadi can make the default config file itself. But the result is same.
Below is the terminal output of kmali.

 ╭─[email protected] in ~ 
 ╰─λ kmail
qt.svg: link #path2410 is undefined!
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server...
org.kde.pim.akonadiserver: database server stopped unexpectedly
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection!
org.kde.pim.akonadiserver: executable: "/usr/bin/mysqld"
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/mohand/.local/share/akonadi/mysql.conf", "--datadir=/home/mohand/.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid")
org.kde.pim.akonadiserver: stdout: ""
org.kde.pim.akonadiserver: stderr: "2022-06-10 14:28:06 0 [Note] /usr/bin/mysqld (server 10.8.3-MariaDB) starting as process 6993 ...\n"
org.kde.pim.akonadiserver: exit code: 1
org.kde.pim.akonadiserver: process error: "Unknown error"
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...
Error loading text-to-speech plug-in "flite"
Cannot initialize model with data QJsonObject(). missing: QJsonValue(string, "urls")
org.kde.pim.akonadicore: Job error:  "" for collection: QVector()
org.kde.pim.akonadicore: Job error:  "" for collection: QVector()
org.kde.pim.messagelist: Failed to load tags  ""
org.kde.pim.mailcommon: failed to retrieve tags  ""

Here is the garuda-inxi output

 ╭─[email protected] in ~ 
 ╰─λ garuda-inxi 
System:
  Kernel: 5.18.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=f8411108-3b15-466f-be03-4b701b5a261f rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 81W1 v: IdeaPad 3 15ADA05
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 3 15ADA05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0Q55724WIN
    serial: <superuser required> UEFI: LENOVO v: E8CN30WW date: 07/28/2021
Battery:
  ID-1: BAT0 charge: 29.3 Wh (100.0%) condition: 29.3/35.0 Wh (83.8%)
    volts: 8.5 min: 7.5 model: SMP L16M2PB2 type: Li-poly serial: <filter>
    status: full cycles: 961
CPU:
  Info: model: AMD Ryzen 3 3250U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen/Zen+ note: check family: 0x17 (23) model-id: 0x18 (24)
    stepping: 1 microcode: 0x8108109
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 192 KiB desc: d-2x32 KiB; i-2x64 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1745 high: 2675 min/max: 1400/2600 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2675 2: 1408
    3: 1217 4: 1680 bogomips: 20761
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2
    mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 16 ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 02:00.0
    chip-ID: 1002:15d8 class-ID: 0300
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-5.1:5 chip-ID: 174f:118d class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: BOE Display 0x0812 built: 2018
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD Radeon Vega 3 Graphics (raven2 LLVM 13.0.1 DRM 3.46
  5.18.2-zen1-1-zen)
    v: 4.6 Mesa 22.1.1 direct render: Yes
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 02:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_pci_acp3x v: kernel
    alternate: snd_rn_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 02:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.2-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:c822
    class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-6:4 chip-ID: 0bda:c123 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 3 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 2.73 TiB used: 1.91 TiB (69.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: LFM1
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital
    model: WD My Passport 25E1 size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 1021 scheme: GPT
Partition:
  ID-1: / raw-size: 143.07 GiB size: 143.07 GiB (100.00%)
    used: 12.06 GiB (8.4%) fs: btrfs dev: /dev/sda9 maj-min: 8:9
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 50.6 MiB (52.7%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 143.07 GiB size: 143.07 GiB (100.00%)
    used: 12.06 GiB (8.4%) fs: btrfs dev: /dev/sda9 maj-min: 8:9
  ID-4: /var/log raw-size: 143.07 GiB size: 143.07 GiB (100.00%)
    used: 12.06 GiB (8.4%) fs: btrfs dev: /dev/sda9 maj-min: 8:9
  ID-5: /var/tmp raw-size: 143.07 GiB size: 143.07 GiB (100.00%)
    used: 12.06 GiB (8.4%) fs: btrfs dev: /dev/sda9 maj-min: 8:9
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 9.66 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 4.2 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda7 maj-min: 8:7
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 58.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 249 Uptime: 1h 37m wakeups: 1 Memory: 9.66 GiB
  used: 4.63 GiB (47.9%) Init: systemd v: 251 tool: systemctl Compilers:
  gcc: 12.1.0 Packages: pacman: 1321 lib: 343 Shell: fish v: 3.4.1
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.16
Garuda (2.6.3-2):
  System install date:     2022-06-04
  Last full system update: 2022-06-10
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            


Have I done anything wrong installing Kmail and Akonadi ??
Please help I want to use kmail instead of other mail clients available for Linux.

Could be this brand new bug?
https://bugs.kde.org/show_bug.cgi?id=455111

3 Likes

Do I have to wait for the bug to resolved by KDE ??

Yes, of course. Sorry about this.
No distro can solve bugs which are "upstream".
Anyway, please check this possible workaround at comment #6 of a previous bug report (the one I listed is now marked as "duplicate" of this one):
https://bugs.kde.org/show_bug.cgi?id=454948#c6

3 Likes

No it did not worked.

Let's wait and see. I will follow the bug report and update if any solution works out Akonadi PIM t be operational.

The following worked for me:

  • delete "~.local/share/akonadi/db_data" (make a backup first)
  • run "akonadictl start"

That creates a new, working DB.

Thanks for the help @filo

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

Hi all, just wanting to save someone some time. I recently installed Kalendar on several machines, all running Garuda. It would not launch. The issue is related to akonadi and it's database. Here is what I did to fix it on all of my computers, quoted from comment #9 in the linked thread:

- delete "~.local/share/akonadi/db_data" (make a backup first)
- run "akonadictl start"

That creates a new, working DB.

https://bugs.kde.org/show_bug.cgi?id=454948#c9

Thanks to our very own filo for pointing me in the right direction in this thread about KMail
https://forum.garudalinux.org/t/kmail-error-showing-akonadi-pim-service-not-available/20149/2?u=techtalk

3 Likes

That's correct, I had to do the same thing on my father's machine this week-end, I remembered your other post regarding KMail and made the connection with Akonadi, tnx to you for bringing it up! :smiley:

1 Like