Kioslave5 spams 20 dns queries per second

hey, i just had a problem where kioslave5 was spamming 20 dns queries per second, another odd thing was the query was for home, so it wasn’t even a real dns name? i “fixed” it by killing kioslave5 a few dozen times, but if it can happen once it can happen twice and frankly i don’t want to be dealing with that, does anyone know what i can do against that or how to figure out what program is “asking kioslave5 to query my dns server”?
i doubt the inxi will help, if you need any additional info please let me know, here’s the inxi anyways tho

System:
  Kernel: 6.7.2-hardened1-1-hardened arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 clocksource: tsc available: hpet,acpi_pm parameters: pti=on
    page_alloc.shuffle=1 BOOT_IMAGE=/@/boot/vmlinuz-linux-hardened
    root=UUID=372689e5-8a05-4c8d-b0a1-d5cb4d6fc475 rw rootflags=subvol=@
    rd.luks.uuid=bdc9d9a7-5505-4937-ac5a-6b24c7ab837d
    rd.luks.uuid=6c89d81b-0faf-4455-a69c-ed567e9a4272
    resume=/dev/mapper/luks-6c89d81b-0faf-4455-a69c-ed567e9a4272 loglevel=3
    ibt=off
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: B450-A PRO MAX (MS-7B86) v: 4.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: M.J0
    date: 06/30/2023
CPU:
  Info: model: AMD Ryzen 5 5500 bits: 64 type: MT MCP arch: Zen 3 gen: 4
    level: v3 note: check built: 2021-22 process: TSMC n7 (7nm)
    family: 0x19 (25) model-id: 0x50 (80) stepping: 0 microcode: 0xA50000D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1477 high: 3001 min/max: 400/4267 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 2994 2: 2992 3: 2947
    4: 400 5: 400 6: 400 7: 2994 8: 3001 9: 400 10: 400 11: 400 12: 400
    bogomips: 86260
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities: <filter>
Graphics:
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports:
    active: DP-2,HDMI-A-1 empty: DP-1,DP-3 bus-ID: 12:00.0 chip-ID: 1002:73ff
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_x11 driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,radeon,vesa dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x285mm (40.00x11.22")
    s-diag: 1055mm (41.54")
  Monitor-1: DP-2 mapped: DisplayPort-1 pos: primary,left
    model: Samsung C24F390 serial: <filter> built: 2019 res: 1920x1080 hz: 60
    dpi: 94 gamma: 1.2 size: 521x293mm (20.51x11.54") diag: 598mm (23.5")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: right model: HP V22e
    serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.4-arch1.2
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6600 (radeonsi navi23
    LLVM 16.0.6 DRM 3.56 6.7.2-hardened1-1-hardened) device-ID: 1002:73ff
    memory: 7.81 GiB unified: no
  API: Vulkan v: 1.3.276 layers: 7 device: 0 type: discrete-gpu name: AMD
    Radeon RX 6600 (RADV NAVI23) driver: mesa radv v: 23.3.4-arch1.2
    device-ID: 1002:73ff surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
    (LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.4-arch1.2 (LLVM
    16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 12:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 30:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 30:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Device-4: JMTek LLC. USB PnP Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-1.2:4 chip-ID: 0c76:161e class-ID: 0300
  API: ALSA v: k6.7.2-hardened1-1-hardened status: kernel-api tools: N/A
  Server-1: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.27 TiB used: 719.53 GiB (30.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P3SSD8
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR30A temp: 23.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LX005-1CW162
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5400 serial: <filter> fw-rev: LVD1 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT1000BX500SSD1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 054
Partition:
  ID-1: / raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
    used: 530.68 GiB (59.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 728 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
    used: 530.68 GiB (59.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d
  ID-4: /var/log raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
    used: 530.68 GiB (59.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d
  ID-5: /var/tmp raw-size: 896.86 GiB size: 896.86 GiB (100.00%)
    used: 530.68 GiB (59.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 34.36 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-6c89d81b-0faf-4455-a69c-ed567e9a4272
  ID-2: swap-2 type: zram size: 31.24 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 30.9 C mobo: N/A gpu: amdgpu temp: 27.0 C
    mem: 26.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
  Processes: 390 Uptime: 6m wakeups: 0 Memory: total: 32 GiB
  available: 31.24 GiB used: 4.56 GiB (14.6%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 1604
  pm: pacman pkgs: 1568 libs: 428 tools: octopi,paru pm: flatpak pkgs: 36
  Shell: fish v: 3.7.0 running-in: konsole inxi: 3.3.31
Garuda (2.6.22-1):
  System install date:     2023-11-03
  Last full system update: 2024-01-31
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut
  Windows dual boot:       No/Undetected
  Failed units:

This seems like a rather unusual issue that should stand out in search results.

Have you searched the Arch Linux forum and the internet in general for similar posted problems?

Have you searched for similar reports on the KDE bug tracker?

4 Likes

https://www.google.com/search?q=kioslave5&sourceid=chrome&ie=UTF-8

Google search.

Kioslave5 appears not to be located in the normal Arch or AUR repos. It’s an AppImage issue, apparently.

3 Likes

do you mean that something running as an appimage is generating those queries or do you think the actual appimage program is generating those?

also of course i tried to find out if other people have had the same problem, but i haven’t found any.

I have no idea. Why don’t you try removing the AppImage you installed and see? :slight_smile:

Most Arch-based users I know don’t touch those things.

Does this actually seem to be causing any serious issues aside from just spamming your logs?

Have you run htop to check for any increases in CPU or memory usage?

Have you checked your logs for any crash dumps?

Have you checked your logs for exactly when this issue began? Check if you performed an update just before this issue started. Check your Pacman log to see which packages were updated just before this began. You can try downgrading any package(s) that could be likely suspects and possibly related to this issue.

Have you tried creating another user account? Login as the new user and check if the problem exists there. If the issue is not present on the newly created user account, then it is likely a misconfiguration on your original account causing the problem.

I noticed you are using the hardened kernel. While there is nothing wrong with this, it would be a good idea to test others. Have you tested any more widely used kernels such as zen, or the linux kernel?

I personally find it doubtful that your issue is directly related to Garuda, (as I can’t recall seeing a similar report from any other Garuda user). IMO this is more likely to be a KDE issue. If you can not track down the cause, then it would seem you have 2 choices. Either live with the spamming of your logs or file a bug report to KDE.

Bug reports for KDE related issues an be initiated at:

https://community.kde.org/Get_Involved/Issue_Reporting

1 Like

Can you share the output of findmnt --real?

kioslave5 is part of the package kio5 on Arch.

kio is used for a lot of things. It would most likely by used by dolphin or some other KDE application. Do you have any logs that show the issue that we could review?

Also, if you want to search it, you would be better off searching for kioslave. It was only recently renamed kioslave5 on Arch due to the upcoming switch to plasma 6.

6 Likes

The output of findmnt --real is this:

TARGET                  SOURCE                                                         FSTYPE      OPTIONS
/                       /dev/mapper/luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d[/@]      btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,subvolid=256,subvol=/@
├─/home                 /dev/mapper/luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d[/@home]  btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,subvolid=257,subvol=/@home
│ └─/home/ash/Downloads /dev/sda1                                                      ext4        rw,relatime
├─/root                 /dev/mapper/luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d[/@root]  btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,subvolid=258,subvol=/@root
├─/srv                  /dev/mapper/luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d[/@srv]   btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,subvolid=259,subvol=/@srv
├─/var/cache            /dev/mapper/luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d[/@cache] btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,subvolid=260,subvol=/@cache
├─/var/log              /dev/mapper/luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d[/@log]   btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,subvolid=261,subvol=/@log
├─/var/tmp              /dev/mapper/luks-bdc9d9a7-5505-4937-ac5a-6b24c7ab837d[/@tmp]   btrfs       rw,noatime,compress=zstd:3,ssd,space_cache=v2,subvolid=262,subvol=/@tmp
├─/run/user/1000/doc    portal                                                         fuse.portal rw,nosuid,nodev,relatime,user_id=1000,group_id=1000
├─/boot/efi             /dev/nvme0n1p1                                                 vfat        rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,utf8,errors=remount-ro
└─/mnt/internal_ssd     /dev/mapper/internal_ssd                                       ext4        rw,relatime

What is this?

1 Like

no idea
edit: it looks like it has something to do with flatpak

I asked 6 separate questions over a week ago requesting info from the OP @ash3781. The OP ignored all of my requests for information.

Perhaps this was an oversight on your part @ash3781 , but I don’t see how you could possibly miss such a lengthy request for information on your own help request thread.

You obviously can’t be too interested in finding a solution if you refuse to answer questions put to you by forum moderators/assistants. As this issue seems to be more of an annoyance, rather than a serious problem I will leave it to you to track down the cause or file a bug report.

I am moving your thread to where posts go to die, as you have have not met the minimum basic expectation our forum requires, (providing the information necessary to find a solution).

I would suggest you please be more proactive when opening any help request in the future @ash3781. Please comply with all future requests for information if you wish to receive assistance on the Garuda forum.

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.