Kio-gdrive dolphin, loading indefinitely

Working in dolphin (so no konsole/terminal input), over Network > GDrive, the Loading folder... progress bar is scrolling indefinitely. My window is stuck at "Loading..."

  • It worked a month ago, but I haven't touched it since last semester ended.
  • sudo pacman -S kio-gdrive said it was up to date, did not reinstall
  • I removed my account and readded in the gui under Online Accounts.
  • Not sure where to look for logs, did a locate gdrive and that was less than helpful, or I just don't know what I'm looking for.
  • I was experiencing other issues after a few system changes last night, so I went to the prior day's snapshot. I am not sure this is what broke it since I haven't even tested it in a month.

I'd be glad to pull logs or add additional relevant detail if you feel there is something I'm missing. Thank you!

Start dolphin in konsole.
Check history from pacman if kde/kio-gdrive changed.


Thanks! This gave me a direction. I'll try reverting to a prior version 21.08.3-1:

╰─λ cat /var/log/pacman.log | grep gdrive
[2021-11-22T18:56:13-0600] [ALPM-SCRIPTLET] kio-gdrive 21.08.2-1
[2021-11-22T19:15:27-0600] [ALPM] upgraded kio-gdrive (21.08.2-1 -> 21.08.3-1)
[2021-12-16T09:57:20-0600] [ALPM] upgraded kio-gdrive (21.08.3-1 -> 21.12.0-1)
[2021-12-16T10:10:13-0600] [PACMAN] Running 'pacman -Su --needed appmenu-gtk-module ark bluedevil breeze bree>
[2022-01-20T06:50:01-0600] [ALPM] upgraded kio-gdrive (21.12.0-1 -> 21.12.1-1)
[2022-01-22T10:28:08-0600] [PACMAN] Running 'pacman -S kio-gdrive'

╰─λ sudo pacman -U /var/cache/pacman/pkg/kio-gdrive-21.08.3-1-x86_64.pkg.tar.zst

No dice. still hangs. No helpful info from running in konsole. :frowning:

╰─λ dolphin
Icon theme "gnome" not found.

It should be this bug:


Sounds about right.

It worked when I first installed Garuda. I've probably screwed enough up on this computer by not knowing what I'm doing early on, and still having a lot to learn. I think it's time for a fresh reinstall so I can apply what I've learned about this arch-based environment. We'll see if that drastic measure helps! :slight_smile:


As you prefer.
It is your system, you're the only one to know its status and what you did.
Anyway, as regards this bug, it will be still there of course after a reinstall.
This was for sure not your fault :wink:


I explored creating backups to reinstall, and all the symbolic links and config changes I made I realized it's going to be a whole weekend project of either script writing, or banging my head against a wall to get it to work again. :slight_smile:

We'll keep going and save that for another time.

Thank you for your help!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.