Keyboard settings problem on Wayfire/wayland (SOLVED)

Can I try to jump on that post since I have exactly same problem with garuda wayfire.

Here are my setups :

╭─[email protected] in ~
 ╰─λ cat /etc/vconsole.conf
File: /etc/vconsole.conf
FONT=ter-220n
KEYMAP=cf

 ╭─[email protected] in ~ took 163ms
 ╰─λ cat /etc/X11/xorg.conf.d/00-keyboard.conf
File: /etc/X11/xorg.conf.d/00-keyboard.conf
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section InputClass
        Identifier system-keyboard
        MatchIsKeyboard on
        Option XkbLayout ca
        Option XkbModel pc105
        Option XkbVariant multix
EndSection

 ╭─[email protected] in ~ took 166ms
 ╰─λ localectl status
   System Locale: LANG=fr_CA.UTF-8
       VC Keymap: cf
      X11 Layout: ca
       X11 Model: pc105
     X11 Variant: multix

 ╭─[email protected] in ~ took 195ms
 ╰─λ

I have read info on Arch wiki on how to setup correct keyboard, locale etc.
but no success. This is very naggy and I would like a solution .

Thank, sorry for late addition.

           BT

Solution to what? Explain how would you want your system to function on keyboard and how on applications language (different things)?

2 Likes

a solution for using the canadian french keyboard ... It keeps using the USA keyboard even if I have setup another keyboard.

This is wayland session.
I have no experience with wayland and wayfire settings.
Have you read any instructions/manuals/wiki on how wayland configures keyboard?

Explain where did you try to type and was not the correct layout.

  • console
  • Display Manager
  • desktop environment applications, terminals, shells...
1 Like

In Wayfire, we have Wayfire Config Manager (docked by default). In there you can go to "Input" and add options according to XKB rules, for example:

XKB layout: us,fr
XKB options: grp:alt_shift_toggle

Then you can switch using alt+shift

3 Likes

Nothing seems to work to change keyboard layout.
The keyboard is stuck with the US layout even if I don't use it.

I have tried with the Wayfire Config Manager (input) as suggested and nothing happened.
I have tried with the "Garuda Parameter Manager" (sorry if translation is not exact, I'm using a french language garuda). I accessed the Parameter Manager with the Garuda Welcome. From the "keyboard parameters", i can set the canadian french keyboard with the multix variant. It ask for sudo password and apply the selection. But the keyboard stays in US english always ... And if I come back to the "keyboard Parameters", they are back to US english like if I had never changed it.

This is a major problem for all people that use other keyboard than the US.

Still searching on my side for a solution. Could it be something related to security ???

regards,
BT

The console have the cf keyboard, but many characters don't show correctly.
Some accented vowel will show a small blank square.
And the rest under wayland and X11 will only use US keyboard even if the configuration files telling to use canadian french keyboard.

I have setup the 'Keyboard Parameters' to french canadian; I have set the Garuda config manager -> input to french canadian. I have checked in the wayfire.ini config and the canadian french keyboard is set too.

xkb_layout = cf
xkb_model = multix
xkb_options = grp:alt_shift_toggle
xkb_rules = evdev
xkb_variant =

I have read garuda and arch wikis and really nothing seems to work.

any ideas ????

What exactly was not helpful?
French specialities are not familiar to me. Have you checked this?
You may need to add an auto-executed command (using setxkbmap) in your shell's rc or other conf file.

Post from a wayland wayfire session terminal:

locale
localectl
sed -n '/\[input\]/ , /\[/p' "$HOME/.config/wayfire.ini" | grep -v "^\[\|^#"
grep "^$USER" /etc/passwd | cut -d ":" -f7

This needs a capable/proper font. Check your respective font setting.

3 Likes

Here are the outputs of the info asked :

type or paste code here
` ╭─[email protected] in ~
 ╰─λ locale
LANG=fr_CA.UTF-8
LC_CTYPE="fr_CA.UTF-8"
LC_NUMERIC=fr_CA.UTF-8
LC_TIME=fr_CA.UTF-8
LC_COLLATE="fr_CA.UTF-8"
LC_MONETARY=fr_CA.UTF-8
LC_MESSAGES="fr_CA.UTF-8"
LC_PAPER=fr_CA.UTF-8
LC_NAME=fr_CA.UTF-8
LC_ADDRESS=fr_CA.UTF-8
LC_TELEPHONE=fr_CA.UTF-8
LC_MEASUREMENT=fr_CA.UTF-8
LC_IDENTIFICATION=fr_CA.UTF-8
LC_ALL=

 ╭─[email protected] in ~ took 2ms
 ╰─λ localectl
   System Locale: LANG=fr_CA.UTF-8
       VC Keymap: cf
      X11 Layout: ca
       X11 Model: pc105
     X11 Variant: multix

 ╭─[email protected] in ~ took 200ms
 ╰─λ sed -n '/\[input\]/ , /\[/p' "$HOME/.config/wayfire.ini" | grep -v "^\[\|^#"
click_method = default
cursor_size = 24
cursor_theme = Sweet-cursors
disable_touchpad_while_mouse = true
disable_touchpad_while_typing = true
gesture_sensitivity = 1.000000
kb_capslock_default_state = false
kb_numlock_default_state = false
kb_repeat_delay = 400
kb_repeat_rate = 40
middle_emulation = false
modifier_binding_timeout = 400
mouse_accel_profile = default
mouse_cursor_speed = 0.000000
mouse_scroll_speed = 1.000000
natural_scroll = false
scroll_method = default
tap_to_click = true
touchpad_accel_profile = default
touchpad_cursor_speed = 0.000000
touchpad_scroll_speed = 1.000000
xkb_layout = cf
xkb_model =
xkb_options = grp:alt_shift_toggle
xkb_rules = evdev
xkb_variant = multix


 ╭─[email protected] in ~ took 9ms
 ╰─λ echo "But the keyboard is still US not cf ... this should be an accented e  : /"
But the keyboard is still US not cf ... this should be an accented e  : /

 ╭─[email protected] in ~
 ╰─λ grep "^$USER" /etc/passwd | cut -d ":" -f7
/bin/bash

 ╭─[email protected] in ~ took 8ms``

Me still mystified ???

Have you read the french article?

Well, the keyboard layout may be the issue here (not sure, you have to find out yourself, changing things).

I have no experience with sway, wayfire, or wayland. They are the factors that I don't know about. I have a pretty good understanding of Xorg, KDE and other DEs on locale, since I need it (Greek).

An obvious catch is

I suggest you do as suggested

to test if the preferred settings are applied (runtime and after reboot).

Also I don't know the real difference between French Canadian and French layouts. Might you need to find out what is the proper one?

Get available settings (you would know if/since you read Archwiki).
For example

localectl list-x11-keymap-layouts |  grep -i "ca\|cf\|fr"   # available Xorg keyb layouts
localectl list-keymaps |  grep -i "ca\|cf\|fr"  # available console keyb layouts
sudo grep -i "ca\|cf\|fr"  /etc/locale.gen  # available LANG options
localectl list-locales # current active generated

Sources:
Localization
Xorg - Keyboard_configuration - Viewing_keyboard_settings
Linux_console - Keyboard_configuration
Locale (look also the variables section)
Fonts - Non-latin_scripts

Give feedback from your testing results. :wink:

3 Likes

For your info, I can't use the french (fr) keyboard because it is an azerty keyboard and the canadian french keyboard is a qwerty keyboard. The french keyboard is not usable for me.

I have added the "xkbmodel=pc105" in garuda.ini config file to be sure. It has no effect that I can see.

here is my X config for the keyboard (generated by localectl) :

 ╭─[email protected] in ~ took 5ms
 ╰─λ cat /etc/X11/xorg.conf.d/00-keyboard.conf
File: /etc/X11/xorg.conf.d/00-keyboard.conf
# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "ca"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "multix"
EndSection

All configs seems to be setup correctly to canadian french an everything stays US. The setxkbmap does absolutly nothing, you can try to setup keyboard to fr and it will stay "us" in a alacritty shell under wayland... I guess that a tool for X isn't effective for wayland.

I will goback to my linux Arch or OpenSUSE on my other disk and check the differences with Garuda for anything related to language/keyboard/locale and see if I can come out with anything.

It makes the distro semi-usable for me and very frustrating. I have files with accented caracters and I want to type text in french with accent for communication with others. So it shall be a "nogo" if I can't find a solution.

But I'm still searching,

           Thanks for all who tried to help me up to now :+1:
                        BT

Whaaat? :astonished: You should have done this from the start!!! Go get some feedback! :wink:

I guess they are on wayland or other non-Xorg...

2 Likes

This is the system setting.
You should look for your user/local session setting, at running level (not only a config file.
Using Wayfire/Wayland is not for inexperienced users, so I guess you either become an expert (if not already :laughing: ), or move to an easier DE :man_shrugging:

The problem is solved. I have modified the ~/.config/wayfire.ini file to add the xkb_model. At first it didn't seems to have changed anything. But I went in the Garuda Setting Manager => Keyboard and reselected my canadian french keyboard as default keyboard. And then it started to work. My keyboard had switched to the french canadian keyboard suddenly.

Here is a print screen of the thing :

Here are my .config/wayfire.ini keyboard lines :

xkb_layout = ca
xkb_model = pc105
xkb_options = grp:alt_shift_toggle
xkb_rules = evdev
xkb_variant = multix

I'm still puzzled as why it wouldn't work before. On Arch the only thing specified is in the wayfire.ini file; and it's the keyboard layout, the variant, the rules. The model and option, are empty.

I still need to find a good documentation with good explications on how to handle those international stuff configuration.

Thank you all for the kind help.

I would like to help by giving feedback on the help received (with all due respect).

I would suggest not to tell others to find an easier desktop when solution is not easily found. Wayfire is a rather new desktop and documentation/tools need to improve. And all users are not english natives. The language barrier is there. It's making the person asking for help feels inferior. Linux configuration is complex and nobody know everything about it. And helping someone at distance is also complex. Misunderstanding are lurking ... I'm glad we succeeded to find a solution.

Thank you very much again for helping me,

               BT
5 Likes

Thank you for writing the solution to the forum.
I mark it solved.

You have to agree that this motivated you to do a better job on searching for a solution :stuck_out_tongue_winking_eye: . I apologize for working on your psychology :slightly_smiling_face: .
Thanks for your feedback. You are a very welcome Garuda community member! :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.