Keyboard layout keeys changing whenever the Desktop Environment is reloaded

I am using the Xfce desktop environment in Garuda Linux Lite, its good but the keyboard layout keeps changing whenever the desktop environment loads or whenever the computer restarts.

I have no idea how to fix this issue and it is really annoying please help...

Just go to settings and keyboard layouts and move your desired keyboard layout to the top and save settings. I hope it works :smiley:

3 Likes

Also you can try setting it via Garuda settings manager :face_with_raised_eyebrow:

3 Likes

Hi, The problem is: whenever I boot it up it changes to English (US) and I have to manually change it every time.

1 Like

Oh... apparently the English (US) Layout was at the top, I changed the layouts in Garuda Settings Manager and I think its fixed now.
Thank you so much!

2 Likes

Im having the same issue, but i want to keep it as English (US), it's going back to Australian (The one i chose when i installed it), everytime i reboot. Can you please explain to me where you changed it to solve it? That's how mine look like at this moment, and how i want to keep it. Cheer!

What's in etc/locale.conf? Might be the fix, too...

1 Like

Here's what i got.

LANG=pt_BR.UTF-8
LC_ADDRESS=pt_BR.UTF-8
LC_IDENTIFICATION=pt_BR.UTF-8
LC_MEASUREMENT=pt_BR.UTF-8
LC_MONETARY=pt_BR.UTF-8
LC_NAME=pt_BR.UTF-8
LC_NUMERIC=pt_BR.UTF-8
LC_PAPER=pt_BR.UTF-8
LC_TELEPHONE=pt_BR.UTF-8
LC_TIME=pt_BR.UTF-8

Looks like what you set once - it should be persistent. You can edit it in that file to be what you want - or access its settings a number of other ways. Here is a quick rundown from the web..

which should help if you don't have it from the Archwiki or elsewhere :grin:

1 Like