Keyboard Keeps Reverting Back To US QWERTY No Matter What I Do

It has been a few months since i last used Garuda i left it because it kept the us keyboard layout no matter what i do in in the setting it shows that i already have colemak layout but it's us qwerty. I was using Arch Linux till now. I am back Garuda to face the same issue again.

I have to "setxkbmap us colemak" every time. i have tried making a script that will run at the time of login to execute this command but this didn't worked. From arch wiki "localectl set-keymap --no-convert us colemak" still not worked. I edited the vconsole file and set "KEYMAP=colemak" still not worked please help.

garuda-inxi

System:
Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=88d40fab-c2cd-49f9-9b45-4b2e28669658 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=972e9645-4a5a-43af-b6dc-99972de5ab3a loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: INTEL model: H61 serial: <superuser required>
UEFI: American Megatrends v: 4.6.5 date: 03/05/2019
CPU:
Info: model: Intel Core i3-2120 bits: 64 type: MT MCP arch: Sandy Bridge
gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
model-id: 0x2A (42) stepping: 7 microcode: 0x2F
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 3286 high: 3300 min/max: 1600/3300 scaling:
driver: intel_cpufreq governor: performance cores: 1: 3293 2: 3293 3: 3261
4: 3300 bogomips: 26341
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GF119 [GeForce GT 610] driver: nvidia v: 390.157
alternate: nouveau,nvidia_drm non-free: series: 390.xx+ status: legacy-active
(EOL~late 2022) arch: Fermi code: GF1xx process: 40/28nm built: 2010-16
pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:104a class-ID: 0300
Display: x11 server: X.Org v: 21.1.5 with: Xwayland v: 22.1.6
compositor: kwin_x11 driver: N/A display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x261mm (19.02x10.28")
s-diag: 549mm (21.61")
Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102
size: 479x260mm (18.86x10.24") diag: 545mm (21.46") modes: N/A
API: OpenGL v: 4.6.0 NVIDIA 390.157 renderer: GeForce GT 610/PCIe/SSE2
direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20
class-ID: 0403
Device-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
chip-ID: 10de:0e08 class-ID: 0403
Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.63 running: yes
Network:
Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
chip-ID: 10ec:8136 class-ID: 0200
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-1.2:4 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 1.93 TiB used: 22.27 GiB (1.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: GALAX model: GAMER L TA1D0120A
size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: SSD serial: <filter> rev: 61.3 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500418AS
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
type: HDD rpm: 7200 serial: <filter> rev: HP35
ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital
model: WD15SMRW-11YNDS1 size: 1.36 TiB block-size: physical: 512 B
logical: 512 B type: HDD rpm: 5400 serial: <filter> rev: 1020
Partition:
ID-1: / raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 22.27 GiB (21.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 22.27 GiB (21.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 22.27 GiB (21.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 102.69 GiB size: 102.69 GiB (100.00%)
used: 22.27 GiB (21.7%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 7.72 GiB used: 1.8 MiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3 maj-min: 8:3
Sensors:
System Temperatures: cpu: 58.0 C mobo: N/A gpu: nvidia temp: 60 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info:
Processes: 222 Uptime: 24m wakeups: 0 Memory: 7.72 GiB
used: 3.27 GiB (42.3%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.0 Packages: 1976 pm: pacman pkgs: 1971
libs: 558 tools: gnome-software,octopi,pamac,paru pm: flatpak pkgs: 5
Shell: fish v: 3.5.1 running-in: konsole inxi: 3.3.24
Garuda (2.6.10-1):
System install date:     2022-12-14
Last full system update: 2022-12-15
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       No/Undetected
Snapshots:               Snapper
Failed units:

This is in GNOME, correct?

NO it's KDE Dragonised

You could add it to your fish config.

micro ~/.config/fish/config.fish

Add something like this, to run automatically if your display is up:

if [ "$DISPLAY" ]
     setxkbmap us colemak
end
1 Like

Are you setting the layout per Application or Global?

i want it to be global. I didn't quite understand your question but to change the layout i type "setxkbmap us colemak"

it didn't quite work, it will only work when i open the terminal.
i still have to type password in qwerty during log in

You can set this Global using KDE's native Keyboard Layout settings in System Settings.
I am not on my machine so I can't provide a screenshot now. :frowning:

1 Like

i did set it global but after the reboot. it shows colemak but it's actually qwerty. Some kind of bug

Yes, it won't work until you log in.

What do you have in /etc/vconsole.conf? Those are the settings systemd should honor from boot.

According to this, you are going to want to have either

KEYMAP=us
KEYMAP_TOGGLE=colemak

or

KEYMAP=colemak

:point_up: The documentation sort of suggests the first is correct, but the thread I linked has a few folks who mentioned it doesn't work for them but KEYMAP=colemak does. The comments are from 2016, so maybe try both.

1 Like

I did tried that earlier but it didn't work

Could this help?
https://wiki.archlinux.org/title/Xorg/Keyboard_configuration#Using_setxkbmap
It could be e.g. setxkbmap us -variant colemak, can be made persistent in xinitrc or xprofile

it didn't work i read the wiki but nothing helps out it only sets the keymap temporary but after reboot it always goes back to qwerty.

When you boot up and it is not working, what is in this file?

FONT=ter-220n
KEYMAP=colemak

before boot up and after it's the same

Is this one useful?
[SOLVED] Possible to set Norwegian Colemak-layout in console? / Newbie Corner / Arch Linux Forums

ckbcomp -layout no -variant colemak > no-colemak.map
gzip no-colemak.map
sudo mv no-colemak.map.gz /usr/share/kbd/keymaps/i386/colemak/

What is the output of localectl?

System Locale: LANG=en_IN
VC Keymap: colemak
X11 Layout: us
X11 Model: pc104
X11 Variant: colemak

Before and after the reboot it's the same

nope

cat /etc/mkinitcpio.conf

Double-check keymap is in your HOOKS, then rebuild the initramfs.

sudo mkinitcpio -P

Reboot, and test again afterward. :crossed_fingers:

If it's still not working, check for any interesting output on sudo systemctl status systemd-vconsole-setup.service. If there is no output, try restarting:

sudo systemctl restart systemd-vconsole-setup.service
1 Like