Keyboard(g513) and networking(wired) not working on boot

Hello.

Since today my system has been taking forever to boot and the keyboard (g513) and networking (wired) don't work until a good 5 minutes after I login to kde. The keyboard is completely unresponsive until openrgb starts up and then strangely open rgb doesn't detect the keyboard until I exit and relaunch.

I tried restoring snapshots from yesterday (which is before I had these issues) and I still get these issues

logs

log errors only

EDIT: forgot to mention the plasma error can be ignored. It is caused by a wallpaper plugin I have to use wallpaper engine wallpapers I did test unsetting that plugin and the only difference is I don't get that core dump

inxi
inxi -Faz
System:    Kernel: 5.14.13-208-tkg-pds x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: intel_pstate=passive BOOT_IMAGE=/@/boot/vmlinuz-linux-tkg-pds-generic_v3
           root=UUID=ef15347e-a4da-4628-afc3-2bff20cbb710 rw [email protected] quiet nvidia-drm.modeset=1 splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           resume=UUID=e7745511-30a0-4b3d-93c1-4bc3daa8b2b8 loglevel=3 sysrq_always_enabled=1 nowatchdog
           Desktop: KDE Plasma 5.23.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux
           base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: X470 Taichi serial: <filter> UEFI: American Megatrends v: P3.50
           date: 07/18/2019
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3 serial: <filter>
           charge: 10% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ family: 17 (23) model-id: 8 stepping: 2
           microcode: 800820D cache: L2: 3 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86477
           Speed: 4117 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 4117 2: 4123 3: 4120 4: 4102 5: 4092
           6: 4115 7: 4112 8: 4078 9: 4123 10: 4101 11: 4100 12: 4097
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 0e:00.0 chip-ID: 10de:1b80 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1
           Screen-1: 0 s-res: 6400x2160 s-dpi: 102 s-size: 1594x543mm (62.8x21.4") s-diag: 1684mm (66.3")
           Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 52 size: 1872x1053mm (73.7x41.5") diag: 2148mm (84.6")
           Monitor-2: DP-0 res: 2560x1080 dpi: 81 size: 798x334mm (31.4x13.1") diag: 865mm (34.1")
           OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44 direct render: Yes
Audio:     Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 0e:00.1
           chip-ID: 10de:10f0 class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASRock driver: snd_hda_intel v: kernel
           bus-ID: 10:00.3 chip-ID: 1022:1457 class-ID: 0403
           Sound Server-1: ALSA v: k5.14.13-208-tkg-pds running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: no
           Sound Server-5: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel bus-ID: 08:00.0
           chip-ID: 8086:24fb class-ID: 0280
           IF: wlp8s0 state: down mac: <filter>
           Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel port: d000 bus-ID: 0a:00.0
           chip-ID: 8086:1539 class-ID: 0200
           IF: enp10s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           IF-ID-1: anbox0 state: down mac: <filter>
           IF-ID-2: virbr0 state: down mac: <filter>
Bluetooth: Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-9:7 chip-ID: 8087:0aa7
           class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 2.27 TiB used: 2.73 TiB (120.2%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 41.9 C
           scheme: GPT
           ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung model: SSD 960 EVO 250GB size: 232.89 GiB block-size:
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 3B7QCXE7 temp: 32.9 C
           scheme: GPT
           ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DX002-2DV164 size: 1.82 TiB block-size:
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC41 scheme: GPT
Partition: ID-1: / raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 127.51 GiB (59.2%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 563 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
           ID-3: /home raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 127.51 GiB (59.2%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-4: /var/log raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 127.51 GiB (59.2%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-5: /var/tmp raw-size: 215.45 GiB size: 215.45 GiB (100.00%) used: 127.51 GiB (59.2%) fs: btrfs
           dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 50 (default 100)
           ID-1: swap-1 type: partition size: 17.18 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
           ID-2: swap-2 type: zram size: 15.55 GiB used: 10 MiB (0.1%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 54.2 C mobo: 36.0 C gpu: nvidia temp: 49 C
           Fan Speeds (RPM): fan-1: 0 fan-2: 1401 fan-3: 1304 fan-4: 1516 fan-5: 1210 gpu: nvidia fan: 0%
           Power: 12v: N/A 5v: N/A 3.3v: 3.30 vbat: 3.28
Info:      Processes: 483 Uptime: 4m wakeups: 2 Memory: 15.55 GiB used: 8.66 GiB (55.7%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 2139 lib: 563 flatpak: 0 Shell: fish
           v: 3.3.1 default: Bash v: 5.1.8 running-in: alacritty inxi: 3.3.08

I'd try linux-zen as a first step to check it's not an issue with this particular kernel variant.

Tried it and the default arch lts kernel same error

It might be worth testing linux-hardened.

I assume you performed a system update and this didn't just happen out of the blue.

Same result and yeah it doesn't seem to be caused by system updates as i tried loading a snapshot like i said in my original post

Also the last update i did was to xorg and Nvidia but the keyboard and everything else was working after reboot from that update

So... what else did you change?

1 Like

I was just playing with OpenRGB

(Working with one of the devs to solve some startup issues and at one point i rebooted and started having issues with my keyboard) today so only thing I can think of is it somehow damaged my keyboard. But i do have alot of strange issues in the journal i posted above. Some even with Nvidia moderating (though its probably unrelated)

I asked because, if there was no update involved that makes me suspect hardware as a factor.

Double check that all cables are firmly seated and undamaged. Test an alternate keyboard if one is available, (preferably a USB KB).

An rmmod of your network driver, followed by a modprobe of the network driver will probably be enough to restore your connection.

Edit:

Just looked over your error log. With all those module errors, I would also suggest testing the fallback kernel.

2 Likes

which one is the fallback kernel? also yeah I do have another non rgb keyboard and that does work on startup with no issues. i still get the same usb 1-1.1: device descriptor read/64, error -110 though (with my Logitech keyboard disconnected) so something is still up there

Try adding iommu=soft to your kernel boot parameters.

The fallback kernel can be selected from the grub boot menu choices.

Edit:

Test the alternate keyboard and the original on a USB 2 bus.

1 Like

My board only has usb 3 ports and the fallback initramfs(Im assuming that's what you meant) doesn't change anything, but
iommu=soft seems to have fixed the keyboard and networking issues although I'm still getting all those usb 1-1.1: device descriptor read/64, error -110 errors still . also its strange that I didn't need to add iommu=soft before

Sounds like a kernel regression. This could also be affected by your bios. Update your bios if a newer version is available. If you have updated your bios recently then you may want to downgrade your bios.

Those errors are reminiscent of errors I have on an old Gigabyte mobo with USB and Ethernet issues. I have to use the iommu=soft boot param or my USB 3 does not function correctly. My Ethernet is unaffected, but some people also have problems with their LAN card. That is how I twigged immediately on trying the same boot param for your issue.

Usually a bios update or kernel fix is required to correct this kind of issue.

1 Like

no i havent touched the bios ever since I bought the board because of this warning
https://www.asrock.com/MB/AMD/X470%20Taichi/index.asp#BIOS

*ASRock do NOT recommend updating this BIOS if you are going to use Pinnacle, Raven or Summit Ridge CPU on your system. on their page so I'm scared it will brick my board since I am using pinnacle

but yeah looks like it might be a kernel regression or something though I don't remember updating the kernel recently and I do have the same issue on the lts version

Is it possible you have physically damaged one of your USB ports?

The other solution is to purchase a USB 2 controller add in card (if you don't want to use the boot param). That parameter generally interferes with virtualization technologies, but there are alternate params that generally don't.

If you'd like more USB ports then an addin USB 2 controller is reasonably cheap workaround.

1 Like

Actually if you check your motherboard schematic you probably already have an onboard USB 2 controller built in. They probably just never included USB 2 connector cables as most people really don't want to use the old tech. USB 2 speeds are more than adequate for a keyboard after all.

Likely all you will need is the USB 2 cable and plate to add into an open slot at the rear of your computer. I think they can be found for $10-15 dollars or possibly even less.

1 Like

yeah, might have to try that. doubt the port is damaged otherwise the non-rgb keyboard would not have been working and the boot pram wouldn't have fixed it I think. I'm thinking of trying a bios update anyway as technically this board did come with a one of those versions that supposedly doesn't work on pinnacle, and this bios version has a known issue with virtualization so I need to update for that anyway and I do have a backup board if something goes wrong. thanks for the help!

1 Like

updating to the latest BIOS didn't fix it and worse it breaks XMP memory support (computer goes into a shut off turn on shut off loop) I'm going to see if I can downgrade back as there might be other issues and its not even solving the original problem

EDIT: I downgraded back to 3.50 which is the last version that asrock says is safe for my cpu and know everything works and all the usb descriptor errors are gone now :confounded: (that is the version I before that was giving me issues (but like I said my board actually came with a newer version forgot which one it was a while ago and then I downgrade to 3.50 and it was working fine until yesterday))

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.