Key xxxxx could not ne looked up remotely

Hello. Trying to update my system but fails with key importing. I've searched around here and found multiple posts that all point to the tutorial page specifically for this issue. I've followed the tutorial (as you'll see below). I've completed everything including fully refreshing the key ring. This is what happens now when I start from the beginning. Note garuda-inxi is not installed on my system and I cannot install it due to this keyring issue. Hopefully I have formatted my konsole correctly.

From first step in the tutorial:
sudo pacman -Sy archlinux-keyring chaotic-keyring

:: Import PGP key 0706B90D37D9B881, "Chaotic-AUR Wild Bear Node <[email protected]>"? [Y/n]
error: key "0706B90D37D9B881" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

Also make sure your system clock is correct!
  • DONE

Of course, it's also possible that the package file actually is corrupt. Remove it from /var/cache/pacman/pkg/ so pacman will download it again.

sudo rm /var/cache/pacman/pkg/*.part DONE

sudo pacman -Sy archlinux-keyring chaotic-keyring
Same prob as above with Wild Bear....

sudo pacman-key --refresh-keys
Took ages, and lots of red ERROR: Could not update key: xxxxxxxxxxx

sudo pacman-key --refresh-keys --keyserver hkps://keyserver.ubuntu.com
Lots of error retrieving xxxxxxxxxxxx messages but only a few in Red! Also took ages.
Also got:

gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
gpg: error retrieving '[email protected]' via WKD: General error
gpg: error reading key: General error
==> ERROR: Could not update key: 6BC26A17B9B7018A

Anyhoo, let's try again:

sudo pacman -Syu
password for sid: 
:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
chaotic-aur                              1566,6 KiB   524 KiB/s 00:03 [----------------------------------------] 100%
:: Starting full system upgrade...
:: Replace garuda-settings-manager-knotifier-git with chaotic-aur/garuda-system-maintenance? [Y/n] 
:: Replace hwids with core/hwdata? [Y/n] 
:: Replace kodi-common with community/kodi? [Y/n] 
:: Replace kvantum-qt5 with community/kvantum? [Y/n] 
:: Replace os-prober-garuda with chaotic-aur/os-prober-btrfs? [Y/n] 
resolving dependencies...
:: There are 4 providers available for pipewire-session-manager:
:: Repository extra
1) pipewire-media-session  2) wireplumber
:: Repository chaotic-aur
3) pipewire-media-session-git  4) wireplumber-git

Enter a number (default=1): 2
:: There are 3 providers available for xxd:
:: Repository extra
1) gvim  2) vim
:: Repository chaotic-aur
3) xxd-standalone

Enter a number (default=1): 
looking for conflicting packages...
:: sweet-cursor-theme-git and xcursor-sweet are in conflict. Remove xcursor-sweet? [y/N] y
:: iptables-nft and iptables are in conflict. Remove iptables? [y/N] y
:: iptables-nft and ebtables are in conflict. Remove ebtables? [y/N] y
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: smbclient will be installed before its cifs-utils dependency
warning: dependency cycle detected:
warning: phonon-qt5-gstreamer will be installed before its phonon-qt5 dependency
warning: dependency cycle detected:
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
warning: dependency cycle detected:
warning: lib32-mesa will be installed before its lib32-libglvnd dependency
warning: dependency cycle detected:
warning: rubygems will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-irb will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-reline will be installed before its ruby dependency

Then it starts working, downloading stuff in parrallel. Takes ages still ends badly:

:: Proceed with installation? [Y/n]
:: Retrieving packages...
babl-0.1.90-1-x86_64                      442,4 KiB   161 KiB/s 00:03 [----------------------------------------] 100%
gloox-1.0.24-2-x86_64                     526,6 KiB  55,9 KiB/s 00:09 [----------------------------------------] 100%
gettext-0.21-2-x86_64                    1829,5 KiB   113 KiB/s 00:16 [----------------------------------------] 100%
bison-3.8.2-3-x86_64                      769,7 KiB  92,5 KiB/s 00:08 [----------------------------------------] 100%
curl-7.81.0-3-x86_64                     1122,1 KiB  56,0 KiB/s 00:20 [----------------------------------------] 100%
libisl-0.24-3-x86_64                     1510,9 KiB  34,0 KiB/s 00:44 [----------------------------------------] 100%
wireplumber-0.4.8-1-x86_64                381,6 KiB  43,1 KiB/s 00:09 [----------------------------------------] 100%
fwupd-1.7.6-1-x86_64                        4,2 MiB  83,0 KiB/s 00:52 [----------------------------------------] 100%
goverlay-git-0.8.r1.g8e8af0d-1-x86_64       3,8 MiB   483 KiB/s 00:08 [----------------------------------------] 100%
libcurl-compat-7.81.0-3-x86_64            268,6 KiB  32,8 KiB/s 00:08 [----------------------------------------] 100%
libcurl-gnutls-7.81.0-3-x86_64            282,7 KiB  37,9 KiB/s 00:07 [----------------------------------------] 100%
gegl-0.4.36-1-x86_64                        3,0 MiB  69,6 KiB/s 00:44 [----------------------------------------] 100%
gcc-libs-11.2.0-4-x86_64                   29,5 MiB   365 KiB/s 01:23 [----------------------------------------] 100%
smartmontools-7.3-1-x86_64                580,6 KiB  71,2 KiB/s 00:08 [----------------------------------------] 100%
gcc-11.2.0-4-x86_64                        28,4 MiB   388 KiB/s 01:15 [----------------------------------------] 100%
linux-zen-headers-5.16.11.zen1-2-x86_64    26,9 MiB  99,1 KiB/s 04:38 [----------------------------------------] 100%
lib32-gcc-libs-11.2.0-4-x86_64             27,0 MiB  56,2 KiB/s 08:12 [----------------------------------------] 100%
linux-zen-5.16.11.zen1-2-x86_64           160,0 MiB   245 KiB/s 11:10 [----------------------------------------] 100%
Total (18/18)                             296,3 MiB   386 KiB/s 13:06 [----------------------------------------] 100%
error: failed retrieving file 'gcc-libs-11.2.0-4-x86_64.pkg.tar.zst' from arch.yourlabs.org : Operation too slow. Lessthan 1 bytes/sec transferred the last 10 seconds
error: failed retrieving file 'gcc-11.2.0-4-x86_64.pkg.tar.zst' from arch.yourlabs.org : Operation too slow. Less than1 bytes/sec transferred the last 10 seconds
(1230/1230) checking keys in keyring                                   [----------------------------------------] 100%
downloading required keys...
:: Import PGP key FAF4946E8D60D074, "Chaotic-AUR Team <[email protected]>"? [Y/n]
error: key "FAF4946E8D60D074" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
garuda-inxi   -  command not found and I can't install it because the Wild Bear Node keys  can't be added i.e. the original problem

Without it, you will not receive any help from the Garuda team or your topic is likely to be closed without notice.

Before you open a new help request, read relevant sections of the Arch and Garuda wiki.
Thoroughly search your issue and any error messages in the forum and on the web.

Report everything you have already attempted to solve your problem.

Run update remote fix in terminal.

And also, please use the search feature in the future.

5 Likes

Hi there, welcome to the community.
First try garuda-update command or update command in terminal, or command by @ TNE. If that doesn't work

You can post output of inxi -Faz instead.

Also, when did you updated your pc last time?

2 Likes

update isn't installed and I can't install it without fixing the keyring.

Try this:

sudo bash -c ". <(wget -qO- https://gitlab.com/garuda-linux/themes-and-settings/settings/garuda-common-settings/-/snippets/2147440/raw/main/remote-update)"
5 Likes

garuda-update is not installed.

inxi -Faz
System:    Kernel: 5.12.11-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=e8afabb7-2035-4f3d-9517-d4c56593050a rw 
[email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
systemd.unified_cgroup_hierarchy=1 loglevel=3 
Desktop: KDE Plasma 5.22.1 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: BESSTAR TECH LIMITED product: X400 v: N/A serial: <filter>
Mobo: BESSTAR TECH model: N/A serial: <filter> UEFI: American Megatrends v: ATB15011 date: 01/12/2021
CPU:       Info: 6-Core model: AMD Ryzen 5 PRO 4650G with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600106 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 88634
Speed: 3055 MHz min/max: 1400/3700 MHz boost: enabled Core speeds (MHz): 1: 3055 2: 3710 3: 2994
4: 3349 5: 2993 6: 2995 7: 2997 8: 2996 9: 3407 10: 2992 11: 2994 12: 2993
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir driver: amdgpu v: kernel bus-ID: 05:00.0
chip-ID: 1002:1636 class-ID: 0300
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") s-diag: 1165mm (45.9")
Monitor-1: HDMI-A-0 res: 3840x2160 hz: 60 dpi: 140 size: 698x393mm (27.5x15.5") diag: 801mm (31.5")
OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.12.11-zen1-1-zen LLVM 12.0.0) v: 4.6 Mesa 21.1.2
direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus-ID: 05:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A
alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Realtek driver: snd_hda_intel
v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.12.11-zen1-1-zen running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.30 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: f000
bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: e000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 bus-ID: 04:00.0 chip-ID: 8086:2723
class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-4: Realtek RTL88x2bu [AC1200 Techkey] type: USB driver: rtl88x2bu bus-ID: 3-2.1:4
chip-ID: 0bda:b812 class-ID: 0000 serial: <filter>
IF: wlp5s0f4u2u1 state: up mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-1:2 chip-ID: 8087:0029
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 105.18 GiB (22.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: OM8PDP3512B-A01 size: 476.94 GiB block-size:
physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: EDFK0S03
scheme: GPT
Partition: ID-1: / raw-size: 223.84 GiB size: 223.84 GiB (100.00%) used: 105.15 GiB (47.0%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 33.2 MiB (34.5%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 223.84 GiB size: 223.84 GiB (100.00%) used: 105.15 GiB (47.0%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 223.84 GiB size: 223.84 GiB (100.00%) used: 105.15 GiB (47.0%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 223.84 GiB size: 223.84 GiB (100.00%) used: 105.15 GiB (47.0%) fs: btrfs
dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 37.9 C mobo: 0 C gpu: amdgpu temp: 34.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 339 Uptime: 5h 05m wakeups: 8 Memory: 15.11 GiB used: 6.42 GiB (42.5%) Init: systemd v: 248
tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.0 Packages: pacman: 1751 lib: 549 Shell: fish
v: 3.2.2 running-in: konsole inxi: 3.3.04

I haven't updated in quite a few months :face_with_open_eyes_and_hand_over_mouth:

Filtering in the forum by "5.12.11-zen1-1-zen", all posts are from June 2021 :slight_smile:
Apart from the remote fix, it will be a challenging update :astonished:

1 Like

Cheers. That seems to have made a lot of changes but ultimately failed with this:

error: garuda-hotfixes: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/garuda-hotfixes-1.1.1-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

let me know if you want more of the multi-page output.

Wow, maybe try again
sudo pacman -Sy archlinux-keyring chaotic-keyring

1 Like

Can you please upload the entire log somewhere? You don't leave as much except guesswork here...

2 Likes

Yay, that worked. I'll try doing the system update now. (as it might take a while I thought you'd enjoy sharing some good news, Thx)

Bad new I'm afraid.
There were many messages like this:

:: File /var/cache/pacman/pkg/librewolf-extension-plasma-integration-1.8.1-2-any.pkg.tar.zst is corrupted (invalid or
corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: minecraft-launcher: signature from "Nico Jensch (Chaotic-AUR) <[email protected]>" is invalid
:: File /var/cache/pacman/pkg/minecraft-launcher-928-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (
PGP signature)).
Do you want to delete it? [Y/n]

So i answer Yes to each one but ultimately it failed with this unhelpful message (no package name):

error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Thanks for helping me with this. I'll post

the entire log

if you can point me to say how you want it. Don't think you want cut 'n paste do you?

Strange. I can only think to try with thegaruda-update package.
I would suggest:

sudo pacman -S garuda-update
garuda-update
3 Likes

Yay that seems to have worked!
There were a few warning messages but untimately it has finished with:

System updated! 🐧

I guess I need to reboot now, just to be sure.

Many Thanks Filo for you helpful support. I'm unsure which post to mark as the solution - I guess it's a combination of all the steps together? Which do you suggest?

1 Like

Yes, sure, reboot and let's cross fingers :wink:
The credit in the end goes to @TNE who created these fantastic scripts.

3 Likes

Ehh. Well if I wanted to be pedantic I'd point out that

  1. pacman -Sy archlinux-keyring chaotic-keyring was already executed by Key xxxxx could not ne looked up remotely - #5 by filo
  2. garuda-update was already installed and ran by the same command
  3. The update remote fix command was supposed to execute the same command, but shorter, but your system didn't have garuda-update installed yet so that would never work.

So in the end it's mostly that script, combined with running the update command a couple of times to delete any corrupt packages that just happened to exist. So I'd suggest marking #5 as the answer :slight_smile:

4 Likes

Cheers Filo.
Reboot done and everything seems to be working fine, perhaps even a little faster!

Thanks for hanging in there with me.

You're welcome, and what's more, welcome to the forum!!!

5 Likes

And update weekly :smiley:

5 Likes

I have to study a little bit more the remote-fix!
:smiley:

1 Like