Kernel shift

Hello all, again my kernel "problems"
So i want to shift or make default a kernel -might be a new one-
Install is not an issue... Very simple with Garuda assist.
As said so time ago, i just want the chosen one to be default at boot.
I found : >"mhwd-kernel -li" more or less Manjaro, or "Grub customiser" Ubuntu like
The aim is just to organise kernels & choose wich one will be default!
No erasing...Any ideas for my simple mind ? I had clues but couldnt work it out !
Best
Fred
(please excuse my poor English)

Do this help you at all?

2 Likes

Use this at your peril.

Not recommended, often creates major problems that are not easily corrected.

You could also test this solution:

3 Likes

Bonjour @tbg , so once again i modyfied "nano /etc/default/grub"
...

GRUB boot loader configuration

GRUB_DEFAULT="2" <-- instead of "0"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="Garuda"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cg>
GRUB_CMDLINE_LINUX="lsm=lockdown,yama,apparmor,bpf"
...

Uncomment to make GRUB remember the last selection. This requires

GRUB_DEFAULT="2" <--instead of "0"
#GRUB_SAVEDEFAULT="false" <-- I added #

I not using "Grub customiser for it's not "working"...
For the time beeing i have
uname -sr
Linux 5.11.11-144-tkg-bmq
&
mhwd-kernel -li
Currently running: 5.11.11-144-tkg-bmq (linux-tkg-bmq-zen2)
The following kernels are installed in your system:
local/linux-lts 5.10.27-1
local/linux-tkg-bmq-zen2 5.11.11-144
local/linux-tkg-muqss-zen 5.11.11-144
local/linux-hardened 5.11.11.hardened1-1
local/linux-zen 5.11.11.zen1-1

Thanks @Stroke_Finger i remember the post but i did not find out where & what to write as specific Kernel !

Overall its not a uge trouble, i just have to choose at boot time !

So now, update-grub and reboot

Best & many thanks

F.

update-grub
/etc/default/grub: ligne 1: ..# : commande introuvable
[root@fwa ~]# grub-mkconfig -o /boot/grub/grub.cfg

/etc/default/grub: ligne 1: ..# : commande introuvable

Deepl might help ! ~command not found !

grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/garuda/theme.txt
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-tkg-muqss-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-muqss-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-muqss-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-tkg-bmq-zen2
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-bmq-zen2.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-bmq-zen2-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot: initramfs-linux-lts-fallback.img
Found linux image: /boot/vmlinuz-linux-hardened
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-hardened.img
Found fallback initrd image(s) in /boot: initramfs-linux-hardened-fallback.img
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-tkg-muqss-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-muqss-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-muqss-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-tkg-bmq-zen2
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-bmq-zen2.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-bmq-zen2-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot: initramfs-linux-lts-fallback.img
Found linux image: /boot/vmlinuz-linux-hardened
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-hardened.img
Found fallback initrd image(s) in /boot: initramfs-linux-hardened-fallback.img
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-tkg-muqss-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-muqss-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-muqss-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-tkg-bmq-zen2
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-bmq-zen2.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-bmq-zen2-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot: initramfs-linux-lts-fallback.img
Found linux image: /boot/vmlinuz-linux-hardened
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-hardened.img
Found fallback initrd image(s) in /boot: initramfs-linux-hardened-fallback.img
Found linux image: /boot/vmlinuz-linux-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-tkg-muqss-zen
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-muqss-zen.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-muqss-zen-fallback.img
Found linux image: /boot/vmlinuz-linux-tkg-bmq-zen2
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-tkg-bmq-zen2.img
Found fallback initrd image(s) in /boot: initramfs-linux-tkg-bmq-zen2-fallback.img
Found linux image: /boot/vmlinuz-linux-lts
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-lts.img
Found fallback initrd image(s) in /boot: initramfs-linux-lts-fallback.img
Found linux image: /boot/vmlinuz-linux-hardened
Found initrd image: /boot/intel-ucode.img /boot/initramfs-linux-hardened.img
Found fallback initrd image(s) in /boot: initramfs-linux-hardened-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
Detecting snapshots ...
Info: Separate boot partition not detected
Found snapshot: 2021-04-06 07:41:33 | timeshift-btrfs/snapshots/2021-04-06_07-41-33/@
Found snapshot: 2021-04-06 05:41:10 | timeshift-btrfs/snapshots/2021-04-06_05-41-10/@
Found snapshot: 2021-04-05 19:59:47 | timeshift-btrfs/snapshots/2021-04-05_19-59-47/@
Found snapshot: 2021-04-05 18:24:29 | timeshift-btrfs/snapshots/2021-04-05_18-24-29/@
Found snapshot: 2021-04-05 17:24:22 | timeshift-btrfs/snapshots/2021-04-05_17-24-22/@
Found snapshot: 2021-04-05 16:05:13 | timeshift-btrfs/snapshots/2021-04-05_16-05-13/@
Found snapshot: 2021-04-05 15:00:02 | timeshift-btrfs/snapshots/2021-04-05_15-00-02/@
Found snapshot: 2021-04-01 21:00:02 | timeshift-btrfs/snapshots/2021-04-01_21-00-02/@
Found 8 snapshot(s)
erreur : syntax error.
erreur : Incorrect command.
erreur : syntax error.
Erreur de syntaxe à la ligne 421
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub/grub.cfg.new file attached.


Thanks, i think @smoky answered...As you very well know, its not a problem !
Just a choise...
Cheers
F.

In order to fix the order it's best not to mess with Grub itself or use grub customizer(which is basically just bricks everything).

The best solution I've found is reinstalling all your kernels in order. Using mhwd, uninstall all kernels(in this state, don't reboot until you've reinstalled a kernel) and then reinstall with them with the one you want to be default first.

I think you could also just remove every kernel besides the one you want as default run grub-mkconfig and then install the additional kernels again.

2 Likes

Thanks a lot, i just wonder:
is there a simple command to just make current kernel the default one, so i don't need to
decide each boot or use snapshots like i did "before"...
And, last but not least, how about taking snapshot of actual state & simply boot on that and THEN
add chosen kernels ??? Oviously the one in use will not be added.
I understand >Grub-manager< IS an open door to major problems...
Nice day
F.

No, there is no such one command.
Take responsibility of your choice to install a program that can change and potentially break your system (grub-customizer).
All required info to help you fix your issue are already posted in this and other forum topics and more info exist at Archwiki.

If you can't make it, reinstall.
Maybe ask a friend with more experience to help you.

3 Likes

Thanks @petsam , understood !
I'm not using grub-customiser even if it seems tempting !
And reinstall is not yet an option... All of you knows why.
Again, thanks
I do have some searches & posts reading to do.
Fred.

1 Like

Sorry to bother..I had big big trouble & reinstall seemed to be the only option!
I just booted on fresh iso usb stick and "repair" grub thru Garuda assistant.
Back on tracks & no reinstall.
I'll try not to mess to much with kernels !
F.

I did it that way and ...no problemo !
Just booting with the kernel i want..
To simple
mhwd-kernel -li
Currently running: 5.11.11-144-tkg-MuQSS (linux-tkg-muqss-cascadelake)
The following kernels are installed in your system:
local/linux-lts 5.10.28-1
local/linux-tkg-bmq-zen2 5.11.11-144
local/linux-tkg-muqss-cascadelake 5.11.11-144
I press start & it rolls (for now !), nothing to do !
Best
F.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.