Kernel problem

Hi @all,

I'm using an hp probook 845 G9 with Ryzen 5 pro 6650u CPU (Radeon iGpu).
When I want to shutdown the PC by using GUI, the notebook reboots.
Same problem with the shutdown now command in the terminal.
The only way to shutdown the PC is to select it from Grub.

After searching on forums, it seems to be a kernel problem, so I tried downloading and applying the Zen3 fixed kernel (linux-amd-znver3-6.4.v.8-1 + headers) thanks to Garuda Setup assistant, but I've got NO Wifi AND it doesn't shutdown as well, only reboot...

I'm new to arch, so be forgiving please :wink:
Can you help me please to get my system working well (shutdown working, and no missing drivers) ?

Have a nice day


Kernel: 6.4.8-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=a69746de-3731-4dcb-93b6-53988d380f12 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: HP product: HP EliteBook 845 14 inch G9 Notebook PC
v: N/A serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: HP model: 8990 v: KBC Version 09.4A.00 serial: <superuser required>
UEFI: HP v: U82 Ver. 01.05.01 date: 03/22/2023
ID-1: BAT0 charge: 29.3 Wh (57.1%) condition: 51.3/51.3 Wh (100.0%)
power: 10.0 W volts: 11.5 min: 11.6 model: Hewlett-Packard Primary
type: Li-ion serial: <filter> status: discharging cycles: 6
Info: model: AMD Ryzen 5 PRO 6650U with Radeon Graphics bits: 64
type: MT MCP arch: Zen 3+ gen: 4 level: v3 note: check built: 2022
process: TSMC n6 (7nm) family: 0x19 (25) model-id: 0x44 (68) stepping: 1
microcode: 0xA404102
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1583 high: 1600 min/max: 1600/4582 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1600 2: 1600
3: 1600 4: 1600 5: 1600 6: 1600 7: 1600 8: 1600 9: 1600 10: 1406 11: 1600
12: 1600 bogomips: 69473
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Device-1: AMD Rembrandt [Radeon 680M] vendor: Hewlett-Packard driver: amdgpu
v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,
DP-2, DP-3, DP-4, DP-5, DP-6, DP-7, HDMI-A-1 bus-ID: 63:00.0
chip-ID: 1002:1681 class-ID: 0300 temp: 49.0 C
Device-2: Chicony HP 5MP Camera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 04f2:b738
class-ID: fe01 serial: <filter>
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
s-diag: 599mm (23.57")
Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x1435 built: 2021
res: 1920x1200 hz: 60 dpi: 162 gamma: 1.2 size: 301x188mm (11.85x7.4")
diag: 355mm (14") ratio: 16:10 modes: max: 1920x1200 min: 640x480
API: OpenGL v: 4.6 Mesa 23.1.5 renderer: AMD Radeon Graphics (rembrandt
LLVM 15.0.7 DRM 3.52 6.4.8-zen1-1-zen) direct-render: Yes
Device-1: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 63:00.1
chip-ID: 1002:1640 class-ID: 0403
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
lanes: 16 bus-ID: 63:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 63:00.6 chip-ID: 1022:15e3 class-ID: 0403
API: ALSA v: k6.4.8-zen1-1-zen status: kernel-api tools: N/A
Server-1: PipeWire v: 0.3.76 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek vendor: Hewlett-Packard driver: rtw89_8852be v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 6000 bus-ID: 01:00.0
chip-ID: 10ec:b852 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3:2 chip-ID: 0bda:b85c
class-ID: e001 serial: <filter>
Report: bt-adapter ID: hci0 rfk-id: 0 state: down
bt-service: enabled,running rfk-block: hardware: no software: yes
address: <filter>
Local Storage: total: 931.51 GiB used: 11.66 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SNV2S1000G
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: ELFK1N.1 temp: 40.9 C
scheme: GPT
ID-1: / raw-size: 224.61 GiB size: 224.61 GiB (100.00%)
used: 11.59 GiB (5.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 71.9 MiB (74.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 224.61 GiB size: 224.61 GiB (100.00%)
used: 11.59 GiB (5.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 224.61 GiB size: 224.61 GiB (100.00%)
used: 11.59 GiB (5.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 224.61 GiB size: 224.61 GiB (100.00%)
used: 11.59 GiB (5.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 30.67 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 53.1 C mobo: N/A gpu: amdgpu temp: 49.0 C
Fan Speeds (RPM): N/A
Processes: 312 Uptime: 15m wakeups: 41039 Memory: total: 32 GiB note: est.
available: 30.67 GiB used: 3.09 GiB (10.1%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1171 libs: 324 tools: octopi,pamac,paru Shell: fish
v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.28
Garuda (2.6.16-1):
System install date:     2023-06-26
Last full system update: 2023-08-06
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:

That’s a good idea, but you switched to a kernel which is using the same kernel version as the one that isn’t working. Try instead switching to the LTS kernel, which is on 6.1.


Thank you very much @BluishHumility for your help !
So I uninstalled the zen3 patched kernel, and I installed the linux-lts 6.1 kernel from "Garuda Settings Manager / Kernels" and I selected it from the Grub.
I then can shutdown properly but Wifi isn't working. I don't know if there are other drivers missing (because I only master Windows sorry, I don't know in Garuda what's like the Device Manager).

So if I understand clearly I should stay with this lts 6.1 kernel and install the missing network driver (and others missing), and I should test the default kernel from time to time if the issue is solved ? Or do you have a better idea ?

Thanks for the answer you gave me @BluishHumility I greatly appreciated :slight_smile:

Yes, that is probably your best bet. For the network driver, try the one filo suggested in this post:

git clone
cd rtw89-dkms-git
makepkg -sri

Thank you very much for your answer,
I'm glad there's people like you who are pleased to help noobies like me

Have a good day :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.