Kernel Panic on linux-zen: ZSTD corrupt

Hey there,
since like two days ago (I updated that evening), trying to boot into linux-zen results in a kernel panic for me:

The only similar and interestingly somewhat recent forum post regarding this was in the mint forums: kernel panic - Linux Mint Forums

Linux-lts works as expected - Does anyone have an idea what happened here?

Thanks!

System:
  Kernel: 5.15.74-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: root=PARTUUID=4f58220f-2b24-374a-96c3-7d9c60290781 rw
    add_efi_memmap [email protected] [email protected]\boot\amd-ucode.img
    rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 sysrq_always_enabled=1
    iommu=soft initrd=\@\boot\initramfs-linux-lts.img
  Desktop: wayfire v: 0.8.0-c3dac7ee info: waybar vt: 1 dm: greetd
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: AX370-Gaming 3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: AX370-Gaming 3-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F50a
    date: 11/27/2019
CPU:
  Info: model: AMD Ryzen 5 2600X bits: 64 type: MT MCP arch: Zen+ gen: 2
    level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
    model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 3839 high: 4172 min/max: 2200/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3383 2: 2825
    3: 4137 4: 2849 5: 4140 6: 4088 7: 3975 8: 4079 9: 4146 10: 4116 11: 4160
    12: 4172 bogomips: 86225
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Baffin [Radeon RX 550 640SP / 560/560X] vendor: ASUSTeK
    driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm
    built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 8 ports:
    active: DVI-D-1,HDMI-A-1 empty: DP-1 bus-ID: 08:00.0 chip-ID: 1002:67ff
    class-ID: 0300 temp: 42.0 C
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-1:2 chip-ID: 046d:0825 class-ID: 0102 serial: <filter>
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.4
    compositor: wayfire v: 0.8.0-c3dac7ee driver: X: loaded: amdgpu
    unloaded: modesetting alternate: fbdev,vesa dri: radeonsi gpu: amdgpu
    d-rect: 3600x1200 display-ID: 1
  Monitor-1: DVI-D-1 pos: right res: 1920x1200 size: N/A modes: N/A
  Monitor-2: HDMI-A-1 pos: primary,left res: 1680x1050 size: N/A modes: N/A
  OpenGL: renderer: AMD Radeon RX 560 Series (polaris11 LLVM 14.0.6 DRM
    3.42 5.15.74-1-lts) v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
  Device-1: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
    vendor: ASUSTeK driver: snd_hda_intel bus-ID: 1-1:2 v: kernel
    chip-ID: 046d:0825 pcie: gen: 3 class-ID: 0102 speed: 8 GT/s
    serial: <filter> lanes: 8 bus-ID: 08:00.1 chip-ID: 1002:aae0
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Device-4: C-Media USB Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4:5 chip-ID: 0d8c:9700
    class-ID: 0300 serial: <filter>
  Sound API: ALSA v: k5.15.74-1-lts running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Broadcom BCM20702A0 Bluetooth 4.0 type: USB driver: btusb v: 0.8
    bus-ID: 3-3.1:6 chip-ID: 0a5c:21e8 class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.96 TiB used: 1.1 TiB (37.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A82 scheme: GPT
Partition:
  ID-1: / raw-size: 195.03 GiB size: 195.03 GiB (100.00%) used: 88.52 GiB
    (45.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%) used: 18.8 MiB
    (6.2%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  ID-3: /home raw-size: 736.18 GiB size: 736.18 GiB (100.00%) used: 153.71
    GiB (20.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 195.03 GiB size: 195.03 GiB (100.00%) used: 88.52
    GiB (45.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
  ID-5: /var/tmp raw-size: 195.03 GiB size: 195.03 GiB (100.00%) used: 88.52
    GiB (45.4%) fs: btrfs dev: /dev/sda1 maj-min: 8:1
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.3 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 48.5 C mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1437
Info:
  Processes: 342 Uptime: 5m wakeups: 0 Memory: 31.3 GiB used: 4.22 GiB
  (13.5%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: dpkg pkgs: 0 pm: pacman
  pkgs: 2121 libs: 512 tools: paru pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  running-in: kitty inxi: 3.3.22
Garuda (2.6.9-1):
  System install date:     2021-12-28
  Last full system update: 2022-10-26
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:            shadow.service

Make sure your system is fully updated and then try rebuilding the initramfs.

sudo mkinitcpio -p linux-zen

6 Likes

So much to learn! Rebuilding the initramfs did it! Thank you so much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.