Kernel freezing/restarting issue

Linux-zen has a weird bug where it restarts and linux-tkg-bmq has a different but similar bug where it freezes after being afk for a while. has anyone experienced this? i didnt have this issue in linux zen kernel 5.9.11. from 5.9.12 onward on both kernels i have these issues. Could you suggest me an alternate kernel or some quick fix?

You know, more details, more help, your father's PC?
Your PC?
Which DE?
GNOME? :smiley:

inxi -Fxxxza

and so on.

And here work on 2008 and 2012 PC on i3 and KDE everything fine.
System: Kernel: 5.9.12-97-tkg-bmq x86_64 bits: 64 compiler: gcc v: 10.2.0

It is my pc. and it is gnome.i didnt have similar issues before.

System:    Kernel: 5.9.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
           root=UUID=4f6fdcfa-53f2-4eaa-b404-0bd0bfa378cb rw rd.udev.log_priority=3
           vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           resume=UUID=ca128974-163e-48d5-869a-fde2f887a0bd loglevel=3
           Desktop: GNOME 3.38.1 tk: GTK 3.24.24 wm: gnome-shell dm: LightDM 1.30.0
           Distro: Garuda Linux
Machine:   Type: Desktop System: Gigabyte product: B450 AORUS PRO v: N/A serial: <filter>
           Mobo: Gigabyte model: B450 AORUS PRO-CF v: x.x serial: <filter>
           UEFI [Legacy]: American Megatrends v: F50 date: 11/27/2019
CPU:       Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen family: 17 (23)
           model-id: 1 stepping: 1 microcode: 8001138 L2 cache: 3072 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76647
           Speed: 3230 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 1: 3230
           2: 3097 3: 2716 4: 3306 5: 3104 6: 2880 7: 2874 8: 3250 9: 3067 10: 2892 11: 3242
           12: 3352
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: Tul
           driver: amdgpu v: kernel bus ID: 07:00.0 chip ID: 1002:67df
           Display: x11 server: X.Org 1.20.10 compositor: gnome-shell driver: amdgpu,ati
           unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
           s-diag: 582mm (22.9")
           Monitor-1: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 102 size: 476x267mm (18.7x10.5")
           diag: 546mm (21.5")
           OpenGL: renderer: AMD Radeon RX 470 Graphics (POLARIS10 DRM 3.39.0 5.9.12-zen1-1-zen
Processes: 360 Uptime: 21m wakeups: 0 Memory: 15.64 GiB used: 4.78 GiB (30.6%)
           Init: systemd v: 247 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 1759 pacman: 1747
           lib: 550 flatpak: 7 snap: 5 Shell: fish v: 3.1.2 running in: alacritty inxi: 3.1.09

USe KDE or something else, you know, its buggy this GNOME today :slight_smile:

im too lazy to switch it on my main. ill lose all my logins and apps and ill have to reinstall all and again get used to it. maybe when i get laptop next year ill main dragonized

Then you must live with freezes, I think.

Use Bitwarden save your app settings and it is not much work :wink:

Im a different level of lazy

1 Like

You haven't exactly posted a lot of information on which kernels you've tried. The first thing to do is test a bunch of different kernels if you don't want to test a different desktop. Always keep at least 2 kernels installed for safety. You always want another kernel installed to be able to fall back to in case of severe problems.

Be sure to post a full listing of all kernels you've tested and any differences you encountered with each.

Also, is your bios up to date?

Another thing to try is to test the fallback version of each installed kernel from the grub start up menu.

1 Like

I've tested the zen 5.9.11 and 12 and same versions for tkg. I didn't have this problem with 5.9.10.

Try the linux-lts kernel, then the real time.

1 Like

I had a similar problem with the linux-tkg-bmq kernel on my HP Envy (Ryzen 2700) laptop. Worked like a charm until those new kernels came and then it would freeze up at various times. Now I am running linux-zen again and it seems to be back to normal.

Weird. Now the zen kernel doesn't work at all for me lol.