[KERNEL BUG] - mt7921e - Wifi not working - (another ASUS Vivobook}

In an non-working session run:

sudo ip link set dev wlo1 up; sudo systemctl restart NetworkManager

In an non-working session run:

rfkill list

Please post input and output of both commands.

Have you done this ^^^


I've tried the mainline kernel and here's what happened:
When I first selected it, it froze mid boot (during the spinny circle screen) and the caps lock indicator started to blink like on zen. On second boot it booted up normally with wifi working. I'm pretty sure this is what happens with zen too. I guess this saves one boot...? As for the new commands you have I'll send them a bit later since it takes a while for this problem to start again

Did you type the first command correctly? In a non working session I got

Cannot find device wlo1

Your caps lock flashing during a failed boot attempt means that your system experienced kernel panic.

Have you applied any bios updates available for your laptop? Be sure to check again as perhaps an update has been released recently.

Are you dual booting with Windows? If so, be sure that wifi power saving is disabled in the device manager's advanced properties window for your wifi adapter.

I just noticed this in your garuda-inxi output:

Failed units:            systemd-networkd-wait-online.service systemd-oomd.socket

I think you should disable/mask systemd-networkd-wait-online.serviceand systemd-oomd.socket systemd-oomd.service.


There are no BIOS updates for my laptop and I'm not dual booting with windows. I've disabled the two services you've mentioned and I'll let you know if they make a difference.

Wifi/Networking fix for broken network adapters coming in the next round of kernel releases, including stable.

Noted here.


Thanks for the link Rodney, but I'm not sure that revision would affect this Ralink adapter. This one really has never had proper kernel support, it's not so much that it has been broken by a recent revision.


Okay it's been around two days and sadly the two commands from before didn't solve the problem. Should I wait for the wifi fix to come through the future kernel versions?

The new zen kernel came through for me yesterday and fixed the Qualcom/Ath9k network adapter issue, just curious, have you tried a 'garuda-update' and a reboot today?


I'm really not a fan of the ASUS Vivobook line of laptops.

It is like the modern-day Sony Vaio, remember that line?

Just like the Vaio line, Vivobook is so proprietary. In fact, I rather choose to go Apple than purchase a Vivobook.

1 Like

I'll try that soon and let you know. Is there a list of kernels that have adapted this change?

Laptop was given as a gift lol. But I'll keep this in mind if ever I get another machine or something.

Okay so it's been almost two weeks and the wifi has been more consistent. I guess it's due to the aforementioned kernel fix. It's not completely fixed but it's way better now.

1 Like