Kernel 5.19 can't see sound device and bluetooth

Hello!

Yesterday I have updated my system, linux-zen kernel has changed from 5.18.16 to 5.19.1
After rebooting my bluetooth mouse didn't work, there were no bluetooth adapter in the system. Also, there were no sound devices at all. When I have restored my system from snapshot, everything worked properly. After re-updating the result was the same - no bluetooth and audio device. Linux kernel (not-zen) can't see bluetooth and sound devices either.
Linux-lts kernel works fine.
What's wrong with new kernel and my system? What can I do?

garuda-inxi output:

System:
  Kernel: 5.19.1-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=2617e99d-fdce-4db0-be58-080633575b74
    rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: HUAWEI product: KPL-W0X v: M1B serial: <superuser required>
  Mobo: HUAWEI model: KPL-W0X-PCB v: M1B serial: <superuser required> UEFI: HUAWEI v: 1.24
    date: 04/11/2022
Battery:
  ID-1: BAT1 charge: 53.3 Wh (100.0%) condition: 53.3/56.3 Wh (94.6%) volts: 8.1 min: 7.6
    model: DYNAPACK HB4593R1ECW type: Li-ion serial: <filter> status: not charging cycles: 104
CPU:
  Info: model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen
    built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 0x11 (17) stepping: 0
    microcode: 0x8101007
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache: L1: 384 KiB desc: d-4x32
    KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2620 high: 3286 min/max: 1600/2000 boost: enabled scaling:
    driver: acpi-cpufreq governor: performance cores: 1: 2633 2: 2000 3: 2628 4: 2626 5: 2635
    6: 2000 7: 3286 8: 3157 bogomips: 31940
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series] vendor: Huawei
    driver: amdgpu v: kernel arch: GCN-5 code: Vega process: GF 14nm built: 2017-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 02:00.0
    chip-ID: 1002:15dd class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22") s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x14d4 built: 2016 res: 1920x1080 hz: 60
    dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.6 DRM 3.47 5.19.1-zen1-1-zen)
    v: 4.6 Mesa 22.1.6 direct render: Yes
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Huawei driver: N/A
    alternate: snd_hda_intel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.1 chip-ID: 1002:15de
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Huawei driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x, snd_pci_acp6x, snd_acp_pci,
    snd_sof_amd_renoir pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Huawei driver: N/A alternate: snd_hda_intel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.1-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
Drives:
  Local Storage: total: 238.47 GiB used: 125.93 GiB (52.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: LITE-ON model: CV8-8E256 size: 238.47 GiB block-size:
    physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 402 scheme: GPT
Partition:
  ID-1: / raw-size: 188.36 GiB size: 188.36 GiB (100.00%) used: 125.89 GiB (66.8%) fs: btrfs
    dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 34.8 MiB (36.2%) fs: vfat
    dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 188.36 GiB size: 188.36 GiB (100.00%) used: 125.89 GiB (66.8%) fs: btrfs
    dev: /dev/sda5 maj-min: 8:5
  ID-4: /var/log raw-size: 188.36 GiB size: 188.36 GiB (100.00%) used: 125.89 GiB (66.8%)
    fs: btrfs dev: /dev/sda5 maj-min: 8:5
  ID-5: /var/tmp raw-size: 188.36 GiB size: 188.36 GiB (100.00%) used: 125.89 GiB (66.8%)
    fs: btrfs dev: /dev/sda5 maj-min: 8:5
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 6.68 GiB used: 2 MiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.9 C mobo: N/A gpu: amdgpu temp: 51.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 259 Uptime: 1m wakeups: 1 Memory: 6.68 GiB used: 2.34 GiB (35.1%) Init: systemd
  v: 251 default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6 Packages:
  pacman: 1649 lib: 470 Client: shell wrapper v: 5.1.16-release inxi: 3.3.20
Garuda (2.6.6-1):
  System install date:     2021-04-01
  Last full system update: 2022-08-15
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            bluetooth-autoconnect.service systemd-guest-user.service
1 Like

Welcome :slight_smile:

Quite pragmatically, take what works. :wink:

Report the problem to the kernel developers.

3 Likes

Hi there, welcome to the community !

This Network Card is having a lot of issues in recent kernel versions. See

https://bugzilla.kernel.org/buglist.cgi?quicksearch=intel%208265

So, it is an upstream bug in Linux Kernel, and not in Garuda Linux/ Zen Kernel. And as there are already so many different reports, it won't make any sense to add another, I guess.
Therefore, I would suggest you should use LTS kernel for the time being, and wait till it gets fixed.

5 Likes

Thank you!
I don't know if problems with this Network Card also affect audio devices...
Yes, I am using LTS kernel now. Hope my problem will be fixed soon.

1 Like

Thanks for suggesting the switch to the LTS kernel, it works for now!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.